Redirect to HD in a different sata port

Roon Core Machine

Win10, intel i5

Description of Issue

i had to change the sata port of the HD with my music library.
the drive letter has not changed (R: for roon)
but when i started roon i cannot find my music. i guess i have to redirect roon to the correct HD.

could you please tell me the steps i have to do, or tell me the pertinent KB page?

Roon app: Settings > Storage

It should show missing or removed location with an option to edit the location.

Click edit and select the new location.

Is there a reason why you changed the Sata port?


I had a problem with the HD with my library.
In the last month or so, it happend to jump to 100% usage.
As i’m not an expert, I’ve tried many of possible checks and “solutions” i could find on internet. With no success.
Clearly, this caused the core machine to “freeze” (not completely), and Roon to stop. Fortunately, it was not so frequent…
Another problem was that trying to copy music files to the HD did cause 100% usage, again.
And i could not even perform a HD chkdsk, as it almost immediately jumped to 100%.

So, just to exclude other possible causes… i’ve tried to connect the HD to another SATA port. And this has worked. The HD works fine, and i could perform a chkdsk, with no errors. So, it was not an HD problem…

Could it be a SATA problem? (driver? MB? controllers… who knows…). I don’t know
But i have connected to the previous port another HD (as all my sata ports are occupied) and on that HD at the moment i don’t see any problem, i could perform some file transfers, and a chkdsk, with no problems…

So, basically i hope the problem is temporarily solved, but i guess that it’s time to buy a new dedicated PC for roon. But that’s another story.

Good thinking!

Some boards have, common on gigabyte boards for example have Marvell and intel sata controllers. (I don’t recommend gigabyte, they are dropping Titan ridge Thunderbolt addin card support on a lot of their board via bios updates. Not cool! :face_with_symbols_over_mouth:Boo them!!) So it could be a controller issue, but usually there are more than 1 sata port on each controller. So it could be a bad port, bad cable.

Anyways, good thinking moving the drive to another port. Did you use the same sata cable? That would eliminate the cable if you did.

Glad you got it working. :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.