Release 2022.10


It took awhile due to ‘real life’ things, but here’s a new release.

Pretty modest release, here’s the changelog:

  • NEW: add suport for Raspberry Pi 3 A+
  • NEW: support for “multi-state” USB WiFi dongles
  • IMPROV: update base packages
  • IMPROV: bump Linux kernel
  • IMPROV: support native DSD on the Musical Fidelity M6x DAC

Oh, I promise the next release won’t take this long again :wink:

Regards Harry


Hello Harry

Does it require flashing or should it update after reboot?
I just rebooted and still on (0524).


Steven, this will take some hours until your RoPieee ‘sees’ the available update, depending on your location. In my case it sometimes has taken nearly a day. So just patiently wait until the RoPieee web interface shows the available update, then simply click on ‘update’… no need to reflash.

1 Like

Andreas, I appreciate this.
Thank you very much.

Harry - have an RPI 3B that is connected via i2s to a DIYINHK ESS 9018 K2M DAC board. Was working fine on the legacy Ropieee. I upgraded today - manually - to 2022.08 and all appeared to go smoothly except the DAC will not lock onto any signal.

I had set the Audio HAT dropdown to the nearest thing I could find to an ESS product - which was the Audiophonics I-Sabre ES90*8Q2M DAC option but no joy. The I-Sabre shows up as Connected to Core in Roon but will not lock on to a signal (my implementation has a screen that shows the sample rate when it locks on to an i2s signal and ‘No Lock’ otherwise). I tried the Allo Katana (which I believe was an ESS DAC) as well as the basic Raspberry Pi i2S but these two do not even show up in Roon.

The 2208.10 update showed up and i updated but still the DAC will not lock onto the signal from the Pi.

Finally, I notice that, with the I-Sabre selected, if I go to Device Setup in Roon it shows ‘I-Sabre…’ but asks to Identify This Device. Not sure its relevant but…

What am I missing?

Just updated to new version in the UK. Running on Raspberry pi 3B with Allo Boss tophat and all went splendidly - many thanks

Nice! I will give it a try this week because I could not get the previous version to work.

Well that was intresting. I got it to work. Seems the obvious choice (the Audiophonics I-Sabre HAT option) for an ESS Sabre 9018K2M DAC board is somewhat flawed. When that option is chosen with the legacy Ropieee 4.020 it would not work on all bit rates. My implementation allows access to a few of the Sabre DAC’s mode options and with a little fiddling I could get the Audiophonics HAT option to work but once the bit rate of the song changed the settings on the DAC had to be adjusted to get Lock and sound again. Not viable.

I tried the new 2022.10 and got the same issues/results. The solution was to use the Orchard Pecan Pi HAT option. Once that was chosen all worked as it should. Hopefully this may be of help to any 9018K2M users out there.

I’m away from home this week, but updated my RPi4 #2 to RoPieeeXL 2022.10 this afternoon with no issues. This is a RPi4 that I take with me and use my iPhone and 2 iPads for hotspot data feeding Dell XPS 15 laptop running Roon 2.0 and Audirvana 2.0. The RPi4 connects to my Dell by WIFI with USB out to Mojo 2 and Focal Clear headphones. Thanks again Harry for this great app.


Just finished update of the lastest 22/10 version, however using it as an NAA endpoint on an Allo USBridge Signature, I’ve discovered an issue of clocking, having observed an abnormal behavior when playing a DSD file coming from a PCM file, the bitrate is not switching to the correct auto rate and resulting in an accelerated and distorted sound.

This phenomenon is reproducible in the other way as well from DSD to PCM.

After some discussions with Jussi (HQPLAYER), he is suggesting to upgrade the NAA version to the lastest 4.2.5 one, therefore would it be possible to include it in the next RopeeeXL version upcoming?

Yep. I’ll take care of that.


Nice, but I will update when you add back Bluetooth support to Ropieee XL.

all pi’s showed an update was available but one. (They all updated just fine, but that one lone pi is still sitting at build 524 and no alert that it’s ready for a new one.)

No worries, as it works just fine, but curious.

Feedback, if you’re interested…

Screenshot 2022-11-10 at 11.17.25 AM

Yes, one of my Ropieee devices is stuck at 2022.08.1 as well.

Feedback: 4d2b642d9d41bb21


And just like that, an hour later, the update alert appeared.

We’re so impatient. :crazy_face:

And here too… :thinking:

haha. And so it goes.

Update went fine. All good. Carry on!

1 Like

Updated my two ROPIEEE XL’s without any issues, all works, also the one with DAC+ HAT
Thansk a lot!