Remote android app looses connection after closing app and restarting

Core Machine (Operating system/System info/Roon build number)
Windows 7.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Remote (android) does not detect core when closing and restarting Android app.

To allow connection, I just need to uncheck and recheck “accept connections from remote” in the core setup then the core is immediately detected…

Any idea?

Hi,

Your topic has been moved to the support section of the forum.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @PierreS,

Welcome to the forum!

Can you please provide some more details regarding your network setup? What is the model/manufacturer of your networking gear?

To clarify, the Core does not show up at all when this issue occurs?
Or do you try to connect and get an error message?
What Android device are you using?
Please provide model/OS version.

Hi Noris, thanks for your help.

I tried with different android phones or tablets and the “reconnect to core problem” does occur only with the huawei P30 pro. Other Androids worked flawlessly.

Another (much easier) way to fix it besides uncheck and recheck “accept remote” is to use the flight mode on the phone with wifi only (thus the mobile network is off, roon is working well and on the top of it, the phone is not ringing :slight_smile:

Regards
Pierre

Hi @PierreS,

That’s very strange that just the P30 is affected.
Have you tried reinstalling the Roon app on it?
Any VPNs active on the P30?

A post was merged into an existing topic: Remote Android devices can not not connect to Core

A post was split to a new topic: Remote Android devices can not not connect to Core

Maybe this has to do with the double Sim in the p30? When switching to flight mode with wifi, thus disconnecting the Sim card, it connects to roon core rapidly.
Sometimes the double Sim conflicts with MAC address filtering in the internet box. Also solved by going flight mode with wifi. It might be something similar here?

Hi @PierreS,

That’s a possibility — Knowing that Airplane Mode with WiFi works better is an interesting data point. We’re going to run this by our team at our next meeting and will follow up soon.

1 Like

Hi @PierreS,

I spoke to the team about your case and if the duel SIM is impacting your Mac address filtering, it can certainly impact Roon as well. If you are able to locate any network settings on the P30 that you can adjust that are related to the duel sim usage that help with the issue, do let us know.

1 Like

Radical solution today is flight mode, wifi only.
Sure I ll tell you if I discover a more subtle solution, more likely disactivating one Sim card. I did not push the tests as I can live with flight mode with wifi.

1 Like