Remote can't connect to Core

Hi @support

I have a Mac mini as core connected through PowerLan to my Netgear Nighthawk X500 Router. When I want to access to the Core via iPhone or iPad I can see the Mac mini but it is only with the status “initializing” and yellow. Sometimes (after rebooting the router or Mac mini) I can access to Roon via iPhone, but only for seconds before the connection collapse. Then it will not connect again. When my Mac mini is over WLAN, the connection works through the remote - but in this case I can´t find my Roon Ready loudspeakers, which is connected via LAN. Awkward :frowning:
All devices are in the same IP range!

I already subscribed and want to use Roon - but without remote this is really a pain!

Hi @SSK84,

We have often seen Powerline adapters cause issues in Roon, my first suggestion here would be what happens if you connect the Mac Mini directly to the router via Ethernet? Does everything work as expected then? I realize you may not to have this as the final configuration but even temporarily testing this way will give us a good data point and pinpoint the issue.

What is the model/manufacturer of your Roon Ready speakers? If they are on the same IP range and the same subnet (with no VLANs), they should be showing up in Roon. How are the speakers connected, are they also through the powerline extender?

– Noris

Hi Noris,

checked that with direct lan connection to my router: same behavior unfortunately. Is there something I need to configure in my router? I had to configure VLAN No. 7 in my router (which is applied to all ethernet ports and WLAN) in order to be able to connect to the internet via fiber modem. Could this affect this?

BR Selim

Hi @SSK84,

Yes, this could be a cause as Roon is designed to work on a single flat network without VLANs. If both Core and the iPhone are on the same VLAN you should be ok, but sometimes VLANs split up the network traffic in a strange way so this could be what’s happening here.

As for your router, I would double check that you have Multicast enabled and allowed to pass through the VLANs. Our Networking Best Practices Docs go into a bit more detail in this aspect, we have seen a few Netgear routers also need to disable the “Enable Smart Connect” option to work properly so I would check that aspect as well.

Please let me know if that helps!

Hi @noris

thanks for your guidance. I did the following steps to get the things work

  1. Checked if all ethernet ports and WLAN are in VLAN 7 (which was the case)
  2. I also deactivated “Smart Connect”
  3. I also (just for testing) deactivated all VLAN settings and rebooted / reconnected everything

Unfortunately same behavior :frowning:

Hi @SSK84,

Thanks for letting me know my suggestions didn’t resolve the issue. I believe the VLAN aspect might warrant a closer look. Do you by any chance have any “multicast” options for that VLAN? Or is there a “filter multicast” setting on your router? If so I would try toggling that off. A screenshot of your VLAN settings may also help identify the issue here.


Hi @noris ,

I just added some screenshots which could be interesting.
There is a “RIP Version” setting which is in Multicast (RIP_2M) - I also added the support description of the router manufacturer.

RIP = Routing Information Protocol
The ‘multicast’ here just denotes the method used to advertise the routing table to other routers.
You should disable RIP if you don’t need it (having multiple routers, with RIP enabled, in your home network).

I would untick the ‘Enable HT160’ option in ‘Advanced Wireless’ (at least while testing).

Make sure you use the newest version (build416) of Roon. If you have the option to enter the core’s ip-address, try to use ‘’ (this helped many users including myself).

1 Like


Thanks. I updated the version to 416!

I tried everything with no results :frowning: Sometimes the remote connects for a couple is seconds with very slow performance and then displays that the connection is slow/ broken.

Any ideas?

Now I tested again to disable VLAN to test it again. The first time it worked for ca. 15 seconds. Fast control of Roon app was possible for the first time - cool :slight_smile:
Then suddenly again the broken connection issue and the request to choose another Roon Core :frowning:

You can try to disable all the fancy WLAN-optimizations (beamforming, MU-MIMO, HT160).
Also, if possible, a test of the behaviour on the LAN-side, by using a Control other than your Core, would be great.

Disabling all the fancy stuff didn’t work :frowning:
I have no option to use another PC/MAC as control and the Mac mini as core yet…maybe some neighbor is kind enough…

Hi @SSK84,

Can you try to check “Disable IGMP Proxying” in your first screenshot to see if that has any effect?
I also read on a forum post (linked here) that NAT filtering may play a part in the issue here as well. Can you temporarily set that to Open to see if that changes anything with regards to the issue?

– Noris

Hi @noris

I appreciate your support (and long breath).
It connected one time (very slow and only for seconds) in order to have a bad connection and fail to pursue working.

Is there some general incompatibility with the XR500? Shouldn’t be but who knows…

Hi @SSK84,

No, I am not aware of incompatibility between Roon and the XR500. It looks like something is allowing the connection but then after a short amount of time it is being blocked.

Let’s take a look at the Core as our next step here. Can you double check to make sure that both Roon and RAATServer have been added as exceptions to your OSX firewall? You can use these instructions to check. Are you by any chance running any other firewall blocking software on the Core (such as McAFee, Bullguard, Little Snitch)?

We have seen these cause issues in the past and need to have Roon + RAATServer added to them as exceptions, the best way to see if these are the ones causing issues here would be to temporarily disable them if you have such applications. Can you let me know if this is possible?

– Noris

Hi @Noris,

I deactivated Firewall for testing - didn’t work.
Roon and RAAT is on the exception list (was there before).
I don’t use any firewall software or antivirus solution.

Hi @noris,

I just lost patience with that topic and ordered a AVM Fritz Box 7590. It works OUT OF THE BOX! This is really cool! I didn’t need to configure a VLAN for my Fiber Connection. What an easy solution. Spend hours on that. The XR500 is gone for good! It was also crappy with my Laserprinter (WLAN) and I now think that this is an usual issue with that router…


Hi @SSK84,

Glad to hear that using another router has resolved this issue! This is certainly strange as I am not aware of any compatibility issues, but thanks for letting me know that it was the router, I will consult with our technical team to take a closer look at this. Either way, hope you have a great Roon experience!

– Noris

1 Like

Thanks to you too for your ideas!

Certainly! It is fast and really good now!
Understand why you have so much reach in the industry! Keep continue the good work!

1 Like