Remote connection via VPN - [Resolved] but ongoing discussion


(Felix G) #122

I have set my environment just like this, and happily connecting and streaming remotely — from macOS.

From the iPhone (7Plus, iOS12), sadly it does not work. VPN connects successfully, I can ping server IP, but Roon is unable to locate it. I even type server IP in the Hint while Roon app is searching, still, no joy.

This is what I got from Roon support (@noris):

“VPNs are known to cause issue with multicast and our RAAT protocol and as such, we do not officially support VPNs. Generally speaking, when you use a VPN this causes the device to use a different subnet than the Core.”


(Rob Kirkbride) #123

Just to update this I got this working in less than 5 minutes using this setup

I have Ubuntu 18.04 on a Intel NUC so ran this script, enabled IGMP on my router, setup forward of port 1194 to that box, installed OpenVPN Connect on my phone and I’m now listening to Roon at work on my Android phone and works a treat.


(Jules Herfst) #125

Wow, after having tried several vpn connections this one does the job. My Roon server is a NUCi6 running Ubuntu 16.04 LTS. I installed ovpn on this server and now for the first time my android phone is able to run roon over 4G. My previous ovpn connections did work but roon did not accept this connection. Not realy understanding why this one does the job but i’m happy it works. Thanks Rob.


(Bart Verhoeven) #126

If I could only make this work with l2tp instead of openvpn…


(Philip Giordano) #127

So I just got it working on iPhone with a L2TP VPN connecting to a Mac running Roon. I think the key was manually entering the local IP address of the Mac. Seems to be working, solid, and sounds great.


(Bart Verhoeven) #128

Now I feel obliged to spend some time to get this to work in the very near future. Hopefully not a waste of my time :slight_smile:


(Jack Riley) #129

This setup worked for me, I’m able to stream over 4G! Still need to play with it some- roon seems to have some trouble identifying my phone as an actual endpoint, when connected through the vpn but so far this is extremely promising! Thank you so much for sharing, Rob!


(Bart Verhoeven) #130

I can get it to work with L2TP VPN…sort of. It discovers my Nucleus+ and sees all the connected devices as well as all the end points that are on my local network. What doesn’t work is playback to the VPN’ed device. It doesn’t list it as a playback device. Maybe because they are on a different subnet?


#131

Are you running the VPN server on your Roon server or on your modem? More details please!


(bin xiao) #132

Oh guys. I think many of users here are misunderstanding VPN connection and network. ROON 1.5 and 1.6 both can stream to IOS. Any kind of VPN can access your LAN. OPENVPN \ L2TP \PPTP they are all OK, just network issue here.
VPN IP address pool normally not at same subnet of ROON core LAN segement. If same, it will cause the other network problem. You can easily check it when you have VM/HYPER-V host using NAT connection to your HOST machine, and your host machine and ROON core are in the same LAN segement. If ROON client of VM HOST can access to ROON CORE and play music to sound card, any VPN client can work properly as well. JUST CHECK THE NAT RULES.


(Bart Verhoeven) #133

I’m not entirely sure it’s a NAT issue, but more of a multicast problem. Through my L2TP VPN, I can literally see my whole local network. Internal servers can be accessed just fine. That includes the Roon Server. It simply doesn’t detect my VPN’ed device as playback device.

And yes, the VPN IP address pool is in a different subnet, or it would collide with the IP addresses handed out by the DHCP server for the lan.


(Philip Giordano) #134

I am using a Luxul router and the VPN server is there. Maybe I just got lucky, I really didn’t expect to to work!


(Philip Giordano) #135

Under the audio tab I have my phone set up under built in output…


(Bart Verhoeven) #136

That’s the first place I looked :wink: it’s not listed as an audio device. All the local network devices are there. Except for the device that VPN’ed its way in. I can even play to the ones that are listed.


(Philip Giordano) #137

Not sure but I hit clicked “Identify this device” under Built in output and chose iPhone…


(Bart Verhoeven) #138

That’s the thing. It doesn’t even list the built in device :frowning:


(Philip Giordano) #139

Try rebooting phone and/or restart app. I just deleted it and started from scratch. That seemed to get it back.


(Rob Kirkbride) #140

Glad it was useful. The only problem I’ve found is that any kind of network latency often causes the stream to stop and I have to press play again. As other people have said if there could have been some kind of buffering at the client end I feel it would work perfectly.

Roon in the cloud, or at least working via VPN is clearly the future so I would hope it’s something the guys are looking at.


(Bart Verhoeven) #141

Rebooted phone. Still not there. I believe it to be a networking issue. I have the issue with multiple devices.


#142

I don’t know anything about that brand but can only assume that the L2TP implementation they provide allows for the clients to be in the same subnet as the local subnet which is considered poor in terms of security but, dammit, I want it!