Remote Core (nucleus+) 1.6 stable update Not Updating

Roon software update 1.7 for my desktop computer worked but I have not been able to update Roon Remote Core (Nucleus+) 1.6 software. It keeps coming up with a message “There was an error checking for an update RETRY”

My Roon Nucleus+ is connected to my home network via ethernet cable. Do you have any solution so that I can update the Roon Nucleus+ with the latest software update?

Hi @Greg_Johnson,

Can you try giving the Nucleus a reboot? Is there any change after doing so?

I tried rebooting my Roon Nucleus+ and also my desktop PC but that did not help.

Hi @Greg_Johnson,

We recently fixed an issue with the update process — Can you try rebooting once more? This time things should work for you.


Thanks. After rebooting my Roon Nucleus+ I was able to update Roon to 1.7.


Hi @Greg_Johnson — I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.