Remote crashes on tablet

Core Machine (Operating system/System info/Roon build number)

Core on Debian i5 1.7 b528, remote also 1.7 b528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

HP switches, all devices cabled, tablets and phones on wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pi4 with RoPieee - USB to DAC

Description Of Issue

Roon remote 1.7 b528 crashes (becomes unresponsive) on my tablet SM-T365 ‘Galaxy Tab Active’. Happens normally when app is backgrounded, but some times also when in foreground.
The previous versions never crashed, ever.
Android brings up a dialogue saying ‘not responding’ and asking to stop, wait or… Killing and restatrting helps for a while.
I have uninstalled and reinstalled the app. Does not make a difference

Hi @ogs,

Do you have any battery saving options enabled? If so, can you exclude Roon from them?

All battery saving is off. Roon is set to prevent sleep though, but I suppose this is when the app is foreground?

Hi @ogs,

Thanks for verifying this. Next, I’m hoping you can make a note of the next time this occurs and respond here with the time you see the error in your local timezone. I can then enable diagnostics and have the team take a look.

Will do that, thanks.

Happened now at around 18:45 Norwegian time

It’s not a full crash. I can still access DSP and volume for example, but not Album view which is empty.
A dialogue says ‘Try removing some Focus criteria’

Also at 06:30 this morning. The play screen had frozen (started an album just before I went to sleep) and album view was gone. Got the ‘Try removing some Focus criteria’ and warning from Android that Roon was slowing everything down and ‘Would you like to close…’ I answered ‘Wait…’ and tried other displays like ‘Composer’ and ‘Tracks’. These and DSP + ‘Settings’ worked. After some poking around also album view returned and the Roon remote started working normally again.
So the remote seems to have trouble with some functions, but not all. Hope you can find clues in the logs.

Happened again around 17:00 today 6. April. Had to kill the app and restart. Has been quite stable the last two days so I was getting optimistic…
Do you still have remote logging active?

Hi @ogs,

Yes, the logging is still active — I’ll be meeting with the team to review soon and I’ll be sure to follow up when I have their feedback.

Thanks!

Hi Dylan,

any progress on this? b537 unfortunately did not solve it…

Hi @ogs,

I just wanted to follow up and let you know that the team has launched an investigation into this issue and we are working to reproduce this in our QA labs and get a ticket to our development team. I can’t promise and specific timelines just yet as our team is continuing to investigate, but we’ll be sure to let you know as soon as we have more details.

Thanks for you patience, and apologies for the ongoing trouble here.

FYI I sporadically use a Samsung Tab 4 (SM-T830) as remote. Running Android 9 this does not show any instability. This tablet is used for other purposes so I can not rely on it as remote for Roon.
The ‘trouble’ unit (SM-T365) is running Android 5.1.1