Remote devices still looking for Roon Server. Again

Roon Server Machine

Desktop tower
Windows 10 Pro 22H2 19045.3693
Intel(R) Xeon(R) CPU E5-2620 v2 @ 2.10GHz 2.10 GHz (2 processors)
48.0 GB of RAM
Roon version 2.0 (build 1353)

Networking Gear & Setup Details

Directly hardwired into Xfinity Comcast modem model XB7
Speedtest by Ookla - Download: 534Mbps | Upload: 120Mbps

Connected Audio Devices

Raspberry Pi 3 with ropieee
Roon Bridge version 1.8 (build 1125)
USB to Chord Mojo DAC
3.5mm out to Yamaha A-S2200 Amplifier

Number of Tracks in Library

A bit over 60,000 tracks

Description of Issue

Exactly as it happened two times before, a couple years back, right after the latest Roon automatic update, none of my remotes work.

Roon plays music and sees my Raspberry Pi that will also plays with no problem, except for the fact that I will have to physically be in front of the server machine’s screen pressing play, since none of the devices I use as remotes are “seeing” the server. They all stay in the “Looking for your Roon Server” loop.

Here it is a list of the devices I have tried although it is important to mention that I typically only use my phone as a remote, the others I have as backup or in case I need to test something.

  • iPhone 14 Pro running iOS 17.1.1
  • Fire HD (10th gen) running Fire OS 7.3.2.9
  • Onkyo DP-X1A running Android 5.1.1
  • iPad Air 2 running iOS 15.7.3

Lastly, to mention that in September of 2020 I had this same issue and it was solved by adding Roon to my firewall outbound and inbound connections. Then again in February of 2022 where I tried going back to the solution applied in 2020 and added both Roon.exe and RAATServer.exe to the firewall exceptions with no positive results.

As explained before here are some other facts:

  • Everything in my network has fixed IP addresses
  • No modem or any network devices updates
  • All apps are up to date in the devices listed above
  • All of them have been rebooted to no avail
  • Reinstalled Roon from scratch in the server machine
  • All server computer drivers are up to date

@Rodik, on your W10 Roon Server PC, have you confirmed the following:

  1. Your W10 PC network setting is set to Private under Windows Network Settings? Roon requires it to be Private so other Roon devices and see the Core on your home network.

  2. You have W10 firewall exceptions allowing roon.exe, raatserver.exe, and roonappliance.exe?

Hello Robert,
Thanks so much for your answer.

  1. Network settings have always been set to “Private”. I realize that is why I can still see & play music in the Raspberry Pi as well as the “Sonos” system on the living room. However, none of my devices running the “Roon Remote” app can find the server.
  2. Yes, the first thing I did based on having this issue already twice in 2020 and 2022 respectively, was to redo the firewall exceptions for both RAATSERVER and ROON with the addition this time of ROONAPLIANCE since last time in early 2022 that last exe file wasn’t there.
    A bit frustrating.
    Regards
    Rodik
    PRIVATE

Hi @Rodik,

The Roon team has identified a longstanding issue and will be issuing a fix in an upcoming release. Stay tuned in the coming weeks, as it will likely resolve your issue and improve behavior around Remote connectivity long-term.

In the meantime, to rule out the possibility you’re encountering a resolvable issue, try the following:

  1. Prioritize your RoonServer IP address in any router bandwidth prioritization or quality of service rules
  2. Try refreshing your database:
  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Roon Server” and connect to the new database
2 Likes

Hello Connor,
Thank you so much for the answer. I tried both of your suggestions without positive results. As a last resort I moved everything to my main desktop computer which is running the same Windows 10 Pro and wired exactly the same way as the original server desktop (specs mentioned in my first post) and everything is running as it should. All remotes can instantly see and control the server. I will use this solution in the mean time until the next Roon update comes and hopefully allows me to go back to the computer I initially and normally use for this purpose.
Thanks again for your help and have a great holidays.
Regards
Rodik

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.