Remote on IPad can't find newly installed Core Server (Ubuntu 20.04)

Been using Linux Server on an Ubuntu dedicated desktop machine, no problems at all. Installed a new Ubuntu on a newer, faster machine. (20.04)… installed ALL dependencies, and have verified the dependencies. Did a EZ installer script, said at the end that the server should be running. It is not.
When I run “service --status-all”, it does not even show up. Driving me mad. Why would one Ubuntu installation work perfectly and the other not? aaarrrrggghhhh… why won’t it start?

In my 20.04 either. Run “systemctl status roonserver” instead. Another way to check if it’s running is doing “ps ax | grep Roon”. Let’s make sure that it really is not running…

Good suggestion! Full output of that command below:

Here is the output:
roonserver.service - RoonServer
Loaded: loaded (/etc/systemd/system/roonserver.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2020-09-26 16:35:38 EDT; 13min ago
Main PID: 1190 (
Tasks: 46 (limit: 19075)
Memory: 176.8M
CGroup: /system.slice/roonserver.service
├─1190 /bin/bash /opt/RoonServer/
├─1216 /opt/RoonServer/RoonMono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
├─1571 /opt/RoonServer/RoonMono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogpo>
├─1578 /opt/RoonServer/Server/processreaper 1571
└─1806 /opt/RoonServer/RoonMono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

Sep 26 16:35:38 LinuxMain systemd[1]: Started RoonServer.
Sep 26 16:35:50 LinuxMain[1216]: 00:00:00.003 Warn: get lock file path: /tmp/.rnsgem0-
Sep 26 16:35:51 LinuxMain[1216]: 00:00:00.709 Trace: [childprocess] using unix child process
Sep 26 16:35:52 LinuxMain[1216]: Initializing
Sep 26 16:35:53 LinuxMain[1216]: Started
Sep 26 16:35:58 LinuxMain[1216]: Not responding
Sep 26 16:36:02 LinuxMain[1571]: aac_fixed decoder found, checking libavcodec version…
Sep 26 16:36:03 LinuxMain[1571]: has mp3float: 1, aac_fixed: 1
Sep 26 16:36:08 LinuxMain[1216]: Running

THANK YOU FOR YOUR HELP!! Now I’m thinking maybe for some reason the network is blocking the server? Have no idea what the “get lock file path” is, might that be the problem?

Ok, so the server is running. As next step I’d suggest you make sure that (1) your new Linux box is connected to a network, and the interface is active; (2) that your control device is connected to the same network, and (3) that you have no firewall active on your Linux box blocking access.

For (1), you can try with ‘ifconfig’… this will output the status of the network devices. We will see if your Linux box has an active interface, and what is its IP.

As to (3), you can try with ‘sudo ufw status’. This will ask your password and display the configured firewall rules and the status of the firewall itself.

As to (2), what device are you using as control device? Do you have a laptop or a tablet device with which you access and control your Roon core? How is this device connected to the network? Can you make sure it is connected to the same network as your Roon server?

Another thing that comes to mind is the status of your old Roon core, the one you have been using until now on a desktop machine. This core must be deauthorized, I believe, to be able to connect to and set up the new core. Roon makes sure that at any time only one of the installed cores is active. So, to turn active your new core on the new Ubuntu server, the previous core must be deactivated.

No, that’s ok. The lock file of the server is a means to coordinate operations of several cooperating processes on the system.

OK…here is ifconfig output:
enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::8f6a:dde1:4e55:26d2 prefixlen 64 scopeid 0x20
ether d0:17:c2:d2:9e:ae txqueuelen 1000 (Ethernet)
RX packets 38928 bytes 39786209 (39.7 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 28371 bytes 4767875 (4.7 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16 memory 0xdf500000-df520000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 12208 bytes 3469690 (3.4 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 12208 bytes 3469690 (3.4 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp4s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c8:ff:28:31:40:c3 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Here is the ufw status:
sudo ufw status
Status: inactive

The core itself is connected with ethernet; I have a separate ubuntu 20.04 laptop that runs the Roon Bridge, also connected with ethernet. For remotes, I use both an Ipad air and an android phone; both are connected to the same wifi network and work perfectly on my other Ubuntu 20.04 box… Making progress, eh? And yes, I de-activated the old core during my search for the new one.

Ok; your server has an active Ethernet connection with IP The WiFi is inactive.

The UFW firewall is inactive which is ok for now.

How do you manage the assignation of IP to devices on your network? Is it all managed by a DHCP server on your router? Or have you been assigning static IP addresses to some devices, e.g. the old core desktop?

Can you make sure that your IPad Air as an IP on the 192.168.0.x subnet?

If you use your IPad Air to look for the new core on the network, can you disconnect the old core and the bridge device temporarily from the network?

Yes all of my addresses are managed by the DHCP server in the router I do not have any static addresses or devices set up… it’s funny when I look at the iPad it shows a Wi-Fi address that looks like a MAC address 8 c: 29: 37: c3: d3: FB and I don’t see it at all in the router although it does have internet access so it must be going through the router or Wi-Fi… Laptop with the bridge is turned off… as well as the old core the machine is off…

Your IPad should have an assigned IPv4 address in the 192.168.0.x subnet.

This seems to me to be the MAC…

I am not really sure where to go from here. Your new core server is running and has an active Ethernet connection. A remote connected to the same subnet really should find it and be able to connect to it, if you have previously deauthorized the old core.

Let’s see if others step in with better ideas, or if someone from the Roon support team can help you. I will change the title of your support topic to reflect on the situation.

Okay thank you I do appreciate your help I did notice in The client list that the new Ubuntu core box has two listings under The client list one is an IP address and the other looks like a Mac ID both in the attached client list IP address and then it has four rows down fc80:: 2c33: cf6e: fe40: 5685 for the same machine? At anyway thanks again for your help I do appreciate it maybe somebody else will have some input as well

Hmm… are you seeing that in your router’s connected client list?

The first address is the IPv4 address, the second is a IPv6 address. But… both are different from what the ‘ifconfig’ command on your new Ubuntu box returned. So, are you sure that what you see on the client list is really your new server?

Remember, your server returned as its IPv4 address, not And it IPv6 address is fe80::8f6a:dde1:4e55:26d2, not fc80:: 2c33: cf6e: fe40: 5685…

So there seems to be a problem…

One thing I would try at this point is to reboot router together will all network-connected devices, if feasible. The new server should show up in the router’s connected clients list with the same IP it shows if you run the ‘ifconfig’ command on it.

Sorry for the confusion I did reboot the router before looking at The client list… Back to the drawing board I guess LOL

Solved. I run a separate wifi network for my Tablo OTA DVR…for some reason, the Roon Server connected to THAT wifi network… The other wifi is run by Google’s Home Wifi, will have to figure out how to get Roon over to that!!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.