Remote on my MacBook Pro No Longer Works After Latest Update

Roon Core Machine

Roon Core (latest version) is on a Sonic Transporter i5.

Networking Gear & Setup Details

Connected Audio Devices

OpticalRendu, connected to iFi Pro iDSD.

Number of Tracks in Library

Description of Issue

After I updated the app (remotes) with the most recent version, my MacBook Pro remote no longer works. The rainbow ball just keeps spinning after I open it up, rendering the app unusable.

My iPhone and iPad remotes work fine. I deleted the remote and replaced it with a brand new copy and the situation remained the same.

Jacob Ofman

Hi @Jacob_Ofman1, thank you for bringing this to our attention.

As seen in this thread, SonicTransporter Update, others have experienced a similar issue. I wanted to provide you with an updated solution that helped others experiencing this.

Could you please complete the following:

Go to → manage → apps → software manager → update

Note: You may have to upgrade even if you have the latest 2.8 installed

Please let us know if you’re still experiencing issues after completing this - thank you! :pray:t3:

I followed all of the steps that you asked of me. I restarted my MacBook Pro – – and no change. The rainbow ball keeps spinning. One thing I did notice. When I originally updated the sonicorbiter software to 2.8, it took a long time. This time, it only took half a minute. It said all three steps have been completed. I’m not sure if that’s relevant or not.

So, now watt?


After re-updating my sonicorbiter software to 2.8, now my other two remaining remotes (iPhone and iPad) are acting strangely. Things are loading very slowly or not at all. Several discographies are claiming to be unavailable. Now granted, for entirely other reasons, I had to remove my music hard drive attached to the SonicTransporter i5 due to it becoming unstable. But I am still subscribed to both Tidal and Qobuz, which have large inventories of albums by popular artists. So when I look up the discography of Bill Evans (the great jazz pianist) and it finally (after taking a long time to load) says his discography is unavailable, something’s wrong.

Any ideas?


It does appear there is a Roon search issue in general tonight do it’s not likely anything you have done or can fix.

You might just have to exercise a bit of patience for a while unfortunately.

Please don’t forget about me.

Jacob Ofman

@Jacob_Ofman1 thank you for trying that step - I’m sorry it did not help. Not to worry, we can continue to troubleshoot the remote issue.

As for the slow behavior and albums being unavailable, TheHammer was correct, we did experience an outage that has since been taken care of - are you still experiencing this?

Back to the remote - would you be able to share a screenshot of what you see when trying to open the application on the MacBook Pro?

Is your MacBook Pro connected via WiFi? If so, could you please connect it to your router via a wired connection? Does the application still fail to load?

Another great resource to review in the meantime is this article in our Help Center: Why can’t Roon Remote Connect? This article offers additional troubleshooting steps that you might find to be helpful.

Thank you for your patience and efforts :pray:t3:

First of all, the sluggish behavior did clear up in a few hours, so no worries there.

As for taking a screenshot, it’s kind of pointless. It just shows the last album I was playing but it doesn’t show the spinning rainbow ball. However, every tie to e, it does show the current album that’s being played at that time. So it’s partially working.

I did try attaching an Ethernet connection to my MacBook Pro and there was no change.

Let me know what you come up with next.

Jacob Ofman

@Jacob_Ofman1 thank you for the update.

Just to clarify - the initial issue of the Mac continuously spinning the rainbow ball is no longer occurring? Is it just now that you are not able to control the Core using the Mac remote? I feel like a screenshot would be helpful for us to understand exactly what you’re seeing.

In addition, can you please check to see if Roon is allowed past your MacOS firewall by using these instructions?

Apparently, I didn’t make myself clear. When I open the remote on my MacBook Pro, a picture of a Jon Hassell album appears, which was the last album I was playing before the problem started. The rainbow ball still continuously spins each time I try and open up the remote. But when I take a screenshot, it doesn’t show the spinning ball, just a giant picture of the Jon Hassell album with my entire desktop in the background. And I also mentioned that it does show the current track that is playing at the moment at the bottom of the app (I used the phrase “so the app is partially working.

However, I do not know how to get a screenshot into this little box where I am writing my reply. They disappear two seconds after I take them and they are not being saved into my Photos. You’re going to have to give me instructions on how to do that if you want to see one. Sorry!


When editing a post, click on the second image icon (the tooltip, when the mouse pointer is hovered over it says “upload”), then select the image to be uploaded (make sure you give it a few seconds for the upload to complete).

I don’t use a Mac but found this, hope it helps.

Here is the screenshot you asked for. Hope it helps’


1 Like

@Jacob_Ofman1 thank you for providing the screenshot, we truly appreciate it!

We have some additional questions to ask to get a better idea of what may be happening here.

• Is the spinner appearing when you use any other large programs or only when you are using Roon?
• Is it possible you have recently installed any programs that could impact the performance of Roon?
• If you quit other running applications, is Roon Remote more responsive?

In the meantime, as another option, you can take a look at Activity Montior to see if any application is consuming all of your RAM or Hard Disk Speed while using Roon as a remote on the Mac device.

Thank you!

• Is the spinner appearing when you use any other large programs or only when you are using Roon?

Only when using Roon–nothing else.

• Is it possible you have recently installed any programs that could impact the performance of Roon?

No, I haven’t installed ANY programs in a while.

• If you quit other running applications, is Roon Remote more responsive?

I tried that, and the Roon remote app was still non-functional even with absolutely nothing else open.

Hey @Jacob_Ofman1,

Thanks so much for your continuous collaboration in trying to figure out what causes the inability to use the Mac as a remote for your Roon Core. I’m sorry we still haven’t gotten to the bottom of it.

If I understand correctly, one of the first steps you tried was reinstalling the Roon software on your Mac, and that didn’t help.

I wonder if you could try this next: resetting the database on the Mac.

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Thanks in advance :pray:

HALLELUJAH!! That fixed it completely. Thank you, thank you, thank you!!!

Now, since you were so brilliant in fixing that problem, can you help me with another one. I cannot get Roon to scan my hard drive and reload all the files.It’s basically saying the folder is empty. I think I’ve navigated to the right place, but I’m not sure. That hard drive is FULL of music–over 80,00- files. Either I haven’t successfully located the correct name of the right folder, or…I don’t know what. Any help would be greatly appreciated. Thanks for your help in advance.


1 Like

Hey @Jacob_Ofman1,

Beginning your post the way you did, clearly sent the message that there’s something to celebrate. I’m over the moon that you are now back to using your Mac as a remote :partying_face:

I’d love to do all I can to help out. How is your hard drive connected to your Roon Core (the Sonic Transporter)? Could you please send us a screenshot of Settings → Storage from within Roon?

Sorry for my delayed response. I was out of town.

The hard drive is connected to the SonicTransporter via a standard USB-A cable into one of its two USB ports that serve as inputs. I hope that helps


I forgot to mention. I named the hard drive “Music Drive”. I also added a folder to the hard drive with a name something like “Jacob’s Music Folder” (not sure if that’s the exact name). All the music went inside that folder.


Hey @Jacob_Ofman1,

Thanks for finding the time amidst your travels to reply to my post :nerd_face: . We just returned to work today after the weekend.

Your second post seems to point to the problem. It looks like Roon is directed to watch the root folder and not Jacob’s Music Folder. Roon will only “see” your music library if the folder containing the music library is set up as a watched folder:

Please, let me know if the above helps :nerd_face: