Remote see synology core as "ready" yet can no longer connect

Core Machine (Operating system/System info/Roon build number)

DSM 6.2.3-25426 Update 3
RoonServer v1.7 (build 710) stable on linuxx64

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi mesh WIFI6 & 10G Ethernet direct connection to PC and android on wifi all fail

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

not relevant to issue

Description Of Issue


Firstly thanks very much Chris - I intend to buy you a coffee (or more than one). I installed roon on my synology last month and it has been running perfectly up until now.

I believe that this is a problem I have created myself, yet would appreciate any help. Whilst accessing something else I accidentally tripped the on/off button on the synology! So the synology did a hard shut down (as opposed to a soft shut-down from DSM). In fairness, this would be better than if there were a power outage - so would be useful to know how to rectify. I turned it back on once it had shut down completely and everything apart from roon is working normally. With roon I see the core from the remote and it is indicating as “ready”. However, when I click on the connect button it takes me to the login page rather than connecting to the core. This is the same whether I use my android remote, or the win10 pc remote (connected via wireless or directly to the synology with a 10G LAN). If I login it recognises my license and asks if I want to deauthorize the synology (which I don’t).

I’ve tried a couple of things based on looking through the help pages and forums, without success.

-I’ve restored from a back-up
-I’ve rebooted router
-I’ve stopped Roon on the synology, uninstalled roon on android and win pc. Started roon on synology, reinstalled roon on android and PC,

all without success.

Are there any suggestions to resolve? It seems that maybe the roon core is not recognising my licence so then takes me to the login page? Or is there a simpler explanation?

I suppose I could uninstall from the synology and start again. But would like to hear if there is a simpler option.

Thanks in advance to all for any help

Best Regards

OK - a bit counter-intuitive but…

…logged-in and unauthorized the synology core and voila PC remote and android remote now working with the synology as the core. Not sure how, yet a moot point.

I do have a spinning icon on the PC with a software update for metadata required. Yet that is fine considering (since I principally control using my android) and it may disappear after a reboot…

Hi @Nigel_Hiorns ,

Thanks for letting us know you were able to resolve this issue by un-authorizing and re-authorizing the Core! You may also want to try changing your router’s DNS servers to Cloudflare DNS, Quad9 or Google DNS if the metadata error persists after a reboot.

Thanks for the response Noris. Hopefully this post will be useful to someone else, as unauthorising was the last thing I wanted to do, yet probably it should have been near the first!

I still have the spinning icon after reboot, which I don’t believe I had before. Both my DNS are set to google &, which is what I changed them to when I first got the orbi 6months ago.

It is probably in a post somewhere - forgive me. But is a Roon 1.8 planned for synology soon? And is the issue with DSM 7 solved (as I use the NAS predominantly for work I only intend to update once stable and I am sure it functions with all the apps I need)

Best Regards


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.