Remote slow to populate until it's restarted and black screen

Core Machine

Rock latest

Network Details

Unifi wired and wireless

Audio Devices

Not applicable

Library Size

3700 albums

Description of Issue

Noticing on the Android app on my Pixel 4 if app goes to the background and is left when it’s resumed and it reconnects to core, it often wont load album or artist details it will attempt to but just get the jellyfish often it does this for an album that actually returns no details at all. If I force close the app and restart it stops this behaviour.

Looking at the logs it shows it trying to refresh the data many times and failed connections. Tried changing DNS not that I believe this is related and it makes no difference, tried clouflare, Google and quad 9 and my ISP nothing makes a difference.

Have no issues streaming music it’s just the app and populating data. Whether this is Roons server or not I can’t tell but it’s got worse since the last app update and over the last week it’s doing it more often.

It just got stuck loading one album and wouldnt load it all just got the jelly fish looked in server logs and nothing shows up.

Simon this is something I used to see regularly, but thankfully not for a while, and I remember it being really frustrating. I was turning off the core Nuc and my phone on a regular basis. It went away on its own from memory.

I did put a DNS server on my Synology and a second on my Raspberry Pi (diet Pi) at points and had them point to cloudflare and quad 9 and I will say that with the caching servers in the house things work better for me in Roon (nothing else ever seemed to suffer before).

One thing with the Pixel 4, have you wiped the cache, just in case it has grown a bit large, I doubt it’s that but I have seen it use way to much space on my iPad.

It’s a brand new replacement phone it did the same on the previous one though. Cache is tiny currently.

Ok good news on that front, but still frustrating.

Are you running something like on your phone, I was and had problems with a few apps. I still have it for when out and remember to use it, but I never turn it on at home anymore.

DNS doesn’t make a difference at all. I already mentioned that in my opening post. Cloudflare, quad 9, google.or my ISP always the same.

Simon sorry I meant the Cloudflare app (
Which created a lot of issues for me when I was using it.

Just reading that @AceRimmer has the same issue on a Windows 10 Computer, only on just one computer today.
Can’t really see it, but maybe some more Roon server issues.

This 8s also what happens for no reason. Had doe nothing since grabbing an image and sharing it. 5 mins later blank screen. !!

App crashes again this morning all I get is a black screen. It was fine one minute went to another app then back and it just goes black and is unresponsive. It’s definitely worse since the last update. So whether this is related to the changes made that helped sort out those with Mali GPU’s

No I don’t use any 3rd party apps for DNS.

And here it is going partially black but is responsive. Not proving to be a great experience at the moment.

But on trying to view any album I get this and it’s still going 4 mins later.!AgHQUEVFVR_n2ohZrlEKKoBy9RibiQ

The downside of having no Roon support over the weekend. Are all your other devices still fine?

I just put my Nuc in an Akasa fanless case, and put it off from yesterday in case it lost the artwork, but it’s come back up and is working perfectly across all my devices at this point.

Other users reporting similar black screen issues.

@support would be good if I can get some acknowledgment of this issue please.

Hey Simon, hoping you don’t mind providing some more information to help us narrow down where to start.

What hardware?

This feels like it could be network related, so it would be helpful to provide as much detail as you can. What Unifi devices are you using and how are they connected to your core & remotes? Have you tinkered with any settings, or is everything default? Any detail about your network topology is going to help a bunch.

It sounds like this was happening before build 795, do you know about when it started? Do you recall anything changing around that time?

What is responsive and what isn’t working? For example, does the home page load properly? I’m having a hard time figuring out the exact steps you’re taking to get into this state, so I’m hoping you can help me fill in the blanks:

  1. You’re in the Roon app, everything is working
  2. While looking at the <insert screen name> screen, you close the app
  3. When you reopen the app, that screen is blank but <list of other screens/functionality> still works
  4. When you restart the app, all problems are resolved

Thanks Simon! Hoping that with your help we can nail this down.

Rock is running on a 7i7 with 128gb sad and 2tb usb storage.

350mb/s fibre for internet via Virgin modem. Network is a Unifi USG Router which feeds a Unifi US8 -60w switch , which feeds 3 X Unifi AP and two more Unifi US 8switches in different rooms.

Rock is hardwired to one of the US 8 switches , obviously the Android remote is connected to one of the APs dependant on the roon I am in. The issue happens where ever I am. I have no issue with streaming music, local or from Qobuz. Windows remote does not have this issue and is on same wireless network.

The waiting for stuff to load has happened before 795 and I always put it down to Roons server load as it generally coincides with this and others have reported similar issues but will return and be fine after this blip. It would happen maybe once a day but not all the time. Since 795 it happens more regularly and more frequent when the app has been in the background or phone has gone to sleep.

Playing with battery optimization helps mitigate this somewhat but I really should not have to if Roon is playing ball. When battery optimisation is turned off the app tends run for a while in the BG ok and then just outright quit so when restored from bg it seems to reload the app. When battery optimization is on the phones default state as is the case with all Android devices then Roon will often just exhibit a black screen as I have shown and will be completely unresponsive when it’s been in the BG or asleep, nothing will do anything at all. The app needs to be force closed and restarted to work again. Or when clicking on album or artist details i get the Roon loading symbol as shown in my video. I can navigate to homepage and othe pages but loading any does the same again. A close of the app will make it all work perfectly again. Or sometimes I get the outer items but black where artwork and now playing controls etc should be as exhibited in my last image I can navigate but it will go to the loading screen again if I try to look at any metadata. None of this follows a pattern its random as to which issue Roon will display. But they all happen when it’s gone to the BG or asleep.

During this time I can be streaming music uninterrupted often in other zones as well as the one I am in. Windows remote does not have this issue at all and its on the same network.

What’s the exact setting that you’re adjusting? On my Pixel 4a I have settings for Battery Saver and Adaptive Battery – is it one of those?

So you don’t observe this behavior when you have battery optimization turned off?

What’s the exact setting that you’re adjusting? On my Pixel 4a I have settings for Battery Saver and Adaptive Battery – is it one of those?

I Just turn off battery optimization in the apps settings.

Adaptive battery is on as it’s a default setting.

I see different behaviour with it off as I explained in my last post it restarts with it off when brought out of sleep or bg . t is not solved it’s just another issue. Roon doesn’t ever stay running like all other music or non music apps I use.