Remotes don't connect to Core after update to build 880

Roon updated on my system and the remotes like phone and laptop won’t connect now. It asks me to update the app on my phone and as far as I can tell its already updated. Is Roon ever giving to ■■■■ together and quit breaking it?

Your phone is still on 831, not 880.

1 Like

You do need to update, it looks funny because you click the link and all is says is open instead of update.

Go into the play store without using the link from Roon and you will see the update option.

simply restart your core if your remote app was already updated, then everything is gonna be fine. I was encountering the issue too and resolved.

I tried all that, I went to app store and it didn’t give me the option of 880.

Same was going on with my laptop. This morning my phone miraculously had updated. Now my laptop allows me to update. These were not available last night so when core updated I was hosed. Now one of my end points won’t show up, not the first time this has happened with a Roon update. I have 2 Raspberry Pi’s with Hifiberry DACs on them. One is showing up and one isn’t. I now have the one that isn’t directly connected to ethernet on my router. To be honest, I get tired of this BS.

Sorry I have it connected directly with ethernet and still won’t show up.

Roon cannot control when app stores release updates. They clearly point out in all update info on the site to check you have apps available before updating. Perhaps they need to say this in the updater.

The hell they can’t. Why would you release firmware for Roon core unless you knew the apps were available for phones. It also doesn’t explain why my laptop wouldn’t update either until the next day. Don’t give me those BS excuses why Roon constantly has problems and then try to blame the users and their systems. Nothing changed with my system. And why every single time it updates does my endpoint dissappear and then just magically show up days later. If I sound ■■■■■■, then you would be correct. Quit screwing stuff up with every release.


Each region gets them at different times and there isn’t a way for them to know when they are out. Then you have everyone on new remotes and old core so same problem arises which is why they say to check first.

I have never had a major issue with updating that wasn’t down setup in 5 years. I wait until I see the new version of app then update as advised. All works. Have to occasionally reboot core to update on that but no it doesn’t break every time for me or many many more. If it does for you I understand your frustration but it would point to something in your setup thats not happy. Slow discovery of endpoints is generally a network issue related to Multicast packets getting rejected somewhere.

Isn’t it obvious to check all the components are available before clicking update, it’s not mandatory to update immediately,

In my case the iOS app update was there even though the Android one wasn’t so was good to go BUT I did check so as to avoid issues like this.

Just makes sense😀

No it isn’t obvious. I’ve never had this specific problem, plenty of others though.

Hey @Donald_Adams,

Thanks for letting us know right away about the issue you’ve encountered. We’re very sorry :pleading_face:

I split the topic from the initial post, so that we can focus on your issue alone. I hope that’s ok :blush:

Have you been able to update your Roon Remote app to the latest build?

My end point has shown up so it appears to be working although I’m not using it since I’m working, only to test. The problems I had last night with the update are not acceptable. Its not like I and many other people haven’t had issues in the past. I have made exactly zero changes to my system before or after Roon was updated. Although I did just recently start to experience the “Tidal is loading slowly” error again and I verified the same thing occurred with music stored directly on my core. I’ll test it more thorough when I get off work to see if that has stopped.

A post was split to a new topic: Update to build 880 does not work

Hey @Donald_Adams,

I’m sorry we’re interfering not just with your music, but work hours too…:pensive: We’d love to help when timing is better for you. Please, let us know :nerd_face:

You’re not interfering with work, I just don’t have time to very everything is working and working well till later today. I’ll let you know. Thanks

1 Like

I experienced the same issue last night. I found the update in Apple AppStore but not in Google PlayStore. It is still not available as of this morning.

I agree with Donald_Adams that we users shouldn’t be bogged down with something like this. When Roon releases a new update, they should ensure the update is readily available at the app stores.

It doesn’t make any sense to me that we must update the Roon Remote to access Roon.

I tested things thoroughly last night and everything seems to be working again. Thanks

1 Like

The Roon Remote update is still not in the PlayStore. Any idea where it is going to be there? This is definitely not a “slight delay “. Please advise. Thanks.