Remotes no longer will connect to Nucleus core

Roon Core Machine

Roon Nucleus (purchased from Roon as a refurbished item 3/2022)
4TB Memory (98% available), OS Version 1.0 (Build 227), Roon Server Version 1.8 (Build 943), Roon Labs S/W Version 1.0 (Build 12), Roon Database and Settings (97% of 114GB available)

No devices directly connected to the Nucleus; only power and Ethernet.

Networking Gear & Setup Details

1GB Ethernet, AT&T BGW320 router, Netgear 16-port GS116 Ethernet switch.
Roon system devices are primarily connected via Ethernet. An Orbi RBR750 WiFi router and one satellite support wireless connectivity to an iPhone and iPad.

Connected Audio Devices

Ethernet: NAD M33 integrated amplifier/DAC
Ethernet: Auralec Aries G1 streamer
Ethernet (MBP)/USB (MM1): B&W MM1 DAC/Speaker set connected to an M1 MacBook Pro
Ethernet: Bluesound Node 2i DAC/Streamer connected to PS Audio Sprout 100
WiFi: iPhone 12 Pro Max
WiFi: iPad Pro 12.9", 5th Gen

Number of Tracks in Library

Approximately 30,000 tracks

Description of Issue

My system has been running flawlessly for the past 2 months. Saturday evening (5/14) it stopped serving music to any of my remote devices. Using the web interface on my MBP, I tried rebooting and power cycling the Nucleus, network devices and remote devices but this didn’t help. I manually restarted the Server Software several times. Based on forum research, I followed the procedure to reinstall the Operating System including renaming the Roon folder to force recreation of the Roon directory structure. On the System Status page, all elements are showing “OK”.

Currently, when I open the Roon app, I’m asked whether I want to "Choose my Roon Core or “Set up a Roon Core” (in this case on my MBP). I pick “Choose my Roon Core” and after a bit the Nucleus is found (green Ready dot). However, when I hit the “connect” button, I just get the animated “sideways octopus” icon that eventually times out and brings me to a “Remote Connection Waiting for remote Core…” screen. Clicking on “Select a different Core” just starts the cycle all over again. As a result, I am no longer able too get to the Roon Home page and access other Settings therein.

I have noticed that the Roon Server Software “Running Time” never increases from its initial value (is not in sync with the Operating System runtime, for example). Not sure if it is hung or rebooting. This observation is what prompted the Operating System reinstallation described earlier.

I have not tried the nuclear option of resetting the “Roon Database and Settings”. Is it time to do so? Any other suggestions?

Can you please share a screenshot of your Nucleus’ administration page? Given that there is a discrepancy between the server times and the OS uptime may indicate an issue.

Hi Robert - here is the requested screenshot of the Admin window:

Ronald, it appears your Roon Server is resetting itself. Jamie from Roon Support published these steps which are assisting some users:

I am just a fellow user, but have seen many posts such as yours recently and this may help you also.

Thank you Robert. I ran across the @Jamie response and performed his procedure before making my original post. Everything goes fine until I get to the step “If everything starts up as expected Restore your Backup prior to the issue starting”. It doesn’t start as expected…. I need the “Else” statement :grinning: The Nucleus Core is found but never Connects. Very frustrating as everything had been working perfectly prior to last Saturday.

BTW… your suspicion that the OS is restarting appears to be on point. Below is another screenshot taken this morning. The system has been undisturbed since last night’s screenshot. The OS is only showing as having been running 46 minutes.

I’m tagging @support for you. This may also be indicative of a hardware issue if Jamie’s instructions did not help, but not positive about that.

Thanks gain Robert - I wondered about the potential hardware issue myself given the Nucleus is a refurbished unit and had been working so reliably the two months I’ve owned it. I’m looking forward to any pearls of wisdom the support team may offer.

1 Like

Hi @ViperRGD,

I’m very sorry to hear about the issue, particularly given that it’s a recently purchased unit.

I noticed you’re using an Orbi router in your setup. We recommended unchecking ‘Disable IGMP Proxying’ in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Can you please give this a try and let us know if there’s any change? You may need to reboot your router, Core, and remote devices after making this change. We’ll proceed with additional troubleshooting steps from there.


Hi Conner - thank you for your reply and interest in helping me resolve my issue. As instructed, I unchecked the “Disable IGMP Proxy” setting in my Orbi router. I also power cycled all network and Roon elements in my configuration. Unfortunately, the behavior I am experiencing is unchanged from what is described in my initial post. Please advise on next steps. Below are current screenshots that may be useful:

Hi @ViperRGD,

I appreciate you working through these steps with us.

It sounds like you’ve already followed the steps for setting aside the RoonServer database without luck, so we’re going to enable diagnostics for your Roon Core and have a deeper look at the reset intervals.

Can you please clarify the wiring of your network? Is the Nucleus hardwired to the router or the unmanaged Netgear switch?

WiFi extenders can also complicate Remote connectivity. Would you specify the extender setup you’re using in your setup (model number, if possible)? I recommend trying to connect without the extender, if you haven’t already, to see if that changes the behavior.

Good morning Conner,

Below are responses to your questions:

The Nucleus Roon Core is connected directly to a port on the unmanaged Netgear Switch (model GS116). The switch is connected to an AT&T 1GB Fiber router (model BGW320). Other than power, nothing else is directly connected to the BGW320. Ethernet cables from ports on the switch provide connectivity to various rooms in my home.

The Orbi RBR750 router is connected to the home network via the Ethernet jack in one of the guest bedrooms. An Apple TV is physically connected to one of the Orbi Router Ethernet ports.

The lone Orbi Satellite is wirelessly connected to the Orbi router and is located in the Living Room. Nothing is connected to any of the Satellite’s Ethernet ports.

I’m using WiFi primarily for in-home iPhone and iPad connectivity as well as a Ring doorbell and Eufy cameras.

I physically disconnected the Orbi from the network, powered it down and rebooted the Nucleus. Unfortunately, the original symptoms persist.

The factor that continues to concern me is that the network configuration has been static since shortly after Nucleus was installed and Roon configured (back in March). The problems that began last weekend seemed to be out of the blue. I appreciate your perseverence in getting to the root of the issue.

Hi @ViperRGD,

Thank you for your patience, and I’m terribly sorry that it’s taken me several days to follow up with you. I’ve set this conversation to alert me directly, so you can anticipate a much faster response time as we continue to troubleshoot.

We’ve attempted the log pull from our end, and it appears the device is having difficulty reaching our servers. That may indicate an SSD failure (drive issue, as you suggested in your private message). However, we want to give RoonServer a fighting chance to start properly on its own before we proceed the hardware route.

Since you’re able to access WebUI and the device has an IP address, you’ll likely be able to access manual logs. If you’d willing to try, you can follow the directions found here and send over a set of logs to our File Uploader.

The next step would be to re-install Roon’s operating system from the WebUI page below “Operating System.” Since you already tried the more thorough database reset previously, resetting the database from the WebUI shouldn’t provide us with any more data points here. That said, feel free to give it a try one more time.

I’ll be standing by for your response and will pass logs to our team as soon as you’re able to upload them. I know this issue has dragged on, and we hope to resolve it for you quickly and efficiently from this point.

Hi Conner - Thank you for the reply. I continue to appreciate your assistance with this matter. I just uploaded the requested logs file (named “ViperRGD”) a few moments ago.

I reinstalled the OS early on in this process back on 5/14. If you would like me to reinstall again, I’m happy to do so. Just let me know.

Regarding the issue symptoms, the OS appears to be running continuously. It’s been up for more than seven days (the last time I rebooted the Nucleus). The Roon Server Software, however, is stopping periodically or possibly restarting.

Over the last week I would occasionally attempt to bring up the Roon client on my MacBook Pro and the client would search for it, “identify”, attempt to Initialize (red status dot) and then time out and return to the “Choose your Roon Core” screen. When I refreshed the Roon Nucleus “System Status” screen, it frequently indicated the Roon Server Software was “Not Running”. I would manually restart the server whenever this was encountered. Unfortunately, this didn’t change the behavior of the Roon Client. Although I’m describing the MacBook Pro experience, it happens with other end points. For example, my iPad Pro exhibits the same behavior when attempting to run the Roon app. For completeness, here is the latest System Status screen:

I’ll stand by and await further guidance.

Hi Conner - just checking in to see if the uploaded logs provided any insight into what may be at the root of my issue and what you had in mind for next steps. I’ve been “Roon-less” for over two weeks now and really miss the flexibility and functionality it provides. Thanks!

1 Like

Hi Conner - it’s been a month since I opened this thread and over three weeks since I’ve heard anything from Roon Support. I’m trying to be patient with this forum-based support model but must confess it is becoming increasingly frustrating. Have the logs requested/provided highlighted anything about what may be at the root of my situation? At this point, does it make sense to have the Nucleus returned for repair/replacement to rule out a hardware failure? I’m willing to take whatever path recommended; please provide guidance so we can get this issue resolved. I miss the utility and flexibility that Roon provides when it is performing as expected. Thanks!

Hi @ViperRGD,

Please accept our sincere apologies that you haven’t received a reply and quick resolution. It’s unacceptable that you’ve been without a system for so long. We’ve reviewed logs and want to clarify three details before we open a PM thread to ship the unit in:

  1. Do you have a firewall enabled anywhere in this network, or are you using a VPN?
  2. Do you have IP Passthrough enabled on the AT&T BGW320?
  3. If you’re willing to try an additional step, you can try assigning a different DNS server in the web administration for the Nucleus+ (and on your upstream router, the AT&T BGW320, as well as the Orbi). We find many customers have success with Google DNS ( and Cloudflare DNS ( You can refer to this Help Center article if you’d like to try this step, and we’d be happy to assist you further here.

I understand this issue has tried your patience, and we’re very sorry. We’re hoping to restore your faith with a prompt resolution - and quick response time - as we proceed from here. Let me know the answers to 1) and 2) above, and we’ll move forward from there ASAP.

Hi Conner - Thank you for the reply. Below are responses to your questions:

1(a) Do you have a firewall enabled anywhere on this network?
Response: A firewall is enabled on the BGW320 router. Note that IP Passthrough is not enabled.

Below reflects the Firewall Advanced settings. Note that I have never changed any of these settings.

1(b) …are you using a VPN?
Response: I have a subscription to NordVPN but only occasionally activate it on an IPTV device. This usage precedes purchase of the Roon Nucleus i.e., Roon worked fine with this use case for the two months prior to the subject issue surfacing.

2.) Do you have IP Passthrough enabled on the AT&T BGW320?
Response: As stated in 1a, IP Passthrough is not enabled. Below is additional insight on the settings.

3.). If you’re willing to try an additional step, you can try assigning a different DNS server in the web administration for the Nucleus+ (and on your upstream router, the AT&T BGW320, as well as the Orbi). We find many customers have success with Google DNS ( and Cloudflare DNS( You can refer to this Help Center article if you’d like to try this step, and we’d be happy to assist you further here.
Response: I looked into this (including the link provided) but the process for making the DNS change doesn’t appear to be straightforward. The DNS server shown in the Nucleus Admin screen is grayed (uneditable). The primary and secondary DNS servers for the BGW320 are visible but the method for editing these addresses is not readily apparent. In any case, I wanted to get you the responses to your two primary questions ASAP. If I am able to perform the suggestion in 3.) I’ll send a separate response.

Please advise on next steps. Thanks again Conner.

Hi @ViperRGD,

Just a few more quick tests to rule out a hardware issue.

  1. Out of curiosity, if you enable IP passthrough does that change the behavior?

  2. An alternative test would be to remove the unmanaged switch entirely, connecting the Nucleus directly to the upstream AT&T router. While the network has remained static, it’s possible an automatic firmware update somewhere kicked a setting change or otherwise introduced the problem.

  3. If that doesn’t work, if you have display/monitor available, you can connect an HDMI output on the Nucleus to the display to show some system diagnostic information. If you’re able to to try this, please let us know any information displayed (photo or quick summary).

Thank you again for your patience!

Hi Conner - here are the results of the recommended steps:

I enabled IP Passthrough as shown below. After rebooting, the Nucleus is found, I’m asked to logon but then I get the screen indicating an issue loading my library. I’m unable to advance beyond this state.

I undid the changes made to address suggestion 1.) i.e., IP Passthrough returned to “not enabled”. I connected the ethernet cable from the Nucleus to one of the three ports on the back of the BGW320. I rebooted the Nucleus. Started the Roon app on my MacBook. The Nucleus is found as the Roon Core. After selecting “Connect”, I’m asked to log in. After doing so, I receive the same “There was an issue loading your library” message as described in 1.)

Hooked up the HDMI port to a monitor. Below is what is showing:

In summary, unfortunately, no breakthroughs. Unless there is a need to preserve the current configuration should you determine the Nucleus be returned, would it make sense to “factory reset” the Nucleus? I understand I will likely lose some meta data. I’m OK with that if there is a likelihood it resolved the problem. As previously mentioned, it worked flawlessly for about two months out of the box. I’ll defer to your recommendation on where to go from here.

Thanks for your continued support on this!

I am going to jump back in here as I have AT&T Fiber. The only issue I ever had with AT&T Fiber was their DNS, which was horrible. At the end of 2019 after almost three years of no issues, their DNS was causing all sorts of issues.

That said, I have always used a separate router and subnet for my home LAN, using my AT&T 5268AC gateway only for phone/ATA and to pass to my ASUS mesh network on a different 192.168.x.y subnet. I use my ASUS router as-is, except assign a specific subnet and DNS servers, and passthrough all IPv4 and IPv6 addressing. While I can change some of my AT&T gateway settings, I have not touched it except to disable its WiFi. All WiFi is served via my ASUS mesh, along with all network addressing being provided by the ASUS router. The AT&T gateway seemlessly allows for the second subnet without any changes to its configuration. I changed my DNS via my ASUS LAN to use Google and all the problems went away immediately, and I did not change anything with my AT&T gateway DNS.

May I ask how your Orbi network is configured? Do you have a unique subnet assigned to it and have it configured in router/mesh mode to act as your primary network?