Remotes not connecting to Sonic Transporter Core

Since June 7, I am having the same problem – and hoping someone has a solution . . .

My core is on a Sonore sonicTransporteri5, with Roon Remote on an iPad. All software is up to date.

On advice from Roon help, I have determined that my firewall is off and that my iPad (w/Roon Remote) is on the same network as my Roon Core. But I am having trouble checking whether my Roon core is configured to accept connections from remote sources. (It should be; I have not made any changes from when the rig worked perfectly.). Here is what the Roon help page says about that:

Why can’t Roon Remote Connect?

If you’re running Roon in remote mode and having problems connecting, here are some troubleshooting steps to get you going.

"Accept Remote Connections

"The first thing to confirm is that your main Roon install is set up to accept connections from remotes. To do this, click the main Navigation menu (top-left of Roon) and select Settings. Next, click the Setup tab, and make sure “Accept connections…” is set to Yes".

My problem now is that I do not know how to find the “main Navigation window (top left of Roon)”. Roon Remote on my iPad hangs on the “waiting for remote core” page and will not offer a Navigation page. Settings for the device holding the core are on the device’s web page (not on a Roon page) and do not offer an “accept connections from remote” option. Would be grateful for any clarifications or help.

BTW, my core and remote are on the same private network. My settings show that Roon has local network permissions.

As mentioned above, I am having the exact same problem as Adam, only with different gear in use and with far less computer knowledge. Thank you to everyone who has posted here. I will patiently await the response from @support and hope there is a solution for me also.

1 Like

Thanks for your suggestions, @Jamie. I tried the rebooting tactic twice, but unfortunately the situation is still the same. Would be grateful for further guidance.

Hey @Robert_Gremore,

Please try the steps below, previously recommended by Andrew to a customer with similar issues, and let us know if that helps. If not you may want to reach out directly to Andrew at Sonic Transporter for next steps.

Uncheck both the settings on this page and save the change. Then go to “System” and reboot. Pressing apply on that page rebuilds all the Roon settings and restarts Roon Core.

Again, thank you for the suggestion, jamie. I tried what you say, but unfortunately the problem persists.

Someone suggested deleting and reinstalling the iPad’s Roon Remote app. But, when I begin that process, a warning pops up telling me that deleting the app will also delete “all its data." In several searches on Roon and Google, I have not found out what data that might be. Is this a big deal? What data will I lose if I delete and reinstall the app? I see that the reinstall has not worked for everyone, but would like to try that fix if it will not require major redo of tags, etc.

Also, it seems that my sonicTransporteri5 might be running significantly warmer than usual. That might be my imagination. If the Roon Remote reinstall does not work, I will contact Andrew about the connection problem and see what he thinks.

Thank you again, and I would be grateful if you (or someone) could let me know what data the reinstall will trash.

Hey @Robert_Gremore,

Removing the app on your iPad won’t negatively impact any of your Roon data. Your customizations and settings are saved in the database that resides on your Core.

You do want to ensure that you’re creating regular backups of your Roon database, however. You can find more info on backups here - but you’re all clear to try installing, restarting, and reinstalling your room remote app on the iPad.

I’m having the same problem as @Robert_Gremore
Not only the ipad remote, but all my remotes (Android phone, Windows PC) do not connect.
Andrew Gillis referred me to Roon Support…
Any suggestions ?

1 Like

I too I’m having the exact same problem as above, since the latestRoon iOS update. Everything was working perfectly before, but now the app just hangs and cannot connect.
I have uninstalled the app from iPad and reinstalled, done the above suggestion in Sonic transporter web settings and rebooted, nothing is help so far.
Any advice is very appreciated please.

Hi @Ori_Onn & @Quark,

Sorry to hear that you’re having issues with your Sonic Transporter. Let’s start with a full reboot of your Router, Server, and remotes.

  • Power down the remotes, router, and server
  • Unplug the router and server
  • Wait a few minutes
  • Plug in the router when the router is online
  • Plug in your server and restart
  • Then power up your remotes

Please let us know if this helps.

Hi @jamie
I did all that now, didn’t help

Ori, I had the same problem a few weeks ago. Tried 14 fixes w/o success. What finally worked for me was to delete Roon core from the Transporteri5 and reinstall it. This worked, but wiped out all tags on the albums in my Roon library. (I had not thought to save them, and did not know how anyway.) Here are the instructions from Andrew Gillis at Small Green Computer for what I did:

"If you can’t access Roon from the Roon app or your database is corrupt you need to reinstall Roon.

This is very easy to do and can be done from the software manager.

  1. From any web browser on your home network enter the URL to locate the sonicTransporter’s web control pannel.

  2. Click manage next to the unit you want to configure.

  3. Then click Apps → Software Manger

  4. To delete Roon click on Installed Apps tab and you will see the apps you have installed. To delete Roon click on the icon for the Roon app and click delete.

  5. Once this is complete click the Available Apps tab and you will see the apps you can install. Click on the icon for the Roon app and then Install to install it.

  6. You now have a clean factory new version of Roon Core server. You will need to go into settings in the Roon app and re-configure your storage settings and also re-enable your players."

You can see more details on this SGC website: MySonicorbiter

Andrew’s advice worked well for me, but I lost my tags. Would be grateful if someone from Roon could explain how to restore them ( @jamie ).

Good luck!

Ori and Quark,

Here is something Andrew suggested trying before re-installing the Roon core. It did not work for me, but YMMV:

"Try this is. It may fix the Roon Core

Go to → Manage → Apps → Software Manager → Press the update button

Go to → Manage → Settings → Roon Server
And press Save Changes "

Hi Robert,
Thank you so much for your replies, you are very kind and it is extremely appreciated. The Roon Community is a wonderful thing.
Yeah, so I tried this process of updating, saving settings and it didn’t help. I also tried clicking on “expose Roon core” and “enable local playback”… which has worked in the past, but not this time.
I’ll have to confess I was being a little daft. My Brain is a little clouded at the moment because of personal disability issues that have kept me in bed constantly for the last two months, and for some reason I thought if I deleted the Roon app and reinstalled it it would delete all my music files and I’d have to transfer them back again from my back up. I was just confused, Fed up of being in bed :laughing:
Anyway, I deleted it and reinstalled it, and restored my library from a back up. Everything is working perfectly now and it didn’t take long.
Sorry to hear that you didn’t have a back up to restore Robert, I know how long it took me to set up my library, favourite tracks and playlists bit by bit over the years.
Thank you so much again Robert, and Jamie for the original contact.

1 Like

This happens to me often, a Roon update comes, and the remote cannot connect anymore. It is maddening. The only fix which has worked for me is to uninstall Roon from the server, and then reinstall it. This is a MAJOR PIA, as it takes a long time here. If updates only came along every 20 months or so that would be one thing, but having to do this nearly every time there is an update means I miss out on a lot of time I could be listening to music. ROON/SGC, please find and fix the underlying problem: it should not be necessary to delete and reinstall Roon with every update.


I deleted Roon and reinstalled it, problem solved.
I agree that this should not happen.
Thanks @Robert_Gremore !!


This mirrors my experience. I wonder if the root cause sits with Roon or SGC?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.