Remotes unable to connect with 1.7

Core Machine (Operating system/System info/Roon build number)

HP Prodesk 600 G1 SFF running ROCK (i5, 8GB ram, 128 Samsung EVO 850 SSD + 2TB Seagate HDD) - Firmware 1.0 (Build 183) Version 1.7 (Build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Porsafe switch, Ubiquiti Unifi AC LR AP, Bell HomeHub 3000 router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Hegel H590 via USB

Description Of Issue

Prior to the 1.7 release, I never had any issues with this setup over the last year. 1.6 has been absolutely amazing. It was consistently reliable and stable. Since the 1.7 update, it has been a nightmare. Remotes will not connect. My main remote is an iPhone XR. If I reinstall Roon ROCK, everything works until I reboot the server. Once I reboot, remotes will no longer connect. My server was left on for 24 hours after one re-installation, and everything worked perfect. I listened to music for an entire afternoon. As soon as I rebooted, my phone would no longer connect to the core. I have tried removing the SSD, formatting it clean on another machine, reinstalling Roon and same thing. Works fine until I reboot. When I log in via a web browser, it appears the Roon Server Software is restarting every 12 seconds as it shows as being OK for 12 seconds to NOT RUNNING and back to OK. Not sure what changed from 1.6. I just get a “lost connection” message and it loops trying to connect.

Hi @William_Boucher,

After a reboot, if you leave ROCK running for some time, does it eventually connect?

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


2 posts were split to a new topic: Remotes unable to connect to Core

It never connects, no. :frowning:

Where do I send the logs to? Thanks!

Hi @William_Boucher,

Can you please share the Dropbox via link and post it here?

Hi @William_Boucher,

Thanks for sending those logs over. It looks like this issue might be media related, I am seeing a few traces in your logs pointing to the following tracks as being problematic:

/InternalStorage/Music/REM/Murmur/03 - Laughing.flac
/InternalStorage/Music/Metallica/Never/08 Orion.flac
/InternalStorage/Music/Lit/Atomic/10 Lit - Slip.flac
/InternalStorage/Music/REM/Murmur/07 - Catapult.flac

Can I please ask you to move (do not delete) these files from your InternalStorage location to a location where Roon is not watching and then reboot your Core? If these tracks are indeed the problematic ones, can you please upload them to Firefox send so that I can get them over to the QA to see why they were causing such behavior? Thanks!

I booted up my server (I completely shut it off being that it is unusable), and it actually worked for a bit, without removing the files. I removed the albums listed above completely, and left it running for a bit. I then rebooted it, and I’m back to square one… I wish I could go back to 1.6…

Here is a new set of logs. Hope it helps.

Hi @William_Boucher,

Thank you for sending the new log package over. I’m seeing Roon getting stuck on these files during analysis, can you please try to move these as well and let me know if it helps?

/InternalStorage/Music/Eels/Blinking Lights (DIsc 1)/12 Eels - Mother Mary.flac
/InternalStorage/Music/Eels/Daisies Of The Galaxy/12 Eels - Wooden Nickels.flac
/InternalStorage/Music/Eels/Blinking Lights (DIsc 1)/13 Eels - Going Fetal.flac
/InternalStorage/Music/EPMD/Business Never Personnal/05 EPMD - Head Banger.flac

Removed those tracks as well. No dice. It was doing the same thing. I clicked “Reset” under "Roon Database & Settings, which worked. Left it import and fully analyze all my tracks. The server was running for over 7 hours, working perfectly during that time. Once I reboot it, I’m right back to where I began, with the Roon Server Software resetting every 12 seconds…

Hi @William_Boucher,

Thanks for sending the new log package over. I’m looking over it and I’m not seeing any signs that this is pointing to media anymore. I know you mentioned this part previously:

please confirm - did you restore the database after resetting it in the WebUI or was this a fresh database?

If you started off with a fresh database and you didn’t restore from a backup, it sounds like this could be a hardware issue. When we have strange symptoms such as these even after wiping the drive, it could indicate issues with the SSD or RAM.

I would run Memtest x86 to check the RAM aspect as a starting point.

I started fresh after the reset. I did not import old settings.

I ran memtest, no issues. It ran its test 4 times. I don’t suspect a hardware issue, everything was smooth until 1.7. I actually installed Windows 10 earlier today after memtest, without any issues whatsoever. I checked the SSD with the manufacturers software, it shows the drive as healthy with an up to date firmware. I’ve now installed Roon on that installation of W10. I’ll see how Roon behaves on W10 on that machine, but I much preferred the elegance of running ROCK. I can only assume that something changed in the 1.7 release and it doesn’t like my machine. :frowning: I honestly wish I could go back to 1.6. That was rock (no pun intended) solid.

Hi @William_Boucher,

Thanks for running memtest/checking the SSD.

Please do let me know if Windows exhibits the same behavior, also I would make sure that you are on a private network (not public) using these instructions and Roon/RAATServer has been added to the Windows Defender firewall as exceptions.

Unfortunately, this is not possible.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.