Remove duplicate tracks? [Can't remove from Roon Library]

Is there a way to remove duplicate tracks?

I found a post here that described how to remove duplicate albums (using focus tool and picking the duplicate option), and I followed that to get rid of a bunch of duplicates, but I still have duplicate tracks remaining. Unfortunately the focus tool in track view doesn’t have a duplicate option.

So far I have just sorted the track view by name and am going through the list manually finding and selecting tracks, but it is taking forever.

Also, I have one album/track that seems to be stuck in my library as a duplicate. While viewing it I deleted it on disk, and now it won’t go away. Editing it to delete the track just tells me the file isn’t there, and it remains in the library. Should I put a dummy file in place so it can delete it?!

Settings>Library>Library Maintenance>Clean Up Library
There are options here to have those phantom entries removed from your library database.

How many duplicate files do you have? Dozens, hundreds? If it is a lot, you may your library storage set up such that the same folder(s) are being watched more than once.
If it’s just a few duplicates, you can go to Settings>General>Show Hidden Tracks and Albums and see if it is set to No. Setting it to yes will suppress display of tracks and albums Roon thinks are duplicates.

I tried that, sadly the numbers there are all 0 so I can’t use that feature.

Maybe a hundred more or so to go (I hope it’s not more!..). It’s because I merged different music collection folders to try and get all my music in one place for Roon. Roon itself is only looking at that 1 folder.

I don’t want to just hide them, but get rid of them from disk.

So you can physically identify that a specific track has been deleted from your file system (by file explorer, for example), but it is still listed as being present in your library?
How did you remove the track, through Roon or by File Explorer? If the latter, you may need to have Roon rescan your library. Settings>Storage>‘burger dots’>Force Rescan

Correct, it’s not there in file explorer. It’s in the library. Trying to delete it from the library tells me the file doesn’t exist. Feels like a bug/oversight to me. A deletion operation shouldn’t fail because something is already (partly) deleted.

I removed it with File Explorer. I already tried a Force Rescan, but it didn’t help.

I removed many other files with File Explorer and Roon picked up those deletions automatically and auto-removed them from my Library just fine. The only difference with this one was that I was looking at the track in Roon when I deleted it with File Explorer.

Okay. Let’s move your post over to Support where Roon Technical people can assess the problem.

Hi @Sendu,

Just to verify — These duplicates are specific only to Roon and do not appear in the storage location, is that correct?

Where are these tracks stored? An internal drive? A USB drive? A NAS?

What kind of Core machine are you using?

Can you share a screenshot of Settings > Storage?

The “bug” is related to a single duplicate that does not appear in the storage location. (My general question on how to remove duplicate tracks is related to duplicate files with different names in the filesystem.)


A headless Ubuntu box that has the NAS mounted in /mnt.

I’m not home right now, but can supply that later. However, I can tell you that Roon is watching a single folder.

How do you just wipe the Roon library completely and start fresh? Import doesn’t take that long anyway for my small library.

Hi @Sendu,

If you want to start completely fresh, please see these steps:

  • Make a Backup of your current Roon Database
  • Close Roon on the Core machine
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.