Removing Watched folders [fixed]

How long should this take? I’ve moved my Roon music files to a new NAS but removing the old folder seems to be taking a very long time.

[Edit] I’m using RoonServer on a MacMini 2.3GHz i7 running El Capitan. My library has about 130k files. Currently the “Removing” message has taken about 2 hours. [/Edit]

Hello @dpstjp, it should take less than a minute. Try to restart the client and repeat the procedure. If nothing will change ping me or @mike


Did that still hung.

Got bored, reinstalled. Still poor.

This needs some working on methinks.

Just to add that I get the same.
I have a watched folder which is a network share using afp, which I know doesn’t work, but can I remove it. Nope

2012 i7 Mac mini with roon server v70 and synology nas.

@weedos, @dpstjp - I’d like to check your logs, so I’m going contact with both of you over PM in a while. Thanks for your patience.

@vova I’ve just sent the logs to you.

Yes I have a smb share to the same location as the afp share, which works fine.
The afp share is /volumes/Data/Audio/Music
The smb share is smb://NAS/Data/Audio/Music

On the NAS afp, smb & nfs sharing is available as to which I use, its probably all of them, as I have multiple macs, iOS devices and a linux pc on there network.

Tried to send logs, but it hangs in the same way. The emails I sent to community at roon etc bounced back with errors.

Are you responding to private messages here on Community, or are you using your email address? Email responses are not currently supported, so whether you’re posting in public or private threads, you’ll need to do it on the site.

@weedos, @dpstjp thank you guys for cooperation, we were managed to reproduce the issue, it is with the dev team now. I’ll update this thread as soon as the problem is fixed.

Hello again, now from this thread. I am getting a little tired of Roon’s bugs and problems. I used to have 3 issues after last builds. : infinite analysis; need to restart roonserver in the mac mini every time I open roon remote in my macbook pro; and impossibility of deleting/disabling watched folders of my NAS. Now it looks that I have two: after being stacked with one file for the whole night, now Roon finished with the analysis. However, still no progress with the other two: the connection b/w both computers depends on restarting and, what it’s worse, since i am not able to remove a folder, roon fish over all of them (one filled with old alac files; the other with the reconverted aiff filles of the same music).
And btw, I have also another “complain”: is there a way of publishing common solutions to these 3 already common problems as everybody else in the market do, instead of going log by log, customer by customer, thus taking out of the forum the long awaited solutions? Are they so specific? Since the problems look so similar, why the solutions differ so much so as not deserving publishing? Hope that finally those very quoted issues would be solved. We are talking about one of the most expensive, if not the most, expensive players in the industry.

Hi @ridom – like I mentioned the other day, we have thousands of people using Roon who aren’t experiencing these issues, including our staff and our internal team of testers. We also have a handful of people (something around 10) who are having some problems, and we’re in the process of gathering information, and investigating what makes their respective setups distinct.

It could be something related to a common piece of hardware, a certain way of configuring your setup, certain kinds of media, or a bug in Roon triggered by some combination of those. Either way, we’re actively working to figure out what’s triggering the issue, at which point we’ll likely make a change in the app, and if possible provide a workaround. I assure you, if we had a simple fix right now, we would make it known.

The investigation is ongoing, and is proceeding as fast as it can, so all I can ask for at this point is patience. If you’re really unhappy with Roon, send me a PM and we’ll work something out for you. Thanks @ridom!

Besides stats, I hope that you will produce some kind of fix in the near future. In the meantime, I will go back to the preRoon era with Jriver. Less glamourous, but at least more stable for me and my system

I am now focused on the issue of restarting Roon Server in my Mac Mini everytime I open Roon Remote in my Mac Book Pro. When the program starts to look for the library without success, the log action in my Macbook pro is

11/16/15 18:11:11.897 Roon[9289]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.5 instead of 10.10.5. Use NSProcessInfo’s operatingSystemVersion property to get correct system version number.
Call location:
11/16/15 18:11:11.897 Roon[9289]: 0 CarbonCore 0x9541c291 ___Gestalt_SystemVersion_block_invoke + 135
11/16/15 18:11:11.897 Roon[9289]: 1 libdispatch.dylib 0x90cf7430 _dispatch_client_callout + 50
11/16/15 18:11:11.897 Roon[9289]: 2 libdispatch.dylib 0x90cf73b7 dispatch_once_f + 251
11/16/15 18:11:11.897 Roon[9289]: 3 libdispatch.dylib 0x90cf7477 dispatch_once + 31
11/16/15 18:11:11.897 Roon[9289]: 4 CarbonCore 0x9539569d _Gestalt_SystemVersion + 1050
11/16/15 18:11:11.898 Roon[9289]: 5 CarbonCore 0x953947c0 Gestalt + 150
11/16/15 18:11:11.898 Roon[9289]: 6 libHIDRemoteNative.dylib 0x05511746 +[HIDRemote isCandelairInstallationRequiredForRemoteMode:] + 38

Hope this helps. Regards, Ricardo

Thanks @ridom @dpstjp – good news! As Vova mentioned above, we have figured out how to reproduce this issue, and we’ll be working on a fix for a future release.

Very sorry for the trouble here!

Those are good news certainly.
In the meantime, I will "hybernate"my Roon version and wait for the solutions. Unfortunately, there is no log action to be sent for the other bugs that do not allow me to use Roon: the rescanning process that starts over and over from around file # 2000; the abrupt disappearing of files which reappear only after a manual re-scan; and the impossibility of deleting library folders. Hope that everything will be solved sooner than later.
My best, Ricardo

@vova Something weird has happened. Still got v70 on the mac mini as the Roon core controlled either by an iPad or macbook pro. Suddenly on both remotes I am now getting duplicates of every album in my collection. Tracked this down to the errant afp share I cannot delete, but now instead of showing an error, it shows it as a valid connection

Can I remove it? Not a chance, still as it was before. I have done nothing to either the macbook or the iPad to my knowledge that would have caused it. Any suggestions?

Hey @weedos – are you running RoonServer or Roon?

Also, are you able to disable one of the two folders?

Hey @mike. No I wasn’t able to delete the afp share, Roon just hung as before. My first thought was to try and delete it. However the NAS and mac mini are set to turn themselves off overnight and this morning after they restarted the afp share is back to the expected ‘unavailable’ and undeleteable so I must have done something on the mini yesterday.

Further investigation reveals. If I manually mount an afp share on the mini, the Roon settings show

as opposed to the usual, when there is no afp share mounted

However if I manually mount it as an smb share, then I get the 2 shares showing

So it looks like I must have manually created a smb share on the mac mini and there is so magic happening here. Although I still cannot delete the afp (Volumes/Data/Audio/Music) share, whether it is available or not.

Thanks @weedos – and you’re running RoonServer for your Core?

I’m running roon server on the mini