Repeated issues loading database and instability problems

Roon Core Machine

Windows 10 x64
ACER Intel(R) Core™ i7-4790 CPU @ 3.60GHz 8GB RAM

Networking Gear & Setup Details


Connected Audio Devices

USB DAC / Google Home / Sonos

Number of Tracks in Library

95,000 tracks

Description of Issue

Whenever I start Roon I receive a message “There was an issue loading your database …”
I have tried renaming the old Database folder and also have tried fresh installs of Roon. The new database will load completely but will then produce the error message or else simply close down.
Since upgrading to Roon 2.0 build 1128, the same thing happens.

Hi @Derek_Dottie,

Please accept my apologies on behalf of the team that you’ve endured such a long wait time. I recognize Roon has been entirely non-functioning with a database issue on your Core, so we’ll be prioritizing this thread to make sure you receive more prompt and immediate assistance moving forward.

Looking through more recent automated diagnostic reports from your account, it would appear you’ve been able to play back some tracks from Roon 2.0 on your Windows 10 Core in the last week. Diagnostic logging is only available for the last ten days or so, so I’m assuming you’ve refreshed your database (Roon_old) in the meantime?

There are several apparent issues we can assist you with:

  1. There’s instability reaching your storage locations; two separate external storage locations are failing sporadically. They might be password-protected, or the mount is otherwise failing for some reason If your library is small enough to host locally on your Core, we’d recommend local storage on the device for users who experience instability in external storage or the USB bus.

  2. There are 401 requests returning from Roon’s servers on a number of unrelated services, beginning with a login attempt. Requests from your Core are returning unauthorized. I’ve verified with our accounts team that your subscription is active and up-to-date, so this is unlikely an issue with your Roon credentials unless you’ve auto-saved them incorrectly on your device. It’s possible there’s a Windows firewall issue on your device, or a network firewall in your network, preventing certain requests from reaching our servers properly. You’ll need to add Roon and associated processes, if you have not already, to your Windows firewall exceptions. Please follow these instructions to add exceptions and the executables themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

  3. Lastly, on an unrelated note, there are illegal characters in some of your .m3u playlists preventing Roon from importing them. I suggest you review the guidelines for .m3u text formatting here to verify everything can import properly.

Thanks Connor.
19 days after first submitting my original post, I’m continuing to try and establish a stable system.

Hi @Derek_Dottie,

I’m sorry to hear that you’re still having difficulties.

I then recommend you verify step 2) above regarding firewall exceptions, and double-check your Core’s ethernet connection the router and internet. If authorization requests can’t reach our servers due to a latent networking or firewall issue on your system, almost nothing in Roon will work properly, beginning with the loading of your database.

Would you mind clarifying a little about your network infrastructure? What make and model router are you using? Do you have any other network hardware in your setup, like managed switches, access points, or a second router? More importantly, do you have any firewalls or network security enabled on your router?

We’ll be watching for your next post to promptly assist.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.