Repeatedly Losing Connection

I’m losing my connection to the Roon Core every minute. Very annoying. I can’t even try it out :frowning: I’m pretty unhappy.

Should I just delete the content of my RoonServer folder and reinstall?

Hey @jaapaap – can you give us some details of your setup?

My core is installed as RoonServer on a QNAP TVS 1271, i7 and 32GB. My clients are a Windows 10 PC and an iPhone 7. My library has about 1k albums and 12k tracks.

Ok, could you zip up the Logs folder from your database and get them over to me?

If you have Dropbox and can send me a link, that would be great. If you don’t have Dropbox, let me know and I’ll give you a way to upload them to our server.


Thanks, @mike. I’ve only setup Dropbox today to see if I could back up my database, but I’m not familiar with it otherwise. Could I send you the zip in another way?

Sure thing – will send you a PM momentarily.

Thanks, @mike.

FWIW, I nuked my Roon QNAP installation and RoonServer folder and reinstalled from @crieke’s package and the exact same problem occurs.

I see stuff like this in the log. Perhaps that’s related?

02/02 00:47:38 Error: 
Local Time:            02/02/2017 00:47:38 -05:00
Device Serial Number:  abc
User Id:               xyz
Roon Version:       1.3 (build 193) stable
OS Version:            Linux 4.2.8
Mono Version:          4.6.2 (Stable Wed Jan 25 15:24:22 EST 2017)

Application Domain:    RoonAppliance.exe
Assembly Codebase:     file:///share/CACHEDEV1_DATA/.qpkg/RoonServer/RoonServer/Appliance/RoonAppliance.exe
Assembly Full Name:    RoonAppliance, Version=, Culture=neutral, PublicKeyToken=null

   Exception Source:      mscorlib
   Exception Type:        System.InvalidOperationException
   Exception Target Site: ArrayListEnumeratorSimple.MoveNext
   Exception Message:     Collection was modified; enumeration operation may not execute.
   Exception Data:        none

   --[ Stack Trace ]------------
       mscorlib.dll, IL 32, N 543
   System.IO.InotifyWatcher.ProcessEvents(Byte[] buffer, Int32 length)
       System.dll, IL 874, N 2134
       System.dll, IL 60, N 159
   System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       mscorlib.dll, IL 23, N 131
   System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       mscorlib.dll, IL 141, N 505
   System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       mscorlib.dll, IL 0, N 35
   System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       mscorlib.dll, IL 49, N 91
       mscorlib.dll, IL 11, N 47

Hi jaapaap,

I’ve got the logs, and I’ll review them in the morning when I’m awake again. I think the problem is related to that message.

Is there anything else at all on your QNAP system that might run at a 1 minute interval that might help us reproduce this problem? Any sort of scheduled anything at all?

Thanks for the logs, and I’ll be in touch if/when I find anything.

I have the same issue since upgrading to 1.3 - pretty much unusable. Both my iPad air 2 and android galaxy note show constant loss of connection. When that message shows up, music playback stops. I am running roon server on a QNAP TS453 Pro with 8GB RAM with the server installed on a dedicated 1TB SSD. The processor is a Celeron J1900 @2.0 GHZ. Firmware is QTS 4.3.2. I had no issues whatsoever with previous Roon versions with this setup.

Same here (repeated disconnections) with RoonServer 1.3 (build 193).

  • QNAP TVS-471 with 4GB RAM
  • Server installed on a 128 GB SSD.
  • Squeezebox Touch
    No problem either with the previous Roon version.

Same here with a TVS-671, firmware Constant disconnections.
I wonder if this is happening while the analysis is going on, and if it may subside once it finishes ?. I’ll be able to check in the morning…

@evanw, @Thierry_Meulemans I contacted both of you to get logs. Thanks

I run Plex and a QNAP’s dlna server. But I don’t know if they do anything every minute or so. Also I run a virtual machine on it.

I saw that audio analysis is stuck at the first track and not moving forward. I tried ‘fast (1 core)’ and also stopped it altogether. Neither made a difference.

We believe we have a fix for everyone that has an error that looks like this one in their logs. The build with that fix should hopefully go out later today, although possibly much later today.

@evanw, @Thierry_Meulemans, @Thomas_Scheidig, I don’t believe we have logs from you guys yet, so this may or may not solve your problem. If you get vova logs we can check or see if we need to fix something else.

I am experience the same situation i.e. constant drop outs. Will try to check logs later.

Also - I have also noticed that the QNAP CPU via the Resource Monitor has been at 50% to over 90% for most of the day. It would appear that Roon 1.3 is a lot more processor intensive? Yesterday I was surprising low. FYI I only installed RoonServer this week so have been looking at lot at resource/memory uses.

QNAP specific issues aside - it looks like a major upgrade with excellent new features!

1.3 will do a lot of audio analysis that takes a long time. How long? Depends on a lot of things, library size, file transfer speeds, etc. Once analysis is done, cpu usage should drop down. You can test it out by turning off audio analysis in the settings and then monitor CPU usage.

I am not very technical with regards to Linux and have no idea how to get to the roon log. Can you send some detailed instructions? I can do that tonight. I am running Rieke’s version. Thank you.