Reset Roon ARC Required for Port Forwarding Despite "Ready" Diagnostic

Hello @connor. This is still happening for me.

Yesterday it happened and I got it working again using the Reset Roon ARC command at the bottom of the Roon ARC options.

This is on two devices, Google Pixel 6 Pro and iPad Air. I’m running Roon ROCK on an Intel NUC 10 Core i7.

Today it has happened again on both devices and it says the Roon Core hasn’t been seen for 1 day.

I’m in the house right now so I’m on the internal network. If I disable Wi-Fi on my phone so that I am on the mobile network instead, it still doesn’t work.

According to Settings / Roon ARC in the Roon app, there is no problem and it should work. And looking at my router under uPnP settings, it shows that port 55000 is being forwarded to the IP address of my Roon ROCK.

In case this is relevant, I was playing with backup and restore yesterday. I created a backup and restored it to make sure that works fine. I wonder if this has something to do with it? Just a long shot.

The reason for suspecting restoring a backup is because at the end of that process, it says to press a button to restart, but then it says it can’t find your Core and you have to select another one. So you select the only Core there is (the same one) and then it’s OK. This seems suspiciously similar to ARC not finding your Core, but if you do a reset then it’s fine.

Hi @bananasareyellow,

I’ve split your post off into a dedicated thread where we can address the issue more precisely. While the other reports were due to a Roon temporary server outage that was resolved on Nov. 14, your own issue appears to be related to authorization within Roon Core.

Do you have a VPN enabled on your network? What about enterprise- or corporate-grade security or network infrastructure? On first pass through diagnostics, it would appear that basic requests from your WAN to Roon’s servers aren’t getting through.

Prior to restoring the backup, have you migrated Cores recently between any of your other computers? On occasion, migration issues can trigger authorization failures.

The team is standing by to investigate further and we’ve pulled logs from your account. Once we’ve clarified a little about security settings, we’ll dig in deeper. Thank you for your report and we hope to resolve your issue promptly.

Hello @connor,

I don’t have VPN enabled, nor do I have unusual security, but I do have a Pi-hole running as an ad-blocking and tracker-blocking DNS server.

I have not migrated Cores recently. My experimentation with backup and restore was in preparation for having a second Roon ROCK running at a second home, but at the time I reported the problem, I had not purchased the NUC for the second Roon ROCK.

I will do some experiments to see if I can reproduce the problem using backup and restore. I’ll also look at my Pi-hole log to see if anything is being blocked.

I’d like to add one recent experience - it may be something in your immediate setup or a software problem, but it doesn’t have to be.

My ARC was working fine. Then one day it stopped working, can’t connect to core. A port scan from my phone suddenly showed the ARC port as closed. The router still had the port forwarding in place and previously the port had showed as open in the scan, as it should. The Roon ARC settings showed “Ready”. It was close to midnight, but I could not bear it and started taking things apart. Hours later I gave up and went to sleep, way too late.

In the morning I dragged my carcass to work. Lo and behold, it worked from the work’s LAN. I installed ARC on a colleague’s phone, using a different mobile provider, it worked. My phone still did not.

Driving home in the evening, I started preparing for a terrible night of stabbing in the dark again. Coming home, I tried again and … it worked from my phone. Then I learned that, starting the previous day, there had been some kind of large-scale cell phone outage in the German cell network, with some providers not being able to establish service at all, while some, including mine, not affected much. I don’t know for sure, but it’s possible that when this started, they might have shut down non-essential services quickly, and, who knows, may have closed down ports within their cell network.

Lesson learned: Patience is a virtue. :slight_smile:

I did some experimentation just now.

I have Roon ARC on two devices:

  1. iPad Air on Wi-Fi.
  2. Google Pixel 6 Pro on mobile (Wi-Fi turned off for this experiment).

On both devices, Roon ARC works fine. When I open Roon ARC, it updates after about 4 seconds to show the recent albums I was playing last night, so that’s good.

Then, using the Roon app on my laptop, I restored the latest backup made in the early hours of this morning. My laptop uses Pop!_OS (Linux), so I run Roon in Bottles (alternative to Wine), but I don’t think this is relevant.

At the end of the Restore process, I see this:

The IP address is correct, so I don’t know why it says Connection failed.

So I closed the Roon app and then opened it again. Now it said this:

Sorry about the tooltip in the screen capture, but you can see it no longer says Connection failed and now says Ready. So I pressed the Connect button to proceed. Now Roon is running again after the restore.

Looking at Settings / Roon ARC, everything is well:

And according to my router, everything is well there too:

But starting Roon ARC up again on my two devices, both of them initially say, Poor connection, shortly followed by, Can’t connect to your Roon Core. There is a message at the bottom of each device saying, Core last seen x days ago (9 days in the case of my iPad, and 4 days in the case of my phone).

So the problem is reproducible.

As I mentioned before, my approach to fix it is to use the Reset Roon ARC command at the bottom of the Roon ARC options. But then Roon ARC shows two possible Cores:

If I catch it while it says Online and ready, I can connect and then all is well, but it seems to struggle to get to this state and most of the time, looks like this:

I hope this information helps.

P.S. Looking at the Pi-hole Query Log with a search for “roon”, there does not seem to be any domains being blocked.

1 Like

Seeing two instances of the same Core on the ARC page is very strange. Looks to be some sort of network addressing issue?

I have two Cores, and if I reset ARC, they both show up just once, as expected…

Remember, I have two control devices, one internal to the network, and one external:

The symptom of showing two Cores happens with both of them. My hunch is that there’s something about restoring a backup that changes the identify of a Core, so the two Cores are the identify before the restore and the identity after the restore.

This person seems to have a similar problem:

I don’t think so. I’ve done test restores and never seen this issue. Let’s see what Support has to say…

Hello @connor,

Any update on what might be causing this? I now have a second Roon ROCK core at a second home. After travelling back to my main home and restoring a backup created at the second home, Roon ARC needs resetting again, and now it shows 3 possible cores.

I sometimes run Roon Server on my Pop!_OS laptop, although I haven’t done so for a few months now (before Roon ARC came out). This was to take to our second home. Later I decided to simply take my NUC with me, and more recently I’ve set up a second NUC to leave there.

On the laptop before going, I’d restore a backup from my Roon ROCK, and when I got home again, I’d make a backup from the laptop and then restore that on the Roon ROCK. I think I only did that once, maybe twice, before I started taking my NUC with me instead.

When home, I would disable the Roon Server on the laptop because I’d now be using my Roon ROCK instead.

sudo systemctl stop roonserver.service
sudo systemctl disable roonserver.service

When I wanted to use it again, in preparation for going to the second home, I’d first enable it again as follows:

sudo systemctl enable roonserver.service
sudo systemctl start roonserver.service

I can see it is disabled now, as it has been for a few months:

systemctl status roonserver.service
○ roonserver.service - RoonServer
     Loaded: loaded (/etc/systemd/system/roonserver.service; disabled; vendor preset: enabled)
     Active: inactive (dead)

Is it possible that this is the phantom Core that is causing the confusion?

Is anyone looking at this?

I’ve not been to the second home since I posted about it a week ago, so that Core has been de-authorized. I just tried the steps again and the problem is still there:

  • Restored the automatic backup from the early hours of this morning.
  • Now Roon ARC cannot connect to the Core. Says the Core was last seen 12 days ago, but I’ve opened Roon ARC in the last few days.
  • Reset Roon ARC from settings.
  • Shows two Cores, but I only have one of this network. One Core seen less than a minute ago, and the other Core seen 2 hours ago.
  • Wait for the first Core to be online and ready. Connect and now all is well again.

Can you please try restoring a backup on the same Core to see if this is reproducible?

I enabled and started the Roon Core on my laptop. Then I stopped it and installed the Early Access version since my control apps are on that. I wanted to see if this deactivated Core was causing any problems.

Then I repeated the process: While connected to the Roon ROCK, restore the last automated backup. Now Roon ARC can’t find the Core and I have to reset it.

So it seems the Roon Core on my laptop is irrelevant.

This is repeatable every time for me.

Note that after a restore has been done, other Roon remotes see this:
Screenshot from 2022-12-16 11-02-53
But the only Core on the network is my Roon ROCK (my laptop Core is now stopped). If I press the button, my one and only Core is there to connect to.

Dear @support

It has now been 3 weeks since the reply from @connor that said The team is standing by to investigate further and yet nobody seems to be responding to my problem.

There is something about restoring a backup that means the Core is no longer recognised as being the same Core, either by Roon ARC or by Roon control apps. This is reproducible, for me at least.


Hi @bananasareyellow,

Please accept our apologies for the lapse in responding.

This has proven absolutely true; there was a keypair matching issue affecting certain migration and backup restore situations that we resolved several builds previously. Are you still seeing issues when you switch between Cores? Perhaps we’ve tried your patience with overuse by stating we’ll look into diagnostics, but if you’re able to reproduce this problem, rest assured, the team will reproduce it internally and investigate thoroughly.

We’ll keep an eye out for your response.

The problem still occurs.

I have Roon ROCK on an Intel NUC 11 Core i5. As before, I used two devices to test Roon ARC:

  1. iPad Air on Wi-Fi.
  2. Google Pixel 6 Pro on mobile (Wi-Fi turned off for this experiment).

Both were working fine before the test.

Using Roon on my laptop, I restored the last backup which was created in the early hours of this morning. At the end of the restore, I saw this:

I pressed the Relaunch button and saw this:

This does not seem right. So I closed and restarted the Roon app and I then saw this:

I pressed Connect and now the Roon app was working fine.

Next, I opened Roon ARC on my two devices. In both cases, the Core could not be found. Here are the screenshots from my phone:

After a while, this changed to:

It says, Core last seen 1 month ago, but I was only using it 10 minutes ago.

So I went to Settings and pressed Reset Roon ARC. Then I saw this:

I only have one Core, so why are two listed? I pressed Connect for the one showing as online. But then I got this:

After a while, it went back to the previous screen offering me to choose between two Cores. So I closed the Roon ARC app and restarted it. It still listed two Cores but this time I was able to connect to the one shown as online.

On the iPad (connected by Wi-Fi), I had the same problem with two Cores being listed. but I didn’t need to restart the app to get the connection to work.

Also, now that the backup is restored, the Roon control app on all other devices now wants me to select a different Core. I restored the backup on my laptop, but now when I open Roon on my phone, I see this:

Same for all other devices in the house.

Restoring the backup has also triggered a reappearance of this problem:

Just as I reported in that post, with my iPad I could select a Core (why do I have to, it’s the same Core?), but with my Android phone, I get this:

If I go to the other end of the house, so that I connect to a different WiFi access point, it can connect just fine. I’m sure this problem is triggered by restoring a backup and it’s not a problem with my network.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.