Restart only option for "No Audio Devices Found"

MacOS 10.14.6 i7 8core 4.2 64GB 8GBRaedeon Pro 580 / Roon 1.6 Build 475

Audio Hardware involved:
Mytek Brooklyn DAC+ firmware 1.25

I have been getting, since installation, the message, “No Audio Devices Found” after I close Roon and then reopen it later or if I turn off the DAC+ for the night. When I reopen Roon or Switch the DAC+ back on I get the problem message and no apparent way to find any of my hardware. The only fix I have found is to restart the computer. I for one do not consider this an appropriate “fix”. Why do I have to restart the machine just because I closed the program? Something must be fouled up somewhere.

You haven’t described your network, have you tried turning off the iMacs firewall?

How does my network come into play, humm, ok? I won’t turn it off, but I can certainly give it a shot on the list of programs able to bypass the firewall. I will see how that goes.

It maybe relavant if you’re expecting devices to communicate over it?

1 Like

Um these devices do not connect over the internet. They are local hardware and more importantly software running on the computers hardware devices/programs. They have nothing to do with the internet as far as their communication with one another. They connect over USB and internally, not the internet. They do not go out to the internet and back again to connect over a USB cable. Same goes for the hardware of the computer, it does not go out to the internet and back to the system where it then processes information.

These devices do not communicate over the internet, they communicate over a decent USB cable and through the hardware of the computer itself. To the best of my knowledge this problem has all the signs of being a software problem, not hardware or internet/network issue.

Here is one reason why I know that the firewall has nothing to do with it. During installation the program would have asked for permissions to either bypass the firewall or have special permissions in order to complete the installation properly. It did not. It installed without the need for any special firewall allowances. It also has not at any point, asked for or indicated that there is a problem with the program being blocked or hindered by the firewall in any way whatsoever. It runs without the need for altering the firewall permissions. On a Mac, I would be informed if a program needed access to the internet but was being blocked by the firewall. Maybe that is just my setup, but be sure I would be informed it a program was being blocked by my firewall.

Ah, no.
That does absolutely nothing at all.
Back to No Audio Devices Found…
Reboot Time

When the device is in the not working state with Roon, can you play to the Mytek with different software, i.e. it is only Roon having the issue.

Um, Yes?

That however is not a solution for the problem posted here. I know that the problem is with Roon. Roon is what I posted about. I have lots of other programs on my computer. By the same logic I could just not listen to music, that would give the appearance of solving the problem as well.

I do not like spending $119 or any money on something that does not particularly work. Being someones test monkey should, at least, be free. It is criminal to release software as a finished product when in fact it is not at all ready to be released. Don’t misunderstand, this program has great potential, it is just not ready for prime time.

We are, unfortunately, the dim-wits who unknowingly signed up to be it’s paying (not payed) software testing and debugging crew, it would seem. I mean we are not even doing this for free, we actually gave them money to do this for them! They have pulled a Tom Sawyer (or was it Huck Finn? Guess it’s time to read that one again) on us. They even have a form for us to follow in the forum providing as much information about our system and network and music hardware etc. as we can stand to give, asking us to be as detailed as possible. What shills we are. How they must laugh at us while they revel in their ingenious plan to have workers who actually pay them for the honor of doing their work for them.

Off subject tirade/rant/life-sharing/lesson/sermon/run-on ------->
It reminds me of one of my early photography jobs that actually “achieved” much the same thing. They brought on photographers who were given jobs where they used their own cars, gas, food etc… The only thing that the company supplied was a trunk of simple medium format camera gear and the days jobs to drive around to do. You would, at your expense, drive all over hell and gone doing shoots, try to sell the photos with none in hand, then drive back turn in your gear and film. They took the film developed it and turned the real business over to the people who brought home the bacon for the company. These experienced sales people would be the actual people who would sell your photos to the customers, it was where they made all their money. The photographer would be told that none of the photos you tried to sell were chosen, better luck next time, it takes some time to get good at this, etc… Well I only took about 2.5 weeks before I was sure it was a con (I was suspicious on the first day). I finally got to talk to some of the other photographers. They had a no talking rule in the morning meeting area, which I realized was a nazi tactic employed to keep us ignorant of what was going on. I mean they quite literally told us not to talk to one another, with a threatening tone and a real threat of being fired! I ignored the stazi completely. Which is when I made contact with another photographer who had similar suspicions. We would talk each morning checking in with each other, she continued to have the same experiences that I was having. We finally had a chance when the supervisor stepped out, to ask some other people if they had ever been paid! We learned that other photographers had similar situations and had been at it for months and even years without pay! The supervisor returned to a roomful of heated conversation, he was not pleased LOL. That solidified it for me, I was surprised that the woman I was chatting with, said she was going to stay for a little while longer. I knew, however, then and there, that they were getting desperate photographers who wanted to break into the difficult photography business. They were getting them to pay for all the expenses involved in running around taking the photos including the cost of their photography and never paying them a dime.

Soak on that misery.

Well, it’s extremely difficult to offer constructive help when the only responses are “Um…”, “Ah, no”, ”Um, Yes”, and long rants. You could try selecting “System Output”, or “Core Audio” in Roon. If this works, then I would suggest you give the Mytek forums a try, perhaps there’s a new firmware out.

Right ok, I am not sure what parts you are reading but ah and um is most certainly not my only response. I guess it’s a habit of mine. I write like I speak, I tend to type out the spaces in my train of thought. Perhaps it’s a bad habit, some people like it.
I would say too that my posts are typically rather long, well beyond um or ah. Quite verbose actually. In fact I would say that last post of blurbus de cradoo, that I would probably not have even read myself LOL. Although it is kinda interesting. Um, alright, I would have read it anyways, too curious not to.

The long story post area was clearly marked as such and no one forced you to read it. It was separated from the rest of the dribble for just such a reason, so you would have a choice to read it or tune it out. It was labeled off subject etc. after all. It even had an arrow pointing to it so no one would miss the bit about it being off topic and a bit of blather on something that happened to me. It was wrongly marked as a rant (rants are usually anger based and my post was not based on anger), it was really a story about something stupid that happened to me on the way to the forum LOL. It was sparked by the whole unpaid labor thing. I do not know what emotion I would assign to it, but anger is not one of them. Weirdness, or disgust in fellow man would be closer. ‘Weirgust’, there I am adding that to my dictionary.

A critique of my particular writing style does not help things either. Why you are personally offended by it, I am not sure. Are you a high school English teacher perhaps? Humm…

As to the Roon problem, I do not think you understand, the software (Roon) cannot find any devices including system, core, etc. nothing, it is a blank page. Again it says it cannot find any hardware devices. That does not mean just the Mytek, it means, Mac’s CoreAudio, the Roon Core, the Midi control, Nothing, Zero. It does not remember one piece of audio hardware on the machine. It (Roon) has ‘forgotten’ them all. Just from closing the program and opening it up again.
It has nothing to do with the Mytek there are no problems with the Brooklyn DAC+ It works impeccably in all my other programs. This is a Roon software problem. Not a cable. Not a DAC’s firmware. It is the Roon’s software entirely. I would bet my left one on it. This thing has more bugs than a forest. The whole jiggle the cable while standing on your head and rubbing your tummy, is not going to work here. :nerd_face:

Sorry, I do appreciate your attempts to help however.
I am also sorry you are offended by the way I write. I am told by my professors that I have a wonderful style of writing. They enjoy reading my essays and papers. I don’t think they would say so if it wasn’t true. I don’t know any professors who give out praise to butter up a student (maybe they think I will donate a wing or something LOL). Oh and before you think you have some young kid you can push around, I have returned to college quite late in life.

Anyway I suppose there is no actual fix for this problem. The programmers probably all work on Windows and so they would not be fazed by a reboot. Whereas in Apple land a reboot is like being kicked in the nether regions. I suppose they will eventually release a build that addresses how the program deals with the actuation/acuzation and release of the hardware.

1 Like

Yup, I have seen that ‘no devices’ behavior. Nope, I have not found a fix…other than using Plex, maybe.

Your posts are rather long. But, heh, if it’s therapeutic, type away.

Hi @RetroSoundBird,

I’m looking through this thread and I see that the main issue at hand here is that Roon does not display any audio devices after the app is restarted, correct? And this behavior remains until you reboot the Core machine.

I would suggest that you double check the firewall, I would make sure that both Roon and RAATServer have been added as exceptions to your OSX firewall by using these instructions.

If you by any chance have any other Antivirus/Firewall applications on your Core, I would make sure these exceptions are listed there as well (I have sometimes seen Bullguard/Little Snitch/McAFee/Kaspersky cause similar behavior).

Can you check the firewall aspect and let me know if it changes anything?

It wasn’t a solution, it was a question to get more information before suggesting one. The additional information you provided in later posts that was not in the OP provided a much clearer picture of your issue.

As Noris mentioned, the first thing to check is firewalls.

If that does not change anything: your symptoms are very similar to those who have had issues with potentially conflicting drivers or other audio software. For example, on PCs, Realtek audio drivers can interfere in much the exact same way, audio options appear and then disappear on re-opening the program. I have also seen where audio production software and drivers can cause similar symptoms.

Well, I have added all that I could to the firewall including Tidal, just in case. Same problem.
It already had the RAATServer in the list. I actually did add Roon at the beginning of this topic and did not have any luck, but I hadn’t put some other programs in that I could have, so I gave it another try. Ah well, I suppose I could get used to it. LOL

Hi @RetroSoundBird,

Do you by any chance have any antivirus or firewall applications on that Mac? This does seem like a firewall is blocking RAATServer from discovering your audio devices. If you have double check for firewall and you are certain you don’t have any that could be causing such behavior, can you let me know the exact local time + date when your Roon is next in this state (e.g. 5:01PM on 11/12/19)?

Ah well, I did not realize that McAfee ran its own firewall… which it would not let me configure so, I dumped the entire stubborn piece of junk. Problem solved! LOL

Um so, I guess it was software after all, just someone else’s software than originally believed to be (sorry Roon, Dam you McAfee). Nothing like an unnecessary second firewall that you can’t shutoff or configure… what a joke that is. LOL

Thank you for all your help everyone! You nailed it, a firewall running that I was not even aware of. (I can’t believe you could not shut it off or configure it! What garbage.)

Oh and ahh, Rugby, sorry I realize now that I misread your post… so I am a dunce. I thought you were telling me to use different audio software, as a solution to problems with Roon. LOL I thought that was a strange response… should have double checked.

1 Like

Hi @RetroSoundBird,

Great to hear you located the source of the issue :slight_smile:
Hope you have a good day and a continued enjoyable Roon experience!

This topic was automatically closed 21 hours after the last reply. New replies are no longer allowed.