Restore backup fails

Core Machine (Operating system/System info/Roon build number)
Roon Optimized Core Kit, 1.7 build 537,
iMac OSX 10.15.4 with Roon 1.7 build 537

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Creating a backup on my ROCK and copying it onto an external hard drive, then try to restore backup on the iMac which starts but then fails at 31%. Tried with several different backups, same problem. From Roon_log.txt:

04/25 09:50:35 Info: [stats] 8358mb Virtual, 2183mb Physical, 1173mb Managed, 78 Threads,  FDs 
04/25 09:50:39 Error: [backup] failed to restore: getfile hash: Base.MultiDictionary`2+<GetValues>d__18[System.String,Roon.FileSystem.IFileSystemDir]/dcf8ab2b107583cb3d24a30369ae0c0dd3a514c306ef50b82a6ec7a08b5a500b: Result[Status=NotFound]
04/25 09:50:39 Warn: [broker/backups] restore first half failed on FileBrowser.Entry:  Lacie8, LaCie P9237 Desktop Media : /RoonBackups: NotAvailable
04/25 09:50:42 Debug: [broker/backups] on done, auto: False, result: Result[Status=NotAvailable]
04/25 09:50:50 Info: [stats] 8385mb Virtual, 2203mb Physical, 1253mb Managed, 79 Threads,  FDs 

Please help me out here; should this work or not, i.e., restoring backup from ROCK on an iMac core?

Hi @Elling_Jacobsen,

Can you send us logs from the iMac? Please use the directions found here and send us over a set of logs using a shared Dropbox link.


Hi @Elling_Jacobsen,

If you try to use another USB drive to facilitate the transfer of the backup from ROCK to the iMac, does the other USB drive work as expected and just your LaCie drive is affected by this issue?

Well, I tried with 2 different Lacie USB devices (one formatted as Mac OS Extended, and one as ExFAT) and same problem with both. But if you believe it is a Lacie problem, I can try to get hold of another brand to test.

Hi @Elling_Jacobsen,

I have seen a few reports in the past regarding Lacie HDDs, so yes it would be good to verify if the same behavior occurs on another brand USB as well.

So, I got hold of a WD small USB HDD formatted OS extended and first copied the backup folder from the Lacie USB HDD to this one, tried to restore on my iMac but it broke down at 1%. Then reformatted the WD HDD to ExFAT, connected it to my NUC and did a backup directly to this drive. Then moved the drive to the iMac and did restore; success! Most likely Lacie problem then, since I tried the same with a Lacie ExFAT formatted HDD before. Thanks for the help!
PS! Any other known problems with Lacie? Any recommendations for external HDDs for use with Roon?

1 Like

Hi @Elling_Jacobsen,

Glad to hear the other hard drive worked as expected!

I haven’t ran into many issues myself, but if you want to check out what other users are saying about the drive and Roon compatibility, you can perform a search on Community, like so:

In either case, happy to hear the issue is resolved!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.