Restore database not working

I have created a backup of my roon rock database.
Trying to restore it on my new Ubuntu roon server.

When I connect to the new core and choose restore it won’t recognize the backup.

I found an article about this problem and it could be that the roon versions are out of sync. Or worse the rock and Linux databases are not compatible.

Can I import the database later if I login in now and update the roon version to latest roon server?

Roon was designed so that a backup of the server from any OS could be restore onto a new server install on any OS. So this is not the issue.

That could be an issue. However, if you update both Roonservers BEFORE making a backup, they should be on the same version. Remember it is the version of the RoonServer software, NOT, the version of Roon OS, that might matter.

But server versions was the latest
I did the backup on my iPad on the NUC then took the usb and inserted in the roon server and tried to restore it.

I tried to restore a Roon Backup yesterday and it failed too. Sounds like a bug in Roon’s software. What good is a backup if it isn’t bulletproof. There shouldn’t be anything the user needs to do but start a restore.


Try an earlier backup and see if that works.

That worked

1 Like

I ran into a problem like the one you reported. The Backups showed in Setting==>Backups==>Find backups, but wouldn’t Restore… Never really figured out why.

You probably want to delete all your Backups (and, if necessary, the folders) and start from scratch, just to avoid any future confusion.