Restore Function Fails Numerous Times

Core Machine (Operating system/System info/Roon build number)

I’m switching Roon Cores from a HTPC, where Roon has run reliably for a number of years, to a new SonicTransporter i9. I’ve detailed some issues with creating Network Shares which are now resolved in this thread:

Now, a new problem has emerged. Regardless of how many times I backup my Roon Core on the HTPC, the restore function fails on the STi9 around the 7% complete stage. I’ve tried backing up to different shares, including newly created ones, but I get the same failure.

This should work now that the network share is established. Any ideas on what might be going on?
Should I try backing up to my Dropbox paid account?

Hi @Herb_Goedecke,

What does your network setup look like, can you list the model/manufacturers of the networking geear and how the HTPC and SonicTransporter are connected?

I would suggest trying to load a backup on a USB drive and then using the USB drive to restore the backup to the SonicTransporter as this doesn’t rely on the network and should be the most stable way to get it across. Can you give that a try?

The home network is based around a high speed cable modem feeding into a LUXUL ABR-5000 router and XWC-1000 wireless controller. The audio system is hard wired via CAT 6 cable.

Here is a map of the system in question:

Netgear ReadyNAS 214 (40,000 FLAC files) >> LUXUL ABR-5000 Router >> SonicTransporter i9 >> Sonore ultraRendu >> Sonore ultraDigital >> Denon AVR4520 (multi-channel DAC)

The HTPC connects directly to the Denon AVR4520 when the SonicTransporter i9/Sonore ultraRendu/ultraDigital combination are off.

Roon Core is off in the HTPC when attempting to restore Roon backup files to the STi9.

Before I try mounting a USB drive, Andrew Gillis of Small Green Computer suggested connecting the NAS directly to the STi9 using a Drive Mounter app.

Unfortunately, the Restore failed consistently once it reached 20% completion. I tried this 3 times in succession and each time the Restore failed at the same 20% threshold.

I have a 4GB USB Key that I can use for a direct backup but am wondering if I have enough storage space for my Roon backup.

Hi @Herb_Goedecke,

Thanks for providing that additional information. It’s best if we set the current network aspects aside and try performing the restore from the USB key.

I wouldn’t copy the entire backups folder to it, but rather plug it in to your old Core and specify the USB drive as the backup destination to create 1 backup. Of course, you may also want to format the drive before attempting this transfer so that there is also as much free space as possible.

Can you give that a try?

Tonight I backed up the HTPC Roon Core to a brand new 256GB 3.1 USB flash drive, which was fully formatted by me. The backup went smoothly.

However, when Restoring to the STi9, the restoration got to the 20% mark, and just as it changed to 21%, it failed. This continues to happen at the 21% point regardless of which method of backup/restore: NAS via network, NAS via direct connection, or USB key moved from device-to-device.

Clearly, there is no issue with my network. Something is rotten with the restoration process as it fails EVERY time at the 21% mark. I’ve done about a dozen backups now - in different locations - and each time the restoration fails.

Is there someway to check the integrity of the backup itself? This is the 4th day of trying to do a simple backup/restore in Roon. At this point, I have no confidence in this feature as it simply does not work.

Is there something else we can try to move my data over to the new Core?

I usually try a restore on the core I took the backup from.

Hi @Herb_Goedecke,

Have you by any chance reached out to SonicTransporter support staff regarding this issue? We haven’t had any widespread reports regarding restoring backup issues.

It might also be useful if we take a look at logs from your SonicTransporter when this behavior next occurs, can you please try to restore the backup once more and let me know the exact local time + date when it “hangs” again?

Afterwards I can enable diagnostics mode for your account and take a look for any additional clues in logs.

I’ve reached out to Andrew Gillis at SonicTransporter for help on providing the log files you need. Hope to have this to you later tonight.


You can get the logs from -> manage -> apps -> Roon

1 Like


The new Backup from the HTPC (on a USB stick)was successful but the Restore on the SonicTransporter failed again at the same exact point: 21%. The local date and time of the failure was Jan 6, 2020 at 8:28 PM.

I’ve attached a copy of the log file for your review.

Hi @Herb_Goedecke,

Thanks for sharing those screenshots. It appears you have two issues here:

  1. Your restore is failing at 01/06 20:28:33 with a System.IO Exception saying that the disk is full. There is also a message regarding an image file, but this might be due to the disk, can you please check to see how much free space you have on your SonicTransporter and ensure that you have enough space to import this backup?

  2. You appear to be getting NameResolutionFailures earlier in the log. While these shouldn’t impact the restore process, you may want to change your router’s DNS server to Google / Cloudlfare / Quad9 to minimize DNS failures as ISP-provided DNS servers are sometimes unreliable.


The STi9 is showing plenty of storage space:

Hi Noris:

I’m out of my depth on this topic. While I can see where I can change this in my Luxul Router, I have numerous devices connected to our network, including VOIP phones. I don’t know how my other devices, some with static IP’s assigned, will be affected by a change to the DNS server.

Hi @Herb_Goedecke,

Thanks for confirming the free space aspect. I have gone ahead and escalated this case over to our QA staff for closer analysis of the logs with the above error traces, I will be sure to let you know once I hear back.

I’m seeing quite a few Name Resolution Errors in the logs. While I don’t foresee any issues with VOIP services, I haven’t heard of negative behaviors in changing DNS servers to something a better one.

You may want to give it a try to clear up some of the errors, but it shouldn’t affect the backup restore process. Maybe Andrew (@agillis) can suggest a way to update the DNS servers just for the SonicTransporter?

I’m working on setting up a remote session with @Herb_Goedecke to see if i can find a space issue on that unit.

1 Like

I found the space problem there is now about 60GB available for the Roon database. Backup are still failing It’s saying there is a problem with the USB key.

Hi @Herb_Goedecke,

I spoke to QA regarding your case and it looks like there might be an issue with the backup you created from the HTPC. Have you tried to create a new backup since opening this thread or us?

I wonder if the HTPC logs report the backup as being successful, can you try creating a new backup from the HTPC to the drive, note the time you created the backup and then send the HTPC logs manually by using these instructions?

I’ve tried several new backups since I started this thread. However, the HTPC backups were never verified so this is a worthwhile effort.

I formatted the USB drive and complete a new backup tonight: Jan 13, 2020 at 7pm. The LOG files were zipped and are stored in a Dropbox folder, named “ROON”…

Noris, I am sending you the link in a separate email.

1 Like

Hi @Herb_Goedecke,

Thanks for sending those logs over, I have requested QA review them and as soon as I hear back I will be sure to let you know, thanks!

Hi @Herb_Goedecke,

I spoke to QA and they noted that according to logs, it looks like the backup procedure completed as expected. The next step here would be:

  1. Can you please confirm if you have any older backups of the HTPC core saved, possibly from when Roon was running on version 1.6?

  2. Can you please test the backup you created on the HTPC Core by using a fresh database? These steps will set your existing database aside and try to restore the backup you created for the SonicTransporter migration.

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” or “RoonServer”
  • Rename the “Roon” folder to “Roon_old” or “RoonServer” to “RoonServer_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Try restoring the backup you created from the USB flash drive
  • Let us know if the backup works/doesn’t work
  • Send a new copy of your HTPC Roon logs using the previous instructions