Restore Path to Roon Backup not Retained

Roon Core Machine

ROCK, NUC8i7BEH, Crucial 8GB Single DDR4 2400 MT/S, Transcend 128GB Nvme PCIe Gen3 X4 MTE110S M.2 SSD Solid State Drive

Networking Gear & Setup Details

Ethernet to NUC: Google WiFi, TP-Link 8 Port Gigabit Switch, Synology DS920+

Connected Audio Devices

MacBook Pro, iPhone 12, Chord MojoPoly, Chromecast Audio

Number of Tracks in Library


Description of Issue

When I need to restore Roon from my NAS-based backups, I am unable to select the drive/folder where I store my backups without deleting and then re-mapping the path. This is pretty consistent and doesn’t seem to make sense.

Here is what I see:

Here is the path:

And after I map it again, Roon displays the same path that was previously not found:

How can I restore without going through this process?

Hi @David_Weinberg thanks for reaching out about this!

Using our NAS Configuration article as a reference, can you please attempt to set up a network share once more and let us know the exact step where something doesn’t seem right?

Additionally, have you tried using a different cable when connecting the NAS?

Are other programs able to see the drive properly?

Ashley, thanks for the guidance. It appears that the mapping to my NAS backups is stable, but a new issue has emerged. After running the restore, Roon reports that I don’t have any music loaded:

I’ve seen this before, and may have eliminated it by a reboot of the NUC running ROCK, but it seems that should not be required.

Please advise, thanks!


Just tried it again-
First with a Roon Server Software restart and then with a NUC reboot. Both came back with no music loaded in Roon.

I think the problem may be resolved. I needed to map the location of my music library in order for the restore to fully execute.

I’ll monitor and circle back if I continue to have to remap, but so far all looks good.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.