RI-101 Streamer has no sound output

Thanks again, wow I thought it was limited to 192k, guess not judging by the MQA.

Looking at your earlier screenshot of DSD do you have some upsampling Or other sample rate conversion happening? Seems like it might be from the signal path and the light blue dot. If you are interested to see if that is the issue with not being able to stream DSD you might try turning off sample rate conversion in the options when you click the volume icon and then the DSP and see if anything is enabled. (Sorry, not trying time tell you stuff you probably have already messed with)

@Veneet_Gupta, thanks and please don’t worry about possibly being condescending in your advice, I am completely new to Roon and could easily have got something wrong with the DSD setup.

As far as I can tell, all DSP options are disabled and I am running at fixed volume (there is no network control of the RI-101’s volume available, only via the amp’s remote).

Neither the PC Roon nor the iOS Roon device setup options for my Vitus show anything at all about DSD, so not sure if this a Roon problem or a Vitus firmware issue, given it appears to play DSD64 natively via mconnect.

@ACvitus, thanks I appreciate it, I hate to offend anyone. I don’t know a lot but I tinker a bit. One thing that I just found I had to do for my Hegel H590 (runs office setup) was to change the dropdown on the device setup page (volume icon then gear icon then click device setup near bottom of that settings page) to enable DSD over PCM after I found that it only did DoP via USB. The Hegel isn’t Roon ready yet via Ethernet.

In my case, the “DSD Playback Strategy” drop-down doesn’t even exist. A bug in my installation of Roon?

I’ll be honest it might be a question for Vitus first or concurrently with Roon. I also sent Vitus a question about this and some other questions, such as what ESS chip they were using.

As a current owner you may have a quicker response, mine just got to Denmark today for a repair of shipping damage, change of faceplate to black and possible upgrade to the streamer.

Hello Everyone,

The Vitus RI-101 is not a Roon Ready device. The device has not been submitted to us for Roon Ready certification testing. We cannot provide support for the device until it has passed the certification testing process.

Vitus Audio has signed up for Roon Ready SDK access with the intention of becoming a Roon Ready partner, and we continue to work with them to complete the process.

For support inquiries, please reach out to the team at Vitus Audio.

-John

Core Machine (Operating system/System info/Roon build number)

Windows 7 / Roon 1.7 (505)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Vitus RI-101 with streamer DAC

Description Of Issue

The streamer DAC in the Vitus RI-101 plays DSD64 natively via the mconnect control app over UPnP. When I set up the Vitus in Roon, there is no option for configuring DSD. Is this a Roon bug or perhaps a Vitus firmware issue?

Hello @ACvitus,

Please see my post above regarding the Roon Ready feature on the Vitus RI-101:

-John

Thanks for clearing up that mystery. Any idea on a timeframe for them becoming Roon Ready?

Hello @Veneet_Gupta,

It is our policy to not give estimates for devices completing Roon Ready certification.

-John

Ok, understood, thanks

Thanks @john for clarifying. Since Roon reports that it is using RAAT in playback to my RI-101 I had assumed that meant it’s Roon Ready. Sounds like it’s only almost Roon Ready. Not an issue for me as native playback of DSD via Roon is not a priority.

If the device becomes fully certified, how does Roon pick that up? Are device profiles checked against a database each time Roon starts?

Hello @ACvitus,

When your Roon Core contacts the Roon cloud infrastructure for things like metadata updates and account checks, it will also request the latest information on Roon Ready and Roon Tested devices. When a device completes Roon Ready certification, Roon clients will automatically update the certification status of the device in the background over the course of a 24 hour window.

-John

I have been comparing the Roon signal path between my Linn streamers and my Vitus RI-101. I noticed that with Linn, although they are only “Roon Tested”, Roon knows that my Katalyst KDS is DSD capable but that my Makik DSM is not (part of the testing?). The advanced device setup options in Roon for my Linn streamers have nothing on DSD however, just like the Vitus, although unlike the Vitus, DSD transcoding is device-specific.

This brings me to an observation that concerns me: as the user, I have no control at all of whether or not Roon will transcode a given format? Am I locked out in that regard? I will continue to encourage Vitus to do what they can to move out of their uncertified Roon Ready limbo. But ideally, there would simply be an option for me in Roon’s device setup to enable formats that I know my DAC supports, even if Roon certification is not complete.

I’m beginning to understand now why my dealer is in some respects reserved about Roon.

Hello @ACvitus,

You are free to change any of the transcoding options by changing the settings in Roon’s “DSP” Sample Rate Conversion configuration.

You can get to the DSP screen in Roon by tapping on the bottom right volume widget and then tapping the “DSP” button.

The default configuration for the “Sample Rate Conversion” feature is “For Compatibility Only”, meaning that Roon will only transcode your content if it detects that the device is incapable of playing the track in its native format. If you change this to “Custom”, you have full control over all of the transcoding/conversion options for every media format that Roon supports.

-John

Thanks John, I had considered that, but I have been unable to get the method you describe to work. I had thought that under the Custom conversion options, I would find something like “Native” to enable me to stream DSD64 natively. If I select Default, all I get is the PCM transcoding. Can you can tell me where I’m going wrong, or otherwise is this perhaps something that could be fixed/made more intuitive?

Hello @ACvitus,

This is due to the fact that the Vitus is not Roon Ready certified. In its current state, the Vitus is reporting to Roon that it does not support DSD playback, so Roon will not play DSD content to the device under any circumstance. This is something that is checked during the Roon Ready certification process to ensure that all supported formats play correctly from Roon.

Roon will allow you to override the DSD settings for USB DACs, as these devices are not “certified” in the same way that Roon Ready devices are.

-John

Thanks, so you are confirming that because the RI-101 is in a Roon limbo (i.e. RAAT enabled but not DAC certified), Roon is not permitting native playback of formats I know that the Vitus supports. However, from a user perspective, the custom options ought to permit the user to enable native playback of all formats, as a safety net in the event that something goes wrong in the handshaking between Roon and the DAC. If DSD options can have an override for USB DACs, I would argue the override should be available universally.

Hello @ACvitus,

In a sense, yes. However, it should be noted that that there is a difference between “RAAT” and “Roon Ready”. RAAT can be run by end users, Roon Bridge is actually a simple application wrapper around RAAT. Roon Ready uses RAAT for audio transfer but includes many extensions that allow device manufacturers to implement native functionality like volume control and metadata display.

RAAT endpoints allow you to override the DSD settings even if they are not detected.

Roon Ready endpoints are a product of careful iteration and testing between the product manufacturer and Roon, and should not be able to be configured in a way that would break playback to the device under any circumstances.

-John

OK, will agree to disagree here. A “native” option in transcoding customisation does not exactly feel like an outlandish request, but perhaps I’m in a odd situation in terms of my hardware. In the meantime, I have Asset and Minimserver to turn to when needed, as they don’t prohibit what formats I can stream natively.