Ripping directly to Nucleus

Tried ripping directly to new Nucleus. The process seemed to function correctly and the CD was ejected after 5 or so minutes. Using the Web UI I went to the Nucleus and under CD Ripper is indicated ‘Success’ with the time and date. But the album is not showing up anywhere in the Roon app.

I also went to ‘setting’ - ‘Storage’ and selected ‘force rescan’ of the Nucleus Internal Storage. Still not showing up.

Any advise? I am completely new to the Nucleus and only somewhat familiar with Roon.

Also, I attempted to drag and drop an album from the desktop of my Windows PC and the small spinning circle just keeps spinning and the progress bar is not moving. Actually, I first dragged the album from a NAS to the desktop and it took only a few seconds.

Dumb question but are you sure you’re putting the music on the music drive in the Nucleus and not the OS drive?

Unsure. But the CD Ripping operation is virtually automatic. Apparently the Nucleus recognizes the external CD ripper when it is connected via HDMI. All one does is insert a CD in the CD ripper and it goes automatically. The ripper was active for about 4 or 5 minutes which the approximate time the manufacturer says it takes to rip CDs. Then the CD is ejected, just as the Roon documentation says will happen.

It does sound possible that the wrong drive is somehow set for saving your music files. Double check the documentation to confirm correct drive/folder is selected for this purpose.

The rips are put in data/storage/internalstorage/cd-rips. On my rock system

First check to see if the album has been successfully ripped physically by going to data/storage/internalstorage/cd-rips and see if there is a folder with the name formed from the time and date of the rip (e.g. CD-Ripped-2022-01-02--13-50-00).

Then check to see whether Roon has been able to identify the album by using the Album browser with the Sort Order set to show the most recently added albums first and see if the album is at the head of the list…

Geoff, Not sure exactly how to do the first. Where do I enter: ‘data/storage/internalstorage/cd-rips’?

On the second, I did select ‘date added’ and the CD is not at the top of the list or anywhere.

Geoff, I figured out that needed to use File Explorer and did so. The album is there. So why is it not showing in the Roon app? It doesn’t appear in either Roon running on the PC or on the Roon remote on my iPad.

Hmm - sounds as if Roon has not been able to identify the album at all. What is the album that you ripped?

‘Aja’ by Steely Dan. Regular Red Book CD. The ripped file on the Nucleus plays fine using a Windows player. I think used Groove Music on the PC.

That album is certainly known to Roon. I wonder whether the ripping process has gone successfully. If you go to Settings > Library > Skipped files - are there any entries there?

Nothing in Skipped files. The CD ripper is from Small Green Computer and is specifically certified for use with the Roon Nucleus. I spoke with their customer support and described the ripping process. They confirmed that it ripped properly and I should contact Roon. External CD ripper for sonicTransporter – Small Green Computer

Hmm. $220 for a CD-ROM drive is too rich for me. I suppose it should work OK, but… I use a simple CD-ROM drive that cost me less than $25 with my ROCK/NUC, which works perfectly well.

Three suggestions before I leave it to Support to pick this up…

  • What happens if you rip this CD a second time?
  • What happens if you rip another CD?
  • Do you have another USB CD-ROM drive that you could try with the Nucleus?

Daft question but have you gone into storage settings and made sure roon is tracking the cd rips folder. I don’t believe it does by default.

It’s probably just not scanned that folder and hasn’t shown you the results.

If you’d rather not automatically scan that folder, just open your room in a file explorer window on your computer and drag the files into a folder that roon is tracking.

I had to add the cd rips location in storage settings to get mine to import

Not a daft question, but the CD-rips folder is in the InternalStorage hierarchy, so it will be monitored by Roon.

Which normally wouldn’t be an issue but it’s possible OPs library may be pointing a step below the standard hierarchy?

Doubt it. The Nucleus adds the InternalStorage folder as the default Watched Folder…

1 Like

Geoff, So I tried another CD and the ripper did not start automatically as it did before. So, rebooted the Nucleus (pulled power plug) and reloaded the CD and it ripped immediately. Using the Nucleus web UI could see the rip in progress under ‘CD Ripper’. Once completed, both this CD and the first CD, Aja, now in ‘My Albums’.

I also was able to drag and drop an album from my desktop to the Nucleus. Took only couple of seconds. Weird. None of this worked for the past days. Thanks for the help.


Ah, I wonder if the root cause of the problem was a known bug in Roon OS that crept in some time ago:

The next time the drive stops working, try simply disconnecting then reconnecting the USB cable of the drive to the Nucleus - that has been reported to clear the bug (until the next time it occurs). If that doesn’t work, then rebooting the Nucleus will do it (as you discovered).

Thanks Geoff.