Riva Arena won’t play in Chromecast Groups after update

@support I was having good luck with multiple zones in Chromecast, but after the latest update my Riva Arena (with Chromecast built in) will no longer play in groups (though it will play if I choose it as an individual zone).

My setup is a Mac Mini as core running OS X high Sierra, a synology NAS, an Allo Audio USBridge, and multiple Chromecast through the house.

Things I’ve tried: rebooting my router, restarting Roon, disabling and enabling zones, factory reset of the Riva Arena, disabling and regrouping zones in Google Home. Any ideas?



I was able to fix this by running another (external) Chromecast through the aux input. Would much rather use the built-in option, however, if anyone has ideas on why the internal cc would create zone issues while the external works flawlessly. Tried the RIVA Wand App and messed with settings in Roon, Google Home, and Tidal but couldn’t solve.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.