ROCK Accessing NAS Often [Expected Behavior]

Just to be clear you have an OS drive AND a 1 tb storage drive ?

The ROCK system drive can’t be used for music storage. If you are using the 1 TB SSD as system drive then I’d suggest swapping it out for the smallest SSD you can get (probably 256GB) and use that as system drive. You can then repurpose the 1TB drive as internal music storage for ROCK (if the NUC has space for it) or stick it in an external USB case and hang it off the NUC. Make that 1TB SSD your active Roon library and back it up to the NAS.

It certainly does seem excessive for Roon to be accessing drives 24/7 to keep 85 tracks updated. But the simplest course as a user where there is no large library involved is to move away from using the NAS as the active library.

I think that this may be a damned if you do, damned if you don’t situation for Roon.

Some NAS users complain if SMB does not work as optimally intended and immediately report watched folder file system updates to Roon, i.e. “Watching for new files in real time” actually does not apply. For those users, forcing a rescan or waiting for a scheduled rescan is inconvenient.

Tim, on the other hand, complains if SMB does appear to work as optimally intended and immediately reports watched folder file system updates to Roon. The side effect may be, though, that Tim’s NAS never puts the HDDs to sleep.

Regardless, when a NUC running ROCK is paired with a NAS, this SMB behavior seems to be dependent upon the NAS. My NAS does not report watched folder updates in real time; a forced or scheduled rescan is required. But I am fine with that, as like Tim, I prefer that my HDDs spin down when not in use.


In the context of music stored on a NAS could someone please explain the relationship between “Automatic rescan interval” and these SMB Client Info Request packets that are sent every 5 seconds?

The two don’t appear related in as much as the “Automatic rescan interval” has no effect whatsoever on the SMB Client Info Request packets.

Also on my system the SMB Client Info Request packet causes a write action on the NAS, it’s not just a read.

I should NOT have to re-architect my network topology so that ROON will work the way I need it to. The entire purpose of storing my music on my NAS is so that I can have my music stored in a RAID configuration. I’m sure as most of you know if one of my hard drives dies I can re-construct the music that was on that hard drive from data spread across the other hard drives. THIS is why I have my music on a NAS in the first place. Roon needs to work for me not the other way around! ROON should be able to figure out that after a while (an hour) it has accomplished nothing by searching for new music and should let my NAS put my hard drives to sleep for the night and put its NUC to sleep. I have no problem at all clicking re-scan on my IPad whenever I download a new album or doing a Wake-On-Lan operation when I pick up my IPad and login to my ROON account. Oh and by the way I am using the following hard drive in my NAS. Western Digital 4TB WD Red Pro NAS Internal Hard Drive HDD - 7200 RPM, SATA 6 Gb/s, CMR, 256 MB Cache, 3.5" - WD4003FFBX

I sincerely hope that in addition to your NAS RAID, you have some form of backup?

Okay…Let’s try to stay focused here on what the original issue is. Why is ROON banging on my NAS 24 x 7. My NAS drives never go to sleep because ROCK is banging on my NAS 24 x 7.

Okay guys. I just $$$$ paid $$$$ my 1 year ROON subscription. How about we get an answer to this question from the people who would know the answer. @support

Tim, support (Noris) responded a month ago, asking you for some more information. You never provided it. What makes you think they’ll try again?


My “Re-scan” interval is set to 24 hours. I only have 88 tracks of music stored on my NAS. ROCK is constantly banging on my NAS and my hard disks never go to sleep. Just constant accesses 24 x 7. What is it doing? Why is it doing this? How do I stop it?

1 Like

I have to agree with the OP here, why is everybody so evasive he has asked a very simple question that no one has answered properly. It should not be accessing his disk all the time period in any situation, if it does then something is wrong in the way Roon works. I have several media servers on my NAS and none are doing this. Same issues apply to why it so busy over a network. It really doesn’t need to be, how often does metadata change or files ? Roon really does have some very perculiar design choices that cause a lot of issues that just get accepted and everybody laps up their reasoning. I gave up on NAS in the end due to the auto update and constant disk use but I should not have had to, the auto update I admit I have had on other software, mostly Linux based ones although not all as my new Ubuntu Plex server has no issues at all but constant access never from other software.

1 Like

Hi @TKelley ,

Thank you for confirming that the rescan interval is set to 24 hours.

We’ve gone ahead and activated diagnostics mode and what this action does is automatically upload a log set to our servers for review.

Looking over the log, we are seeing quite a few mount errors with the Core not being able to resolve the address of the NAS:

Debug: [roon/cifs] returned 1: mount error: could not resolve address for NAS3B1AF1: Unknown error

Perhaps this mounting / remounting is causing the behavior you’re seeing, can you please confirm if using an IP address instead of Hostname for the NAS helps with the issue?

Using an IP address is a more reliable method of connection, but we would also suggest that the address does not change, you can do this by specifying a Reserved IP in your router configuration for the NAS.

Please let us know the results from this change when possible, thank you.


Hi @noris

I have exactly the same problem, could you possibly activate diagnostic mode and check my logs please? I am using IP addresses (static) for the NAS access. As per post earlier I’m fairly positive this activity is caused by SMB Client Info Requests which can be captured on the network.

Thank You

Hi @Noris,
Thanks for getting back to me! I have a NetGear Router. I am using the address reservation feature on my router to reserve 2 IP addresses for my QNAP NAS and my Intel NUC which is running ROCK. My NAS is ALWAYS at ip address My ROCK is ALWAYS at ip address On my Ipad when I go to settings I have ROON CORE is at which is correct. Under settings / storage I have FOLDERS is set to \\NAS3B1AF1\TimKelley > music. Are these settings correct? Anything suspicious there? I guess I’m a little surprised that you’re seeing mount errors. I play music all the time from my IPad and it seems like everything is just groovy. My only complaint is that ROON is banging on my NAS 24x7. I do have my NAS mapped as a network drive on my windows 7 PC which is how I am downloading music tracks onto my NAS. My NAS is hardwired to the router. My Intel NUC running ROCK is hardwired to the router and my DAC is hardwired to the router. Let me know if you have any more questions. Thank you! Appreciate the help.

Hello??? @Noris

You know ROON guys…
I created this topic on February 11 and I STILL do not have an answer to my very simple question.
Today is April 9. It has been 2 months and NO answers from @support. Not really impressed with ROON’s customer support team. In a word AWFUL!!!
If someone were to ask me if I thought getting ROON was a good idea, I would have to say that it is a pretty good product but their customer support sucks. I would encourage you to call Discover credit card or T-Mobile and see what excellent customer service really is. I called ebay today and got to talk to Rachael in the phillipines. Yeah I’m sure her name was Rachael. After a few minutes of not being able to understand her I hung up the phone. I get good support from QNAP when I have NAS questions. I submit a ticket and I ALWAYS get an answer the next day which is great! I answered @noris questions 3 days ago and nothing.This blog / community platform for requesting support is a big failure and not getting the job done at all.

1 Like

ping? Anybody working in @support today? @noris

Hi @TKelley ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Based on this setup, it sounds like you are using the NAS via Hostname, can you please confirm if using the NAS via IP address has the same behavior?

The easiest way to make this change is to navigate to Roon Settings → Storage → 3-dot menu near NAS entry → Edit → Browse → Add Network Share → add NAS IP of + credentials.

Eliminating the hostname from the equation would be a valuable data point to have, as using hostname is generally less reliable than using IP Address and may be contributing towards the issue.

If the same behavior occurs on an IP-type connection, please let me know and I can request additional feedback from our QA team, but please let’s check to see if there is any difference with the IP method as this would likely be their first question when reviewing the case, thank you!

1 Like

Good morning @noris,
I followed your recommendations above and unfortunately I am seeing the same results.
Using my Ipad I set my Network share settings to use the hardcoded IP address of my NAS which is instead of my NAS’s hostname which is NAS3B1AF1. I saved my settings and rebooted my NUC/ROCK. I listened to some music for maybe an hour and then I went to sleepy time. When I woke up I ran over to my NAS like it was Christmas morning and unfortunately ROCK continues to bang on my NAS’s hard drives constantly about every 5 seconds or so. I have my NAS settings to put the hard drives to sleep after about 20 minutes of no activity. This is my goal. If I’m not playing music I expect ROON to stop banging on my NAS hard drives so that they will go to standby mode/ sleep.
I have also noticed that a second after ROCK bangs on my NAS the disk access LED on my NUC goes on.
Thanks, appreciate the help. have a good day --TIm

1 Like

Okay ROON…Its been a week since I put up the answers to your suggestions. How about working on my issue for a while? @noris. No the problem hasn’t gone away on its own,…