ROCK Backups To Mac

I’ve tried everything I can think of and just can not make Roon Rock Backups to my Mac work. Rock will not connect to my Mac SMB share. Other Macs can see it and can connect.

It either says, “There was an unexpected error: UnexpectedError” which is not very helpful or “Could not connect to share: Unauthorized”.

Is there a step by step guide I could follow?

Hi Nick,

I assume you created a folder on your Mac and then went to System Preferences > Sharing and clicked Files and added the folder to Shared Folders, clicking on the + and navigating to the folder.

Under Computer Name at the top of the Sharing window, make a note of the address just below your computer name where it says “Computers on your Local Network can access…”.

On the same Sharing window, now click Options. Make sure Share Files SMB is clicked. Also click the check box beside the name under Windows File Sharing. It will ask for a password for that Account.

Now in Roon, when adding the share, use SMB://Computer name address you noted above/the name of the Shared Folder.

Add the Username and Password using the name and password you checked from the Options window under Windows File Sharing.

See if that helps.

Cheers, Greg

1 Like

Thanks for the suggestions Greg. When I do exactly as you described, I get the error: “There was an unexpected error: UnexpectedError”

Hey Nick,

Could you give us screenshots of the Sharing and Option screens on your Mac and the Add Network Share screen in Roon?

I’ll flag @support to help you out and move the thread to Support category.

Cheers, Greg

I have ROCK backups going to different NAS systems so the options should work similarly for a MAC. I do use the NAS IP address rather than the name.


This is pretty strange. When I went to take a screen shot this morning, I discovered the Roon did a successful backup last night. This is the first time it has worked since I switched to Rock. And this is despite the error msg I got when I added the share location. And despite the fact that the Network Shares window is empty (I believe it saves the shares you add normally).

I’ll wait a few days and see if it continues to make nightly backups properly. If so, I guess we can consider this resolved, although there is clearly some bug in Roon (ie the error msg).

Question: If my Mac is asleep, will Roon wake it to make the backup?

I wouldn’t count on it…I guess you will find you soon enough.

Thanks, but that was a question for Greg or Roon support who I suspect know the actual answer. By the way, thank you for the suggestion about IP address. I appreciate it. However, it made no difference.

One more thing… I believe the difference between this time and my previous attempts to get this to work was turning on Windows File Sharing. I had not realized I’d need that, since my Rock server is running Linux. Still very strange that it gives that error msg, does not show the server as added, but still works.

This is SMB so without this all you will get is AFP shares open

Hello @Nick,

To answer your Mac asleep question, Roon would not wake your computer up to make the backup. As @wizardofoz mentioned the “Windows File Sharing” option has to be turned on, otherwise SMB wouldn’t work properly.

Can you confirm that the folder you have designated for the Roon backups actually contain the backups and are syncing properly? What is the error message you are receiving now after enabling the Windows File Sharing setting, can you please provide a screenshot? Have you restarted you Roon Core and are still seeing the same message? Please let me know when possible.


Thanks. I set my computer to auto-wake shortly before the backup time (it is a setting in the Energy Saver control panel).

I’ll respond to the rest tomorrow, after I see a second successful backup.

No new backup this morning. Will post pictures when I get home.

I’ve been very busy this week, but am still seeing an issue. Will post details over the weekend. Thanks.

1 Like

I can’t explain it, but this all works now. So, please go ahead and close this.

Thanks again for all your help @noris, @Greg, and @wizardofoz too .

Hello @Nick,

Glad to hear that everything seems to be working as expected!
If the issue resurfaces again, please just let us know and we can gladly take another look.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.