Rock boots to blank screen

I’ve been running Roon Core on a NUC6i5 for a while under Windows 10. No problems. I tried to convert the NUC to a ROCK server. I’m running the most up to date BIOS. I reset and made all of the BIOS settings exactly as suggested in the installation guide. I installed ROCK on the NUC with no problems. I got to the “RoonOS Install is complete! Please remove your USB installer and hit enter to reboot”. At that point, when I reboot the NUC all that I get is a blank screen with a flashing cursor. No keyboard input is recognized and the NUC is otherwise completely unresponsive. No Roon devices show on my network.

I’ve tried to reinstall several times. I left the NUC sitting with the flashing cursor for several hours thinking maybe it was updating something but nothing ever changed. The NUC has proven itself solid as far as hardware is concerned since I have been using it with no issues as a Windows HTPC for several years.

I’m not sure where to start resolving this. Any suggestions?

This is probably a stupid question but what does your boot device order look like? Is the drive Rock is installed on at the top of the boot list?

Yes, of course the internal SSD is the only boot drive available. It’s at the top of the boot order. But just to be sure I did the F10 boot option to force choose the drive, but same exact result.

I’ve also re-downloaded and re-imaged the USB boot with a fresh RoonOS image just in case that was corrupt the first time. Same result: Successfully installs RoonOS but then boots to blank screen with flashing cursor in upper left corner.

Also have confirmed compatibility of my SSD with the Intel chart for my NUC. Again, this was a reliable and fully functioning NUC for several years immediately prior to this ROCK installation attempt.

Assume you are using a LAN connection?

YES, wired LAN connection. The same connection that I have been using on the NUC for several years with no problem. The same LAN connection that I downloaded the Roon ROCK installation file on minutes before installing on the NUC.

Also, the NUC BIOS successfully identifies the M.2 SSD as well as the correct RAM.

No need to be quite so sarcastic to those users trying to help?

Hi @CraigK,

Just to confirm, while the NUC is in this state, can you connect to the ROCK Web UI?

Going back to the creation of the USB key, instead of using Etcher as the instructions suggest, try using Rufus. You can find it at I have found at times, Etcher messes up, so I always use Rufus.

1 Like

Thanks for the comments. Regarding connection to the ROCK Web UI, I tried that and it times out. (Fortunately my router is set to assign a fixed IP to that NUC MAC address so I knew what address to try.)
Regarding the use of Rufus, I’ll try that and let you know the result.

@ged_hickman1, apologies if anything came across as sarcastic. It certainly was not my intention and I’m not sure what you are referring to. Written communication unfortunately does not always portray the correct emotions.

Thanks for the suggestions.

Created a new boot USB with Rufus. Fresh Roon Rock ISO download, different USB key, and used Rufus. Same result. First boot to blank screen with single flashing cursor in upper left corner.

FYI the RoonOS installation is completely uneventful and proceeds completely normal. It identifies the correct M.2 SSD without any issues and the installation completes all the way through the notice about removing the boot USB key and pressing ENTER.

Really frustrating.

Hi @CraigK,

Is you BIOS up to date on the newest version? Have you enabled Legacy and not UEFI mode? I would try loading the defaults on the BIOS and make sure that the BIOS has been configured using these instructions.

Thanks @noris. Yes, BIOS was updated to most current version prior to the RoonOS installation. I think v72 for my particular NUC, dated Oct. 1, 2019. I’ve reset to BIOS defaults via F9 numerous times and performed the required changes per the guide. UEFI boot is disabled, Legacy boot enabled, disable network boot, enable USB boot, etc. M.2 slot SSD is enabled and is the first and only device in the boot order.

I’m wondering by chance if the ROCK does some kind of online self update upon first start? Could a network router DNS issue cause problems? In theory, should the ROCK NUC boot up even with the LAN cord unplugged? I run a PiHole DNS server on my network and just thinking if that could be blocking web traffic that is necessary for the ROCK NUC to properly start? I’m not seeing any blocked activity in the PiHole log that looks related to the ROCK but thought I’d check. I’m really running out of options.

I just removed the PiHole from my network so now DNS traffic is all “normal”. Same result. So it does not appear to be a DNS issue as I questioned in my above post.

Also, I noticed that the last time my NUC communicated with my router was just prior to the RoonOS installation yesterday. Ever since that, the NUC has not appeared active on the network.

M.2 sata or nvme?

It’s actually M.2 PCIe ACHI.

Hi @CraigK,

Can you let me know what is the exact model/manufacturer of the M.2 SSD? If you try to install another Linux-based operating system on the NUC, such as Ubuntu, are you presented with the same issue?

The drive is this: Samsung SM951 256GB PCIe Gen3 8Gb/s x4 M.2 80mm (AHCI Version) Solid State Drive SSD. Purchased and successfully using in the same NUC under Windows since early 2016. At that time I think NVMe drives were just coming out so the older AHCI technology was considered more compatible (as I understood it). That particular drive is exactly listed on the Intel NUC hardware compatibility list for my gen 6 unit.

I have not tried another Linux install yet.

Considering the direction this seems to be going, I’ve already ordered a newer NVMe drive that I plan to try tonight. It’s a Samsung 970 EVO Plus Series - 250GB PCIe NVMe - M.2 Internal SSD (MZ-V7S250B/AM). Probably a bit of overkill, but it was actually the least expensive Samsung M.2 PCIe NVMe SSD I found on Amazon. (I prefer Samsung SSD hardware.) I’ll flash the most current firmware to the drive and update you how that RoonOS install goes. I’m hopeful that will solve the problem!

Thanks for your support and helping to steer this in the right direction to help resolve it. (Hopefully!)