ROCK Bricked by Roon 1.8

ROCK on Intel NUC - 1.7 (build 710)
PC on Windows 10 - 1.8 (build (756)
iPad on iOS - 1.8 (build 748)


So I noticed all of the problems people were having with Roon 1.8 and decided to put off upgrading until they were solved and it was a stable release.

This morning I go to use Roon on my home setup only to find that the iOS app has updated. It’s forcing me to upgrade ROCK.

So I bite the bullet and go for it. It just sticks on download for ages. After an hour or so I’m desperate and turn off the NUC and turn it back on again. Start the upgrade again. Same result. So my home ROCK is bricked and I have no operating Roon setup. Not a happy camper. How do I fix this?

I go into my office. I start playing music from my Roon setup there. An hour later when I go to turn it off, I find the iOS app has upgraded. It now wants me to update the ROCK on the Intel NUC. I can’t stop the music. I’m not game to upgrade as I might get the same outcome as at home. What should I do?

I’ve gone from having two working Roon setups to none! Not at all happy. This is no way to roll out an update.

I just hope in Roon 1.8 you’ve finally addressed the problem of not having a guest account for Roon, That is, have a guest account where the user can’t change anything. Because if that’s not done I’m going to be an extremely unhappy camper. You seem to have too much emphasis on how the app looks, and not enough going into basic functionality. Then again, you’re already got me as a lifetime subscriber for two licenses, so maybe you don’t care.

How can I roll my iPad and/or Win 10 apps back to Roon 1.7 in the hope that then I’ll be able to access? the ROCK and start playing music again?

More information. I accessed the ROCK and restarted the Roon Server software. Then I was able to start the download again. It’s a very, very slow download. Probably because your servers are overload. Not like you couldn’t have foreseen that happening.

When the download was about 70% done my Internet connection dropped out. When it came back the software download didn’t resume. So that’s an issue you might look into.

I’ve restarted the Roon Server software and upgrade a few times. Finally it’s taken. Now to see if this upgrade to Roon 1.8 is worth the grief.

Hi @Lloyd_Borrett

I just wanted to check in and see if things are working for you still after getting things updated. If there are any issues please let us know!

Thanks Dylan. It’s working. But for me Roon 1.8 is a disaster. I use it on landscape desktop, laptop and tablet screens so the new UI is painful. Things I use constantly are now buried deep in the UI. I have my library (about 2400 CDs) and don’t use streaming services. Functionality I had previously has gone. The new features overlook my use case. I’ve reported elsewhere problems and bugs I’ve discovered with Roon 1.8. What I’m really annoyed about is that Roon 1.8 doesn’t address problems or add features me and others have been requesting for years. If I could I’d happily go back to Roon 1.7 on my two lifetime licences. For me, Roon 1.8 is lots of pain for no gain.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.