ROCK Browsing is slow, fails, or crashes client, Tidal/Qobuz tracks fail to load "the track is not currently available" [Resolved - DNS update]

Roon Core Machine

  • ROCK on Intel NUC NUC8i5BEH
  • 8th Generation Intel Core i5 8259U processor
  • 16GB RAM
  • 500GB SSD
  • 2TB Internal Storage

I have also tried:

  • Using my PC as a Core - Not ideal for obvious reasons
  • Installing Windows on the CORE - Unstable due to updates
  • Install Ubuntu on the CORE - High degree of tinkering required, not suitable for WAF

Networking Gear & Setup Details

  • 1GB Fiber Internet Connection connected to ASUS RT-AC5300
  • Netgear Gigabit Switches
  • Core and most endpoint/speakers are hard-wired.

Connected Audio Devices

  • KEF LS50 Wireless IIs
  • RME ADI-2 DAC via USB
  • Schitt Modi DAC via RPI4 running Ropiee
  • Various Sonos speakers via Airplay
  • Core connected via HDMI to HDFury Vertex2 which Connects to Sonos ARC HT
  • Chromecast for Display only

Library Size

  • 10K in local storage on ROCK
  • 15K total including Tidal/Qobuz

Description of Issues

  1. Browsing Artist collections fails on the first time usually with “Discography unavailable”, re- search and hitting Discography will bring it up on second, third, or fourth tries. The same thing for just loading an album, I can get tracks to play but eventually the music just stops…
  2. Adding Album from Versions will fail or I have to try multiple times - as you can see it shows greyed out (just clicked) but then does not add to my collection. I have to try multiple times.
  3. Constant crashes on the client, sometimes improved by restarting Roon Server Software or NUC entirely
  4. Tracks from Qobuz/Tidal fail to load with “the track is not currently available”, eventually resulting in no music playing. I can’t reliably play a whole Album from Tidal/Qobuz or a playlist.
  5. Chromecast Display fails to load unless I recently restart Roon Server

I have not experienced the same issues when running Windows or Ubuntu. I expected ROCK would be an improvement in stability and performance. If Ubuntu or Windows10 will perform better? I can make the time investment to make that work…

Please help @support, this is a frustrating experience.

I have the same Problem not loading Albums from Qobuz and no Live Radio search.
Greats Remo from Switzerland

While i’m not support, i’m sure they also would like to know what you are using as a controller?
And, i can assure you that you are not getting the ROCK experience! :slight_smile:

@Support @dylan - I use an iPad Pro 12.9 running iOS 14.6 as my primary controller, sometimes my iPhone or PC.

Thanks @Mikael_Ollars!

Hi @Henry_Svendblad

Sorry to hear about the trouble here! My initial suspicion based on the types of issues you’re seeing is that there is some type of networking issue at play here. Much of the content that seems to not be working for you rely heavily on network communication with our servers.

What’s strange, though, is that this only seems to affect ROCK and not Windows or Ubuntu.

I’d like to take a look at logs — Would you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

Thanks @dylan. As a CTO, I suspected network issues but I can tell you my home network is very solid when it comes to networking. Also, when I had Windows and Ubuntu on that box I had no issues. That’s not to say that something is off with the NIC driver or something else.

Here is the link to the logs Dropbox - - Simplify your life

Thanks in advance for your help!

@dylan @support - Could this be DNS related? COX has been having some issues in the past week or so….

I suspected DNS issues. Ran a DNS benchmark, resulting in better PRI/SEC DNS for my provider/DHCP settings. I looked at the logs and the number of “warn” entries was almost nothing? Could it be as simple as that? I noticed you can only configure one DNS for ROCK. Might be good to allow for more than one?

I’ll continue to monitor but so far fingers crossed this appears to be working better with regards to lag.

I have finde the Problem. I have changed on my provider to surf protect and on this moment i have this Problem. So i have deactivated the surf protect from my Provider and now Roon works fine.


@support @dylan Please mark this as resolved. I reviewed the log files and saw many warnings around name resolution. I ran a DNS benchmark and noted the primary ROCK DNS was throwing some warnings. Updated to a new Primary DNS and so far it has been smooth sailing. A few delays, but browsing albums, artists, and songs is now fast and what I was experiencing in Windows and Ubuntu but now with the benefits of an appliance. Anyone having these issues check your DNS performance. I use something called DNS Benchmark. Thank you.

1 Like

Thanks for the update, Henry – I’m glad you were able to get this resolved!


This topic was automatically closed after 12 hours. New replies are no longer allowed.