ROCK build 1159, Remote 1148

I appear to have incompatible versions of Roon. The Mac OS works fine. But my iPads, iPhones etc do not. Removing Roon from the remotes and reinstalling does not impact it. Guessing this is a simple fix so input is appreciated and perhaps associated with the core having an early access version. I gather that others have a similar problem.

Appreciate anyone’s assistance. Thank you.

New apps just popped up on iOS AppStore for me under TestFlight. Which you need if your on early access build.

Thank you. I downloaded Test Flight app, but there was no path forward. Certain I am missinng something obvious.

You need to get the test flight links setup.
Follow the early access FAQ

Academic question…if I deleted ROCK and began from scratch, would I still have the beta version, guessing so.

You chose to install I guess

Just follow instructions here.


Thank you. Apparently, I need an early access code. If I had one during ARC’s testing, I did not keep a copy.

Thanks, this worked for me :pray:

You don’t need a code just follow the instructions. If you have installed TestFlight click on the TestFlight links it will add them and you then install them.

Ugh. Ran into the same problem as OP, but my remote is a Mac OS. Here is the error page:

This occurred after I naively opened Settings/About, which triggered a new core installation, which triggered a window offering me to Update All, which I did. Upon reopen, I am stuck at the above window.

How do I get beyond this window? Thanks.

I solved it by following the recommendation of @CrystalGipsy

I appreciate his re-directing me.

Download TESTFLIGHT from the Apple Store and follow these instructions. They are overly long instructions, but it does work.

Thx, but do the Testflight instructions work on MacOS? I have TF installed on iOS units, none on (this) MacOS unit.

Update: just accessed my MacOS TF installation. It says “Tester Removed” under the Roon Remote icon.

Not sure what any of this means, but I’m not feeling welcome :frowning:

It worked for me and all remotes (I understand you use your Mac as a remote).

The goal is have your MAC on the same early access build, and you do that through TestFlight.

I think Test Flight is only for phone and tablet apps.

See my post, recently updated.

Here is what I get from a newly installed TF on my MacOS:

So, it would seem I’m approved to early access core releases, but not remote releases.

Maybe here…see downloads near bottom.


TestFlight is for iOS remotes and ARC only. There are no testflight apps for MacOS. You download and install the earlyaccess installer from the links provided in the the early access programme for the Mac and other OS apps.

1 Like

I would think that indicates that you have been moved from a beta tester to the current release.

To me that means your Mac should now be compatible.

@CrystalGipsy and @Jim_F may have thoughts. My problem was slightly different. I could access Roon on my Mac but not my iOS devices.

Well, with respect, I went to Apple Apps site on my MacOS and successfully loaded TF. I like you thought it was iOS only, but it seems there is a MacOS versionas well.

My apologies, @7NoteScale , I highjacked your thread. Bowing out now to create a new one.

So sorry. (UPDATE, FIXED!)

1 Like