Rock - Cannot stream from Tidal, only from local drives, after 1.5 update [Resolved - Router firmware update]

For the past year, I have successfully using the Roon Rock on an Intel NUC. I stream Tidal and play local files on a USB drive connected to the NUC. My playback device is a PS Audio Directstream DAC. I have a hardwired ethernet connection from the NUC to my router, and from the Direcstream DAC to the router.

Last evening I received the pop up notification though the Roon Control on our iPad indicating a device update was available, which was the 1.5 upgrade (I am not sure why I just now received the notification since 1.5 has been out for quite a while - head scratcher). The update completed successfully, but now I cannot stream from Tidal, I can only play my local files on the USB drive. My Tidal playlists show up as normal, and I can search songs on Tidal, but when I try to play the song, the progress bar at the bottom of the Roon Control just bounces back and forth, then skips a track and try the next track and so on. Eventually, I received an error message stating too many transport errors so playback was halted.

I have completed several troubleshooting steps so far.

  1. Power cycled the NUC several times - no effect.
  2. Power cycled my router (TP-Link AC1900 dual band gigabit router) - no effect.
  3. All wireless devices connected to the router have internet access.
  4. Reinstalled the Rock OS (1.0 build 158) through the Web interface on Roon - no effect. Shows “OK”
  5. Restarted the Roon Server Software (1.5 build 323) - no effect. Shows “OK”.
  6. Reset the database & settings through the Web Interface on Roon - no effect. Shows “OK”. I had to re-enter my Roon Account and Tidal Account settings, which worked just fined.
  7. I switched my Core from the Rock to my iMac, and I can stream from Tidal just fine and playback through the Directstream (my iMac is only connected through wireless). Everything behaves normally as it did with the Roon Rock before the 1.5 update.

I do not know what else to try to get the Roon Rock streaming from Tidal, as it did before the 1.5 update. Please help.

Thanks for the detailed report, @Dennis_Vanda_Laloge!

May I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are your DNS settings on ROCK any different than on your Mac? If you use Google DNS do you see any improvements?



As a bit of a long shot, I updated the firmware on my TP-Link AC1900 router (I have had the router about 2 years). After the firmware update, everything returned back to normal and I could stream Tidal again through the ROCK. It appears my problem might be solved…

Thank you for the response back.



Thank you for the update @Dennis_Vanda_Laloge!

I’m glad to hear you’re up and running now. If anything else comes up or the issue returns always feel free to reach out.

Happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.