ROCK connection issue after restart

I am using a NUC7i7BNH as the core service with ROCK.
So far, it is working okay, but I did run into some hiccups
Few days ago, I need to turn off the NUC (by pressing on the power button on the NUC) to rewire the AC/DC adapter.
When I turn back on the NUC, all my Roon remote apps (both Mac and iPhone) were having a hard time to connect to the NUC. The app keep trying to find and connect to the ROCK Core.
Meanwhile, I can successfully access the webUI on the NUC and I see no issue on the WebUI, ROCK started correctly and running.
I have to turn off the NUC, restart, and tried the same process for 3x before the Roon App on my phone or my Mac able to connect to the NUC again, any suggestion?

Connection: Gigabit Ethernet
Library and Audio Analysis database were built and finished.
Once it is connected, the Core and the Remote app runs normally.

Hi @Anthony_Chan ---- Thank you for the report and sharing this observation you’ve made with us. Sorry to hear of the troubles.

I wanted to touch base and see how the remotes have been “holding up” since you created this post. Are things stable or in the same state? Let me know.

If further assistance is required just drop a flag for support (ie @support) and a member of the team will be glad to help.


Hi Eric @support:

The problem still exist.
When the ROCK CORE needs to be turn off, the remote seems like having trouble connecting to it when the Core restarts.
I need to restart the ROCK CORE NUC 2-3 times in order for the remote app to successfully discovers the Core again.
I cannot say the is totally reproduce-able every time I turn of the NUC, but I would say 4 out of 5 times when I need to turn off the NUC, the remote will have problem connect to it.

Right now, the workaround is to keep rebooting the NUC until the remote app recognize it.
I did try connecting my Mac with LAN, so everything is connected with physical wire connection (bypassing the WiFi) and that doesn’t really help.

The thing is, I am able to connect to the WebUI, that means the Core is started normally, I would assume.


What happens if you just wait for a few minutes after a reboot - do the remotes connect then? I ask because I’ve noticed that when Remotes lose connection with ROCK, it can take a few minutes for the Core to be fully initialised and back on the network, even though the ROCK web page remains fully available throughout.

Hi @Geoff_Coupe @support

Thanks for your reply.
Last time I waited 5 minutes and eventually I need to perform a “cold” reboot 2x to get the Core be available to the remote app.
The “reboot” which worked was able to be discovered by the remote app right away.
To me, it seems like either it didn’t initialized or it did, when it didn’t (for most of the time), a reboot it needed. Almost like rolling a dice. :joy:

I will try again tonight and report back.
If I experience the problem again, I will wait for full 60 minutes and see if the remote app pick it up.


Hi @Anthony_Chan ---- Thank you for the follow up and the continued feedback.

I would like to grab a set of remote logs from one of your devices, as we have been conducting an investigation into this behavior. We have been asking users who are experiencing this issue with their remote devices, to fill out the survey found in the provided link and to also provide us with remote logs after the issue has been reproduced. This seems like a good opportunity to collect this data from you :wink:

I will be contacting you momentarily via PM with instructions on how to send us over logs from one of your remotes.


Will do when the problem shows again
I turned off everything, my NAS, my Core, and the Devialet Expert 200 this morning.
I will run a full “switch on” test from cold tonight and report back.
If symptom comes back, I will send you the log files. Will wait for your PM for instruction. :slight_smile:

1 Like

A post was split to a new topic: After restarting ROCK I must remove and then re-mount my storage device to get the server to launch

Hi Eric:

Please close this inquiry for now.
I wasn’t able to reproduce again.

I suspect it has to do with the network connectivity of my local network.

I will let you know if it comes back again.

Thanks for your support


1 Like