Rock Data directory cannot be found

NUC ROCK brank new 10 i7 16GB and 128GB

I was able to get Rock on it…updated itself to 1.8.
Then I am able to see on ipad…windows got client up as well.

But windows does not see data drive. Nothing.

None of them work. All come up empty. One PC in the house was able to see it, but then ID and password came up…did guest guest…nothing.

Tried to do network share.
tried network drive

Nothing. just does not see

I was able to put in thumb drive and got some songs to apprear…but I have no codecs… cannot see data drive.

no idea what it could be. Rock server and PC are both wired into the same router in same room.

You need to use the format: //

clearly shows windows \Rock\data

Using that format just brings up browser saying not found.

Something else is wrong. either my pc is blocking or rock has error. But it adds files from usb…so I think that data directory is ok. is it not open for sharing? did I miss a step?

With ROCK, the OS drive cannot be used to store music. You would need to add a second internal drive, or, an external drive to store music. The data you see is just a share, so you can get to the logs, or add the codec.

When you add a 2nd drive or an external drive, then, they will show up under
\\ROCK\Data\Storage which is where you would copy your music. (keep in mind you need 2 \\ at the beginning, so \\ROCK under file explorer should work)

I was refering to the // not the direction of the slash. Windows tends to use the backslash (\) but both will work in this instance since ROCK is a Linux distribution.

As Daniel says, ROCK should also work. You may need to append local to the end, i.e. rock.local. The Data folder will give you access to the Codecs folder.

nope did not work . Getting another PC to try. but any other suggestions would be great. everything else seems to be working

Start a powershell window, enter NET USE and show us what you get, also make sure your using 2 slashes in the front

that did not work either.

I have 2 laptops from my work and 1 kids PC. None worked. kids (he is 21) so no idea what he has on that PC… work ones may have something blocking…so I grabbed a friends old windows 7 PC…that worked like a champ. So it was PC issues. upgrading that to windows 10…but I was able to get codec on the Rock. Thanks for the tips.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.