ROCK database backup fails with System.IO.IOException: Input/output error

Roon Core Machine

ROVK 1.8 (Build 898) running on a Intel NUC10FNH

Networking Gear & Setup Details

Gigabit Ethernet, CIsco SG350-10

Connected Audio Devices


Number of Tracks in Library

25,000 tracks

Description of Issue

Database Backup fail; error message in RoonServer_log.txt:

02/07 16:06:27 Debug: [broker/filebrowser/volumeshare] Use dispose, id: \\\bkp
02/07 16:06:27 Info: [broker/filebrowser/volumeshare] Volume's removable changed: True
02/07 16:06:27 Warn: [broker/backups] unexpected error doing backup on FileBrowser.Entry: \\, bkp : \RoonBackups: System.IO.IOException: Input/output error
   at System.IO.FileStream.CheckFileCall(Int64 result, Boolean ignoreNotSupported)
   at System.IO.FileStream.ReadNative(Span`1 buffer)
   at System.IO.FileStream.FillReadBufferForReadByte()
   at System.IO.FileStream.ReadByte()
   at Sooloos.Broker.BackupCompute.<>c__DisplayClass12_1.<ComputeBackupFiles>b__1(String file, Boolean needs_copy)
   at Sooloos.Broker.BackupCompute.<>c__DisplayClass12_0.<ComputeBackupFiles>b__0()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.ExecutionContext.RunFromThreadPoolDispatchLoop(Thread threadPoolThread, ExecutionContext executionContext, ContextCallback callback, Object state)
--- End of stack trace from previous location ---
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot, Thread threadPoolThread)
--- End of stack trace from previous location ---
   at Sooloos.Broker.BackupCompute.ComputeBackupFiles(List`1 filesinmanifest, List`1 filestoupload, HashSet`1 latesthashes, Canceler canceler)
   at Sooloos.Broker.BackupDestination`1.StartBackup(Entry location, Nullable`1 numberofbackupskept, Boolean auto)
02/07 16:06:27 Debug: [broker/backups] on done, auto: False

Tried different CIFS shares (from a Windows Server, a Mac OS system, Ubuntu, and also Dropbox); always the same error.

How to enable diagnostics to find the root cause of the failure?

Does anyone have any idea how to debug the backup failure?
How to enable more verbose diagnostic messages?

Hi @pwo ,

Since you are on ROCK, enabling flags is a bit trickier than other operating systems, it has to be done remotley by our QA team. Are you able to add watched folders under Roon Settings → Storage or does that give you an error as well?

What happens if you try to host the Roon Core on Windows / Mac, does that same backup share also give an error?

I could add a subfolder of my backup share as a watched folder just fine. No error message.

Hosting the Roon Core on a Windows or Mac OS system, I can try in couple of days (real work keeps me a little busy right now).


I installed an Ubuntu 21.10 test system, installed the roon server and was able to perform a backup without errors on the same backup share that gives me an error when used from the roon ROCK server.

I guess we need to debug on the ROCK server itself.

Connected a local USB drive, backup to the local USB drive also fails!

have you performed a reinstall from the GUI? NOT a Reset…a REINSTALL

Yes, I did try the reinstall, not change, backup still failing

Hi @pwo ,

I’ve activated diagnostics on your ROCK and I am seeing signs of your M2 SSD starting to fail, I suspect this is what is causing the I/O errors. Can you try to replace your SSD with another one and see if that helps?

1 Like

The delivery of the replacement SSD is delayed, hopefully I can test in a few days.


Made a fresh install on a new M2 SSD, so far two successful backups.

Unfortunately, not having a recent backup, lost some information (playlists, liked songs, etc);

Next time I’ll act faster to minimize the loss of meta information.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.