ROCK downgrade failure : remote on legacy but core waits 2.0 update

Roon Core Machine

ROCK on NUC i5
Roon 1.8 build 1105

Networking Gear & Setup Details

Synology RT2600 router
Roon remote on Windows 10 1.8 build 1126

Connected Audio Devices

Windows 10 speakers

Description of Issue

I followed the instructions to downgrade my Intel NUC Core to 1.8 version :

roon file inside the branches folder contains production1x as explained in the faq steps.
When I launch my remote, it detects my cre and keep saying it needs an update :

I click on the connect button and see this :

The RoonServer logs confirms that the core is still on the production branch not the production1x branch as it want to update to 2.0 build 1128 :

09/26 16:46:44 Debug: [base/updater] Update response: priority=major
09/26 16:46:44 Debug: [base/updater] Update response: updateurl=
09/26 16:46:44 Debug: [base/updater] Update response: machineversion=200001128
09/26 16:46:44 Debug: [base/updater] Update response: displayversion=2.0 (build 1128) production
09/26 16:46:44 Debug: [base/updater] Update response: branch=production
09/26 16:46:44 Debug: [base/updater] Update response: type=roon
09/26 16:46:44 Debug: [base/updater] Update response: changelog=
09/26 16:46:44 Debug: [appupdater] Update is available: 2.0 (build 1128) production, Major
09/26 16:46:44 Trace: [remoting/remotingserverv2] SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='Available' HasChangeLog=False AvailableVersion={ MachineValue=200001128 DisplayValue='2.0 (build 1128) production' Branch='production' } CurrentVersion={ MachineValue=100801105 DisplayValue='1.8 (build 1105) stable' Branch='stable' } }

Waiting for @support to have instructions to use Roon (again).

Hi @AdZero,

Your screenshot shows that you are running 1.8 but not 1.8 legacy as required. Can you try again using the legacy download links as provided in the link you supplied in your initial post? This is the section you need to look at:

RoonOS Core 1.8 Legacy (Nucleus / ROCK):

Hi @Wes ,

as explained I downloaded the file and followed the instructions for ROCK :

1. Go to the /Data/ share (instructions) and create a folder called branches
2. Download the following file: roon_1-8 (It should be named roon_1-8 and saved with no file extension) 
3. Copy the file into the branches folder previously created
4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)
5. In the Web Interface, click "Reinstall" under Operating System

As I understand your instructions, after the reinstall step, the core should be on the legacy branch but it is not despite the content of the roon file.

Hi @AdZero,

To clarify, you did in fact navigate to the WebUI and selected re-install? Did it give you any change in your version or otherwise indicate that it was re-installing?



Yes, I connected to the Rock WebUI and clicked on the Reinstall button under the Operating System section. I even did twice but nothing changes.
For whatever reason I thought that Roon Server must be shutdown before. I think I was confused by the 1.8>2.0 instuctions just below. Sorry for that.

I tried once again but this time it worked after I unauthorized my account on the core :


Iā€™m glad to hear this. Our apologies for the difficulty this has caused. Thank you for your understanding and enjoy the music.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.