Rock failing to connect to shared folder hosted on windows10 server[fixed by increasing IRPStackSize value]

I am in the process of setting up Roon on a ROCK server (NUC5I5RYK). Installation process of Roon itself was very smooth (thanks), but when I try to connect it to network share where my music is stored it fails.

I have my music on a disk connected to a windows 10 server that I have shared and made availalble on my home network. I can connect to this shared disk from other windows 10 servers as well as my mac mini, but when I try to get my ROCK server to connect to it it fails with error message “There was an unexpected error: UnexpectedError”

(if I try to connect the ROCK to my QNAP NAS then it seems to work, but this is not the solution I want to run going forward).

Hello @borgen,
Can you be more specific about the issue:

  1. What file path are you using when trying to add network watched folder ? (you can just make a screenshot of the ‘Add Network Share’ window when it fails).

  2. What is the file system of the drive you are trying to add ?

The disk hosting the music is a 1TB external disk on a win10 Pro machine. The disk has been shared to the local network and can be accessed/ mounted on another win10 machine and mac mini (latest OSX version).

I then try to configure the ROCK from scratch (not using backup/ restore) and start with adding network share.

I have tried with both \server\share and smb://server/share, I have rebooted both server and ROCK, I have tried with both IP address and hostname, I have tried with different user accounts. I am kind of running out of ideas as what to try next and would appreciate both practical and morale support :wink:

Can you please take a screenshot of the ‘General’ tab of the Toshiba (D:) Properties ?

Thanks for additional info, @borgen.

At this point we would like to check Roon logs. I’ve contacted you via PM with instructions how to send them

With the help of Vova and Roon support we were able to fix this issue. It turned out to be a windows10 issue with IRPStackSize parameter settings (this seems to be a quite common issue). The fix for me was to create a registry entry for IRPStackSize and set it to 30 and then reboot.