Rock fails to reboot when connected to external drive

Roon Rock (on Intel NUC) fails to reboot if connected to USB external hard drive. [Error message on Web UI: Device has not rebooted, try manual reboot or contact support]. The reboot also fails when a manual start-up is attempted.

This occurs only if an external USB drive is connected to the NUC when reboot or manual start is attempted. If the external USB drive is disconnected, a reboot or start up is successful. The drive can then be connected after reboot and the music library on the external drive functions as expected.

Details of my setup is as follows: -

  • Intel NUC 8i7BEH (Turin Fanless) with 8GB RAM and 256GB M2 SSD. Running Roon Rock ver 1.7 (Build 667). Connected via ethernet cable. Remote is on an Apple iPhone running IOS 14.2 Roon ver 1.7 (build 610). [NB: This problem also existed on prior versions of Rock].

  • Operating System: Roon ver 1.0 (build 227).

  • External USB Drive: Only one HDD connected. Toshiba Canvio Basics HDTB420 with 2TB HDD storage. I initially connected this HDD with the default NTFS format out of the box and encountered this reboot problem. Subsequently reformatted HDD to exFAT but it has not solved this reboot problem. I have also tried connecting HDD to different USB ports on the NUC.

  • Library details: The external drive contains a library of ripped CDs and downloaded WAV files approx. 60GB. i.e. Only 2% of capacity utilised. Streaming Tidal and Qubos.

  • Audio Connection: Rock NUC to Schiit Yggdrasil Unison USB dac to HiFi system.

Any assistance to resolve this will be much appreciated.

Thanks,

The nuc bios might be configured to use the usb drive as a boot device. Check and disable if it is.

2 Likes

Thank you for this. I will try this over the weekend and post outcome. Thks again.

2 Likes

Hi @arjibarji,

Hope that setting change has helped with the issue, but if you need further assistance, just let us know!