ROCK has suddenly begun crashing every 2 min

Roon Core Machine

NUC 7i7 running RoonOS 1.0 Build 227
Roon 1.8 Build 918

Networking Gear & Setup Details

Cable modem with ORBI WIFI + 2 ORBI satellites. ROCK is hardwired to ORBI which is hardwired to router. External Storage drive plugged into NUC.

Connected Audio Devices

1 Macbook via CoreAudio
2 TVs via Chromecast streaming
3 Squeezebox via Squeezebox streaming
1 pair BlueOS via airplay
1 pair Sonos One SL via airplay

Number of Tracks in Library


Description of Issue

I’ve had a Roon Rock up and running w/o issue for at least 2 yrs. This past weekend I added a stereo pair of Sonos One SL speakers and things seemed fine. The next day I was unable to play music for more than a minute or two without it stopping. The control app kept losing the server. I looked in the RoonServer folder on the NUC and saw a new log file created approx every 2 minutes. The NUC itself is staying up because I can stay connected to it via a remote shell. I’ve tried disabling the new Sonos speakers but it makes no difference.

Additional - after reading other posts, I’ve tried disabling the connected storage and also the Qobuz service. And to clarify…it crashes every couple minutes whether I’m playing music or not.

Ken is the Rock crashing or just the Roon app?
Can you see from the web page that the uptime for Rock is still going up?

I had a bad NVME boot drive in a Nuc based rock and it crashed constantly.

Thanks for responding, Michael,

OS (RoonOS)
Version 1.0 (build 227) stable
Running 22 hours, 18 minutes, 48 seconds.
(Last time I manually restarted thee Nuc)

Roon Database & Settings
99% of 227 GB available.

Roon Server Software
Not Running

(Upon restart)
Roon Server Software
Version 1.8 (build 918) stable
Running 0 minutes, 4 seconds.

Ken do you reboot your Rock every night?

Could be a corrupt database or Disk (though I am just an end user and not Roon support).

Check that uptime on a regular basis, to see what it is at. Do you have a regular backup job, as running one will tell you if you’re database has corruption.
The database is stored on a different Disk to your Music.

Hey @Ken_Bowen,

Thank you so much for choosing to get in touch when this started happening. We’re so sorry :pensive: . We’re also grateful that you’ve engaged with our community of subscribers. And, special thanks to you, @Michael_Harris :pray:.

If after the restart and detaching the storage devfice the issue persists, could you please:

  • make sure you have a backup of your database (this is very important :warning:)
  • upload the entire database folder as a zip folder here
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Many thanks :pray:

1 Like

Renaming and regenerating the RoonServer folder did the trick! It’s back up and running. I just lost my date added on the albums as they all got reimported today…I can certainly live with that. Thanks much to you (and Michael). As soon as the compress completes, I’ll upload the database zip as requested. Maybe it can help figure out what happened.


Thanks so much for going through the steps, @Ken_Bowen! I’m really glad that you are up and running.

We’re grateful for the database. It’s now with our team for investigation. We’ll follow up with any relevant findings.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.