Rock - HDMI dropouts

Today I built a NUC and installed Rock (latest update installed) on it. The NUC is a 7i7BNH, with 120GB M2 SSD and 8GB RAM. The NUC is directly connected to a Denon AVR-4400x through HDMI. In Roon the HDMI connection is on the HDA Intel PCH HDMI 0.

When playing songs, the music repeatedly stops, as if the HDMI connection fails. This is reflected on the display of the AVR. I have tried multiple HDMI cables and multiple HDMI inputs on the AVR, all with the same result. Roon shows a processing speed of 20x+. The NUC also has an ethernet connection to my LAN. No monitor is connected/switched on when listening to roon using the AVR.

Any ideas on what may cause the music dropouts?

Edit: I might have to look into this firmware update:

Bad news is that it will require a Windows installation first…

Hi @Harmen ---- Thank you for the report and sharing this observation you have made with us. The feedback is very appreciated!

We have many ROCK users who are making use of an HDMI connection to their various devices without issues. While the mentioned firmware update couldn’t hurt, I am not certain that this will fix the issue being experienced.

I understand from your report that you have tried a few different HDMI cables to determine if the connection between the NUC and the AVR is the problem. Have you by chance tried connecting the NUC via HDMI to another device? Say for example to your TV?


Knowledge Base: Troubleshooting Audio Dropouts

Hi @Eric,

Your response is much appreciated. I connected the NUC directly to the TV, which indeed appeared to work fine. Similarly, everything appears to be fine when the NUC is connected to the Denon AVR, with the TV switched on as well (showing the brief Rock status text).

The hickups start when I switch off the tv, which I recognise from when I used my macbook pro connected through hdmi with the Denon AVR. That also did not work, unless I switched on the TV as well. So, it seems the issue lies with how the Denon AVR deals with a combined audio/video input over hdmi when no monitor is active to show the video input.

Unless you have heard of this Denon issue before and know of a solution, it seems I am left with the option to either switch on my tv or use a separate audio-only endpoint to connect to the AVR. Anyway, it does not seem to be a specific Roon/Rock issue.

Hi @Harmen ----- Thank you for the follow up and sharing the observations you made during the proposed troubleshooting exercise. The continued insight is very appreciated and my apologies for the delayed response.

Being as ROCK is working as expected when playing to your TV via HDMI, my gut feeling is that there is something going on here with the AVR itself. I did some searching around google and came up with the following:

Denon AVR-4400x: Manual

Have you tried adjusting any of the mentioned settings in the “HDMI pass through” section, or perhaps has Denon support been able to provide any insight into these settings?


Hi @Eric,

Disabling passthrough on the avr has done the trick it seems. I am going to monitor it for a few more days, but I have not had any issues since. AV tech can be a wonderful world :wink:


I see this exact problem with the Nucleus+ on Marantz AV8802a. Turned off all HDMI pass through settings to see if that helps…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.