ROCK install: Keyboard is disabled when booting from USB. Cannot enter command to install

Roon Core Machine

Nucleus (Rev B) w/Samsung 860 Pro 512 GB SSD

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue


After replacing a failed M.2 SSD, I’m attempting a USB flash ROCK install on my Nucleus. I believe I have my BIOS settings correct (boot priorities, fast boot is off, secure boot is off) but when I boot to the install menu (see photo), the keyboard becomes non-functional. I’m quite stuck. Any ideas why this is happening?..and/or what I can try next? Thank you so much.

You might check the USB configuration in the BIOS, it should under “Devices>USB”
Yours may be slightly different than the model I looked into, so YMMV,
From Intel site:

A post was merged into an existing topic: Help needed with Nucleus recovery:

Thank you. The BIOS settings remain at default and the keyboard functions properly with the BIOS interface.

The issue is - when I boot from the UEFI USB OS Bootloader, the keyboard is then somehow disabled. Thus I’m unable to enter the command to initiate the ROCK OS install.

My understanding is that the keyboard would function properly in the BIOS regardless of the settings. Which makes sense as you would not be able to change anything if the USB got disabled when in the BIOS setup.

However, when the BIOS hands the system over to the OS (in this case ROCK) the settings would then take affect. I was making sure that you checked the settings to make sure that the port you are connecting to is not disabled when the BIOS hands over the system. If the “default” is set so that the port you are connecting to gets disabled, then it would exhibit what you are seeing. Setting a USB port to be disabled by default, I would think, is not a desirable thing if that is what is happening… ?? Were any of them disabled? If they are all enabled, then we need to look elsewhere.

Have you tried all or any of the other USB ports? I remember sometime back that it was recommended to use the rear USB ports during setup. But that was a long time ago that I read that so take it with a grain of salt.

1 Like

Here’s a screenshot of the default USB settings.

This unit is a Nucleus, so there are only two USB ports. I use one for the USB drive and the other for the keyboard.

Thank you for helping!

That all looks fine to me.
Have you tried swapping the usb stick and keyboard to the other USB ports?
Do you have a different keyboard you could try?

I running out of ideas here.

Just to make sure, have you tried starting the Nucleus without the thumb drive inserted to see what happens with the keyboard?

When I have issues like this, I use a wired keyboard. Are you using a wireless KB?


The Nucleus has only two USB ports, so no opportunity to reconfigure.

The keyboard is perfectly functional except for when I boot to the USB ROCK OS bootloader. The bootloader (as I understand it) is a program called GRUB. I’ve found reports of other having this issue on the GRUB support forum. I suspect this may be a worthwhile lead (GRUB bug) but I’m quite out of my element, so will have to wait and hope for advice/ideas from others more knowledgeable.

I don’t have another keyboard (Mac user) but I can order one if needed.

Thanks for the help!

1 Like

Thank you, everyone, for the advice and suggestions. As suggested, my Asus keyboard was the issue (keyboard would become disabled when booting from USB). A new keyboard worked perfectly.


Hey @brad_thompson,

I am awaiting access to a resource that can trigger the update from ROCK to Nucleus. Bear with us. We’ll get it done as soon as possible.


1 Like

Thanks again for all your help, Wes. Is there anything I can do to help facilitate the Nucleus OS/ROCK update?

Hey @brad_thompson,

I’m sorry for the delay in getting back to you. I was out last week.

It looks like your Nucleus was successfully updated remotely.

How are things?


Hi, Wes.

Yes, I believe the recent update did the trick. I now show Nucleus on the control panel instead of Roon Optimized Core Kit.

Performance has been perfect.

Thanks again for all the support.

1 Like

Loving it!

Enjoy the music, @brad_thompson. I know I am. My current listening selection:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.