Rock Install Loop Error

I seem to be caught in an install error loop. I built a new NUC and succeeded in installing Rock. I transferred my SSD from my Nucleus, hooked everything up and booted up. I was prompted for a backup which I restored successfully. Then I get a screen telling me the connection failed. Here’s the error screen.

Here’s the Rock’s setup page showing everything seems to be okay.

How do I get past this error? I’ve rebooted and reinstalled numerous times and I’m out of ideas.

Hi David, I had this once before on a fresh install. I had a problem trying to connect to the core via Windows, then I tried logging in via my phone App. I chose the option to connect to another core location and sign in which gave me access again via the App. You may also get the option to “Unauthorize” as it still sees you as logged in to the old core, it’s okay to action this.

A few minutes later I shut down the Windows app, gave it a minute then restarted, I was then able to access the core.

Hopefully this will work for you but it may be a different issue. Worth a try.

What happens if you click the “Configure Roon OS Devices on your network” at the bottom?

I tried to log in with my phone and I get the “Uh oh, somethings not right”. Problem is I have no idea what’s not right. Is it possible my backups are corrupted? Do I need the Nucleus on the network and running to enable the new NUC? I took the Nucleus off because I needed the music drive to put in the NUC.

The “Configure Roon OS Devices” simply takes you to the web interface for the device. As shown by my first post, everything seems in order for the NUC.

Oh OK, I forgot.

No. If it still considered your Roon license to be assigned to the Nucleus, you should see a button “unauthorize” that would transfer it from the Nucleus to the NUC

It’s possible but seems not likely that it would cause this issue. The whole thing looks like a network issue of some kind to me, but I have no idea what it could be as after all you can connect in the browser. Did you change anything at all in the network setup apart from switching the Nucleus to the NUC? Can you tell us more about the rest of your network setup? (What router, any managed switches, etc?)

The NUC is hardwired to a Netgear Orbi router through a Netgear unmanaged switch. It’s about as simple as it gets. I did just notice that when I open Roon and I get prompted to select my core, when I select the NUC everything works fine. I restore the backup and it seems to work fine. Then, when I relaunch as directed the error message says “Last seen 5 sec ago”. The NUC is a NUC11TNHi7. Is it possible the network drivers aren’t working?

Yeah the network seems straightforward enough and after all it worked before. It’s all very weird.

It’s possible that the network card has issues, I guess. The NUC is on the approved list, so surely we can expect that the drivers are in RoonOS. However, someone just had to perform an (apparently) firmware update for the NIC in a new NUC12 before it worked.

The reason I’m confused is it seems to work fine it just won’t connect to Roon. The timing error message suggests to me that it’s all good until I restore the backup.

I’m confused by the same thing :slight_smile:

I’d guess either a hardware problem (perhaps with with one of the SSDs) or a problem with the backup.

If you don’t restore - but just login and let roon scan your media drive - does it work ok?

Without media present - and something in the database a SSD or hardware problem might not show itself.

If that all works fine - then it may be some sort of backup corruption (although I thought current versions of roon validate the backup process). That would be one for Roon support (then can check logs etc).

I assume that you are waiting long enough for Roon to start up completely? On my ROCK/NUC, it takes Roon 3 minutes to come online fully after Roon OS (and the web page) is running. This is with 60K+ tracks in the library.

I finally got it working. Bad news is I still don’t know what was wrong. After getting completely frustrated I decided to login to Roon without the restore and bingo, everything was there. Believe it or not, I then proceeded to restore my latest backup and as you might guess, no connection error. So I got out of Roon, went back in and logged in again and everything was fine. I have no clue what that means. Anyway, I’m back in business so thanks for everyone’s input. It helps to know you’re not alone when struggling with these things. Oh and btw, the new NUC is much more responsive than the old Nucleus Rev 1. So it was worth it.


I find that weird. My 10i5 NUC with ROCK goes from off to fully functional in about 30 seconds or so with 41K tracks

May be because of my particular mix of local and Qobuz albums, may be because of the age of my library (5 years), may be because of something else entirely. Doesn’t bother me, because I’ve come to expect it.

Sure, no problem if it’s fine, I just found it surprisingly long

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.