ROCK installation issue[solved]

Hi All,


I have a NUC5i5RYK on which I successfully updated the bios to version 0365.2017. Then I have downloaded the image file and successfully installed it on an USB stick via Etcher.
The bios configuration has been done as well as per recommendation found in the section
“ROCK: Updating and Configuring BIOS On Your NUC”.

Finally I plugged the USB stick and reboot the NUC taking care to boot on the USB first but nothing happens. The ROCK installation does not start. I tried to download again the image file and redo the operations on a second USB stick but it does not work.

I don’t know what to do…If you have any suggestion, it would be very welcomed.

Have you set the boot to Legacy rather than UEFI?

Yey I have disabled UEFI and set the boot to legacy

can you describe what is happening?

after the bios screen that says Intel NUC goes away, what are you doing and what are you seeing? maybe a short video taken with your cell phone would tell us whats going on better.

basic stuff out of the way:

  1. are you pressing down F10 to boot from usb?
  2. do you see an errors or a blank screen?

I will have another try tomorrow. I may have missed something…normally it should go straitforward

I just tried again by redoing the USB key with a fresh image. The NUC seems starting on the USB key but stop immediately.
It just display a message starting by “Linux…” but disappear almost immediately and I don’t have enough time to read it.
Then I have no video signal sent to my TV screen.

On the USB key, I have the following file/folder:
a folder “identity” which is empty
a file “roon.tar.bz2” 42’749 KB

Nothing else…

Ah… maybe you are not flashing the roon image that need to be flashed from the factory reset file per the instructions here?

To install ROCK, you will first need to download the factory reset disk image from here.

  1. Writing to a USB flash drive:
    Windows / Mac OS / Linux
    Plug in your USB flash drive (it must be larger than the factory reset image size – 1GB is more than enough).
    Download and install Etcher from
    Start Etcher
    From the Etcher application interface, select your .img.gz file as “the image”
    From the Etcher application interface, select your USB flash drive as “the drive”
    Click on “Flash!”

It is what I did from the beginning.
I formatted again my USB stick in FAT32 not FAT(Default) and flash it again. Now it seems working…
It’s a bit strange…Let see if it goes successfully to the end of the install.

Sorry my original post was a bit incorrect…the above details are correct and the USB should contain those files. Are you sure the Bios Updated successfully?

I have a NUC7i7 and this worked fine but the bios update was a bit tricky…what are the specs on the USB stick?

Hi Wizardofoz,
The bios is updated correctly (I checked the version number and it is correct)
Finally the Rock installation started and went until “asking for removing the USB key and pressing a key to reboot”
And then after rebooting I got below message just displayed a fraction of second. I was obliged to film my TV screen in order to have time to see the message. (Sorry for the poor quality)

I re-installed again Rock on the NUC and get confirmation message that everything is correct and asked for reboot but unfortunately I still have the same issue. The Rock installation does not continue after 1st reboot.

do you have the video of that bootup (you seem to have posted a screenshot of the video)?

it looks like it installed fine and is booting up now…

It seems booting up…but not sure as my TV screen immediately display “No video input” and then nothing else.
Would It be possible that everything goes fine but Rock does not support HDMI output therefore I don’t see anything on the TV screen?

If everything went fine you should see the ROCK as a Roon Core Connection option in the remote app

I should see it as well in my network?

You should but I don’t know what your network looks like or what clients you are using

Finally by installing Roon Remote on my laptop, I was able to see Rock on the network on to connect it. Indeed it was my TV screen turn it off too quickly which let me think that the installation was not completely finished as I was not seeing the IP address.
I will now continue the configuration…
Thanks all for your help

1 Like

so it was working all along? you just hadn’t run Roon/RoonRemote to speak to the ROCK/RoonServer?

After the first installation, I’m not sure it was working as Rock did not appear in my network, but after the second tentative, it was working.
The fact that I did not see the IP address at the end of the installation let me think that something went wrong.