ROCK issues. Found source of problems


Writing this in case it can be of use to other ROCK users…

Over the last couple of months I found some weird behaviour running roon on an NUC10i3. Here goes…

When prompted to update roon after a new software release I clicked ‘Update all’ from my PC screen.

At this point ROCK downloaded but failed to automatically restart. When using the web interface to ROCK the system was shown as not running. I tried to restart from the web menu and could see that roon tried to start but failed after 4-5 seconds. Tried to start a couple of times but no luck.

After a hard reset on the NUC, and subsequent power on everything appeared to get back to normal.

At the next roon software update the above repeated itself. This had me a bit worried as I will not be home to hard reset at any given roon update occasion. This could of course cause issues if I wanted to run ARC from a holiday home…

At a later time I went to check how my roon backups were doing only to find out that no backups had successfully run since sometime in december 2022. One backup was in progress but not getting anywhere. This was a backup with its storage location on a 32GB SANdisk USB stick connected directly to the ROCK. All other backups failed as ‘another backup is already in progress’.

After a bit of trial and error it was clear that the USB stick was bricked. Trying to restart roon from the ROCK web interface showed the same behaviour as mentioned above. Removing the stick allowed a software restart. Inserting it again led to the same stuck behavious as before.

At this point I replaced the USB stick and backups to this, and the other, destinations work again.

So, to summarise. It’s not always obvious what is causing an issue. I’m happy it was possible to get back to normal before there was an issue with the database as the most recent backups got progressively older as time passed by. Perhaps it would be good to get some sort of warning message after repeated backup failures? I must confess checking the backup status is not something done with any regularity…

Thanks for reading this far… :slight_smile:


When I have a backup fail, I get a red warning triangle with an exclamation mark, top right.

1 Like

Yes same here, and even after checking it (going in the menu to look which back-up is failing), the warning triangle will remain at the top right, and repeat the next day (I think), right?

I think so, IIRC

Thanks. Either I have missed this warning (quite possible but not likely after so many days of no new backups…) or perhaps there is no warning if a backup doesn’t start because there is another backup already in progress (one that never finishes…).

Anyway, I’m up and running OK again now…

Yeah, maybe

That is an interesting failure mode, thanks for reporting it. I always get a red triangle as described above if a backup cannot run (due to music playing usually). I get it recently however when the NAS it backs up to is powered off. The error message accompanying this is ‘selected drive is full’ or similar, which is clearly incorrect.

I also get that ‘drive full’ error message when a Windows 11 laptop, that is one of my backup locations, has powered down at the time of the roon backup.

I could be wrong, but I don’t believe I get that aforemantioned triangle warning when these backup errors occur. Or perhaps I’m not looking in the right place…

This prompted me to look at my back-ups and I found that one of them has been failed since Jan 11th. The PC that it backs up to was off. I did not get the triangle error. I only see the red text below the back up when I go to “view” on the settings/backups page in Roon that says “selected drive is full”. Which is incorrect, same as what @Anthony_B said above.

Actually, just checking now and I don’t have the red triangle but I do have a missed backup when I view the backups page due to ‘selected drive is full’. So I may be mistaken. Surely by design it should always show a red triangle when a backup is missed?

Fresh example of ‘drive is full’ error. No warning triangle to be seen anywhere…


Drive isn’t full. Laptop is in sleep mode.

Do not backup to USB ‘sticks.’ ROCK tends to eat those for breakfast (been there, done that). Best to backup to a NAS, an attached HD, or the cloud.

2 posts were split to a new topic: External HD but after Jan 22, ROCK no longer can see IT