Rock just stopped playing and restarted by itself?

Hi @dylan - ok I’ve only got 4gb in there as at the time everyone seemed to say that was enough, so I’ve ordered another 4Gb and will report back. Likely my library has grown quite a lot since end of 2019 when I bought the NUC?

Hi @dylan - ok the RAM has been upgraded to 8Gb but unfortunately after 22 hours the server just reset again 23:44 my time. I only have a modest library, mostly Qobuz, doesn’t seem likely it would need more than 8Gb.

1 Like

It seems Roon can run fine and perform meta updates ok with no problem, except when music is playing… so @support why not restrict all that activity to when the server is idle? Also, can you see from the logs if the RAM is ok and 8Gb, the NUC is headless so I have no idea if all is well - wouldn’t it be a good idea to have more diagnostic info available on the Roon Rock web page to help in these situations?

I can see this isn’t ever going to get any attention now, but to keep the thread alive for others who might search for this issue it just did it again. I reinstalled Roon ROCK a few weeks ago and haven’t had an issue since (although I’ve taken to turning the NUC off each night, not sure if that helps?) but at 22:33 or thereabouts the server reset itself again. It’s obvious this only happens when Roon Server does something, updates something, and that something is always late at night, usually around 10:30 to 11:30pm BST. This really ought to be a doddle to track down if the logs do their job… but I haven’t been asked for them by @support, maybe they have access to my system from their end now?

Anyway, every time it happens, I’ll post here, could end up being a long thread by the time it gets archived! I think it really is time Roon invested in more support staff and started a proper ticket system - they really can’t just rely on peer support on a forum forever… can they?

I suppose the next tactic might be replying to every advertorial and re-tweeted post on Twitter with negative comments about the support and stability issues… seems a bit mean, but if it brings about change then maybe future folk who buy into the software might benefit?

Hi Tim,
I feel your pain, having suffered from a ‘ROCK Server restarting itself’ issue myself (but every 3 days). A restoration of the DB from a backup did not fix the issue but starting over with a completely new DB did. Have you tried this yet? You will lose all your customisations etc but it is worth a try. You can always restore the last backup if it does not fix the issue.

If it still restarts after that, Roon should recheck your logs to verify that the memory issue has gone away.

Thanks @Anthony_Bates and it is an option I suppose, but a somewhat extreme one as I have probably customised all manner of things for certain albums, especially release dates and titles and such. Also many artists have alternative pics I felt were more in keeping with the era that artist was most active (pictures of bands as old men today when the 60’s is their era irritate me! :joy:).

I might as well just go back to Qobuz and its basic list of favourites… :woozy_face:

I’m actually beginning to think Roon is far too complex an application, I don’t mean in user interface I mean in it’s technical back end. It is far too busy on the network all the time, it is not at all efficient in the way it uses network bandwidth and I am sure it could be massively faster and more robust if these underlying operations were addressed.

I’m also becoming convinced that somehow the RAAT protocol or maybe the server messes up and the sound isn’t right, seems to get an edge and a halo of distortion. I’ve noticed this if it is left on for days without a reboot, after a reset things sound cleaner somehow? But that’s computer Audio isn’t it,

To be honest, all these issues are making me long for Qobuz Connect and a streamer I can just stream to direct from Qobuz Mac desktop (now quite a nice interface with more linked metadata arriving) - at present the beta version of Qobuz UPNP streaming sees my Lumin and connects ok but nothing plays, no sound comes out even though the progress bar moves along… shame as that would be a great fallback when Roon plays up. The Lumin does have an app but it’s clunky and not very intuitive to use, ok for queueing up a track and playing it, but that’s about it.

Agreed it is an extreme measure but one that will cost you nothing but time to try. You can always restore from the backup. Once your DB gets corrupted in some manner there is only one way to fix it…

This will at least rule out a corrupt DB issue. When you start with a new DB, do not enable any music folders either, working just from online sources. That will also rule out a failing music storage HD too if the problem persists.

My take on your issue is that when Roon tries to update the DB with metadata it is accessing Core DB, Network and of course RAM. So issue is either:
Failing SSD
RAM issue (you need to confirm it is still not running out with 8GB and that NUC BIOS detects 8GB)
Corrupt DB - starting over with a new one is the only fix
Network issues - (I have no experience with mesh systems but Roon is picky…)

The first three are hardware and most likely to cause a server restart I guess but the last should not (error message and log entry more likely).

See also: Roon Remote connection failed TP-Link Deco M4
But if it is a network issue, you should be having other issues at other times.
Roon really do need to look at your logs again.

1 Like
  1. Please confirm you are using the original power supply for the NUC, not a third party LPS.

  2. Please tell me the exact hardware model of the SSD boot drive you are using for ROCK.

  3. Do you have another computer that you can temporarily use as Roon Core?

1 Like

Hi Peter @wklie, thanks for joining in! Yes Im using the power supply that came with the NUC (NUC515MYHE), the boot drive is a 120Gb Kingston SSD A400 M.2 2280. I do have a MacBook Air and I have set this up as a Roon core again (that’s what I used to use before the NUC) mostly to make sure the backup I made before reinstalling ROCK on the NUC was good! I did play a few tracks with it but the interface is so very slow I sort of gave up…

The problem is I can go lots of nights with no problem (after the reinstall anyway) so testing solutions takes ages, I’ve already installed extra RAM, but I’m not ready to go replacing the SSD unless Roon can determine that is the problem for the logs?

Please find a day when you don’t listen to music, and run this memory test (free edition) for no less than 24 hours:

You may need to adjust BIOS option for UEFI before you can boot it, and revert it to go back to ROCK.

If you are unable to boot the above no matter what, there is another alternative:
https://www.memtest.org/

1 Like

Thanks Peter - I am short of USB sticks so I’ve just ordered another for tomorrow so I’ll give the memory test a go and report back here. I’ll try and live without music for a whole day! Actually I could still listen with Lumin app I suppose, but I use Roon for a bit of EQ and balance/distance adjustment for my speakers… don’t think there is a balance option in the app is there?

While waiting for the USB stick, please change router DNS to 8.8.8.8 then reboot the whole network, especially the Roon Core.

Lumin does not have a balance setting for now. Even if it may be done in the future, that will be for analog output on some models only. It cannot be done to Digital outputs.

Hi @Tim_Woodward

Apologies for the lack of response here. Our QA team has been investigating some similar behavior and we are currently working on a solution that I believe might help here.

To confirm if this is the case, I’d like to take another look at logs. The next time this happens can you send logs over to us right after and make a note of the time it happened? We’ll take a look and confirm. Thanks!

1 Like

Hi @dylan - I have found the instructions on locating the logs, when this happens again should I post the sharing link here?

Best to send the link in a Private Message to Dylan - click on his avatar and then click on the Message button to create a PM to him.

3 Likes

Even though I’m not sure if Roon Build 795 contains the aforementioned solution, please update it and see if it helps.

If you have done the memory test, I’d like to know the results.

Hi Peter - I have updated to 795 but even before then I haven’t had a reset for the 9 days since I last reported here. I did completely reinstall the ROCK software from a new USB stick download so maybe that helped? At the moment I’m running-in a new DAC so I haven’t had a chance to perform the memory test - it arrived a few days ago just as the new USB memory stick arrived and I was preparing to have a go! I’ll let you know when I’ve done it, thanks very much for your input…

PS. Just as an aside, I know you have advised elsewhere for the USB connection to be removed when using other outputs for the U1 Mini, but if I can’t get at the back of the Lumin very easily in my rack, would it the same if I removed the USB cable form the DAC end only? I’m eager to try both the AES/EBU out and the Coax spdif to hear the difference on my new Denafrips Pontus II :blush:

If a reinstallation helped, you had a corrupt database or dying SSD.

Since you’ve had reinstalled it, you may defer the memory test until the problem comes up again.

Yes, same.

1 Like