ROCK - Latest Image - Failed to Partion Disk - Disk Had ROCK 1.0 Installed

This is driving me nuts - I’ve been fighting this problem for the past two hours.

I have an Intel NUC6i5SYH that’s had ROCK 1.0 installed on it for almost 2 years. The NUC contains:

256 GB Samsung SSD (2.5")

First I battled getting the NUC to boot from USB. It turned out the USB stick was formatted with a GPT partition table - not MBR and the BIOS in the NUC was still in Legacy Boot mode from ROCK 1.0.

I resolved those issues by enabling UEFI in the BIOS and reformatting the USB stick from another computer running Ubuntu 22.04.

Once I boot from the USB stick, I follow the prompts to install ROCK, then choose the Samsung SSD drive. The following is displayed after a second or two:

ERROR: Failed to partition disk

There was a critical failure during installation

Please press ENTER to reboot and try again, or contact support at

Please note the above ERROR message and your hardware configuration when contacting support


I thought perhaps there was an issue with the fact that an existing Roon installation on the Samsung SSD, so I created a bootable Ubuntu installation USB stick. I ran fdisk /dev/sda and wiped all existing partitions off the drive, then tried again.

And I’m still getting the same error message. What’s ROCK complaining about (and not providing a useful error message at that)?

What did you use to create the ROCK installation on the USB stick?

I tried:

  • Balena Etcher (Windows and Linux)
  • Rufus (Windows)
  • And good ole’ dd on Linux

I’ve also tried a couple of different USB sticks - one USB 2.0 and the other USB 3.0 - just for the sake of ruling out the USB sticks are OK.

I even tried using diskpart.exe and fdisk to completely clean any previous filesystems and boot sectors off the USB sticks.

I’m not sure what the MD5 checksums are on the original downloads - they don’t seem to be listed anywhere. I have the following for the compressed and uncompressed:

26fb50b5f34a788d81479cb7bbf2b822 roonbox-linuxx64-nuc4-usb-factoryreset.img.gz

26d5088191f150f435d331ab2975abe8 roonbox-linuxx64-nuc4-usb-factoryreset-100000254.img


I gave up. My intent was to install ROCK, then review/backup my library, wipe the disks, then install Ubuntu Server + Roon Server.

Since all of my music was on 2x external USB drives, I disconnected the drives, installed Ubuntu Server 22.04, then installed Roon Server, mounted the USB drives, and I’m back in business.

Now I can run a proper backup utility (restic) and automatically backup to AWS Glacier storage. The idea of having to copy my media via CIFS to another computer before I could back it up didn’t make sense. ROCK was too restrictive.

I wish I could have helped with troubleshooting the issue, but I needed to move on.

Thanks for the willingness to help!